DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-13-2009, 07:04 PM
kccoln
Guest
 
Posts: n/a
Default Cold Engine knock 95 ram 5.2 liter

I have a 1995 Dodge ram 1500 with the 5.2 liter.It has 145000 miles.It runs excellent,carries good oil pressure.I changed oil in it and developed a cold engine knock at idle mainly and the knock completely vanishes after truck gets to normal operating temp.The knock sounds to me like it is coming from the intake area.The engine purrs like a kitten.Powerful.It runs as good cold as warm but has the knock when cold.It did not do this until I changed oil.I used pennz 10w-30 high mileage oil.It is a knock and not a tick.It doesnt sound like its going to throw a rod loud,but very noticable.The previous owner ran havoline 10w-30.I cant figure it out.Has anyone had the same problem?Should I switch back to havoline?Can anyone tell me what it is?Im pretty sure its not piston slap,lifter maybe but I thought they were more of a tick and not a knock.Could it be something with the intake or injectors?Please help.Im going crazy trying to figure it out.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 02-14-2009, 10:53 PM
black beauty's Avatar
black beauty black beauty is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2008
Location: Missoula, Montana
Age: 25
Posts: 270
Gender: Male
Vehicle: 2000 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:23
black beauty is on a distinguished road
Default

you can try switching back to havoline it can't hurt any, i'm a mobil 1 guy and i have never had a problem with it yet with my 2000 5.9L and it just cranked over 120,000.

what grade of gas do you use?
you can try going up a grade that might help. or you can use fuel injector cleaner or octane booster i've heard that works sometimes.

but if i were you i would try and go back to the old havoline first, i have heard some really wierd stories about motor oil and engines so try that first and get back to me when you do i would like to know what happens.
Reply With Quote
  #3  
Old 02-14-2009, 11:15 PM
kccoln
Guest
 
Posts: n/a
Default

Hi

I just bought the havoline today and Im going to change it tomorrow.I also bought a purolator filter this time.I hear they are the best for retaining the oil in the engine without dumping it back into the pan.I have used seafoam in the tank and oil,and no results yet.As far as gas,I have always used the cheap stuff and never had any problems.I could try some premium,I guess.Im going to try the havoline,if that doesnt work Im going to try this stuff called Zmax.If that doesnt work,I may pull the pan and check the pump and screen for blockage.perhaps the pump is weak,not getting proper lubrication to the top of engine at startup.If I pull the pan,Im hoping I do not see something i do not want to,if you know what I mean.Ill let you know if the havoline is a fix.Thanks for your input.I appreciate it.
Reply With Quote
  #4  
Old 02-17-2009, 05:03 PM
kccoln
Guest
 
Posts: n/a
Default Cold engine knock

Switched back to Havoline.There wasnt any change.There werent any foreign materials in the oil.It looked great no grit no grime, and no metal.One thing I did notice was during warm up the engine surged a couple of times and each time the knock went away for a split second.This happened once before I switched oils and twice in a row the next day after I switched.

Any ideas with the new symptoms?Im about ready to take the plunge and take it to a mechanic.Its out of my league.

Anybody know anything about this? Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:11 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum