DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-01-2009, 02:53 AM
chrismcr6 chrismcr6 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2009
Posts: 7
Gender: Male
Rep Power: 0
Rep:12
chrismcr6 is on a distinguished road
Default Erratic Idle and dying problems on 97' 1500 5.9L

Hi all,
I have a 97' Dodge Ram 1500 4x4 with a 5.9L and about 104K.
Lately my idle when I come to a complete stop will LOOP or surge. It goes up and down, up and down until I start to go(within about 1k RPMS). It only does this when I stop at a light or w/e. It does not do this when I start the truck, and sometimes It Never does it. Its really erratic and non consistent. It has died on me a few times after the idle drops too low. Also, when/before I get to a stop, if I put the truck into nuetral and then roll to a stop, this problem rarely happens???

here is what I have tried/changed so far without any luck:
IACV-Idle air control valve.
New air filter,
check all vaccum lines, didnt find any aparent leaks. Tightned all loose connections.
What else should I check, it is really starting to bother me.

Thank you for all your help
Reply With Quote
Sponsored links
  #2  
Old 04-02-2009, 10:39 PM
chrismcr6 chrismcr6 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2009
Posts: 7
Gender: Male
Rep Power: 0
Rep:12
chrismcr6 is on a distinguished road
Default

anyone???????
Reply With Quote
  #3  
Old 04-03-2009, 10:06 PM
fd1007 fd1007 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2009
Posts: 8
Gender: Not Specified
Rep Power: 0
Rep:10
fd1007 is on a distinguished road
Default Erratic Idle

We had a similar issue with our durango and it's 4.7 a while back.

I took it to a buddy who is a mechanic and he cleaned the heck out of the throttlebody and all of the parts attached.

Problem was solved.
Reply With Quote
  #4  
Old 04-03-2009, 10:08 PM
Burkdadhemi's Avatar
Burkdadhemi Burkdadhemi is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2008
Location: Alabama
Age: 54
Posts: 555
Gender: Male
Vehicle: 2008 Dodge Ram 1500 4X4
Trim Level: Laramie
Color: Brilliant Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:100
Burkdadhemi will become famous soon enoughBurkdadhemi will become famous soon enough
Default

Hows your Fuel pressure, just sound like a fuel issue.
__________________


MagnaFlow
Airaid Jr Kit
D/S Predator
Amsoil
Reply With Quote
  #5  
Old 04-05-2009, 12:58 AM
ph3nom3non03's Avatar
ph3nom3non03 ph3nom3non03 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2008
Location: davenport, iowa
Age: 28
Posts: 154
Gender: Male
Vehicle: 2000 Dodge Ram 1500 4x4
Trim Level: SLT LARAMIE
Color: Intense Blue Pearl
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:11
ph3nom3non03 is on a distinguished road
Default

im on this same subject in mechanical problems and solutions the post is in dier need of advice im trying to figure this out myself but when i do i will definitly be posting on this im going to be redoing my intake gasket and checking the pan that lays in the intake but read up on it and see where your standing
Reply With Quote
  #6  
Old 09-16-2011, 02:14 PM
sonocativo's Avatar
sonocativo sonocativo is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: Rehabbing (a house that is )
Posts: 1,554
Gender: Male
Vehicle: 1997 Dodge Ram 1500 4x4 club
Trim Level: Laramie
Color: Electric Blue
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 4
Rep:210
sonocativo has a spectacular aura aboutsonocativo has a spectacular aura aboutsonocativo has a spectacular aura about
Default

TPS will cause that as well. Cheap fix.
__________________
Mike
Reply With Quote
  #7  
Old 01-26-2012, 07:01 PM
indyjoker's Avatar
indyjoker indyjoker is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: indiana
Age: 37
Posts: 1
Gender: Male
Vehicle: 2001 ram 1500 4x4
Trim Level: slt
Color: grey
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
indyjoker is on a distinguished road
Default

i had about the same problem check the crank position sensor,fixed mine right up
Reply With Quote
  #8  
Old 01-26-2012, 10:10 PM
selfserve217 selfserve217 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: PA
Posts: 12
Gender: Male
Vehicle: 1994 Dodge Ram 1500
Trim Level: Laramie SLT
Color: Green
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
selfserve217 is on a distinguished road
Default

I would agree with sonocavito.....check the tps. You should be able to use a multimeter to test the voltage to the sensor as well as what the sensor puts out itself. There are 3 stages you run the test in.....1 for signal voltage (at the connector), one for sensor voltage at closed throttle, and one for sensor voltage at WOT (key on engine off of course). Don't quite remember what the voltage ranges are at the moment, but I can get them to you if you need them. that is a simple way to check whether or not the TPS is on the fritz. I'm not certain about the Crank sensor, as the readings it takes is very imperative to the trucks functionality. It's one of those parts that if it goes bad, the truck simply will not run. Let me know how it turns out.

Last edited by selfserve217; 01-26-2012 at 10:21 PM.
Reply With Quote
  #9  
Old 01-26-2012, 10:32 PM
Screamintrashcan Screamintrashcan is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2011
Location: Alston, MI (BRRrrr)The shores of Gitche Gume
Age: 56
Posts: 457
Gender: Male
Vehicle: 95 & 98 1500 Ram 4x4s
Trim Level: SLT & Sport
Color: 1 Blk,1 Red
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:36
Screamintrashcan is on a distinguished road
Default

Got me on this one, all I can think of is this, the tps screwing up will generally cause the tranny to really like to run in overdrive, and not downshift when the motor is mashed. Good luck, and please come back to this site when you figure it out, and publicize!!!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:55 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum