DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-23-2009, 10:26 AM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default No Power When You Put It To The Floor

I have a 00 Dodge Ram 1500 5.9(360) it was my step dads old work truck and it barely got any attention so i thought that i would try to fix it up. But this is just one of many problems, When you put it to the floor the motor like bogs out and almost stalls out on me. So at my school we looked at the spark plugs and re-gaped them cause i have to wait for my next pay to get new ones but that still didnt help and ever scene we re-gaped the plugs now the motor really shakes around like it has a wild cam it haha ( i wish ) but any ideas what it could be??

Logan.
Reply With Quote
Sponsored links
  #2  
Old 06-23-2009, 10:33 AM
chithead's Avatar
chithead chithead is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2008
Location: Landis, NC
Age: 33
Posts: 12,930
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: R/T Baby!!!
Color: Bright White
Rep Power: 16
Rep:2078
chithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond repute
Default

I would double check the spark plug wires. Make sure they are in the correct firing order. Then maybe inspect the distributor cap and rotor, look for any shorts or splits in the wires.
Reply With Quote
  #3  
Old 06-23-2009, 10:41 AM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default

Okay i'll try that thanks you
Reply With Quote
  #4  
Old 06-23-2009, 10:58 AM
ljonesj ljonesj is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2009
Location: Kingsport, TN
Age: 34
Posts: 111
Gender: Male
Vehicle: 2005 Dodge Ram Quad 1500
Trim Level: ST
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:14
ljonesj is on a distinguished road
Default

and replace fuel filter in tank and along the frame
Reply With Quote
  #5  
Old 06-23-2009, 11:13 AM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default

is that the black box on the side of the frame? And where would i get one just like a local parts store?
Reply With Quote
  #6  
Old 06-23-2009, 11:27 AM
ljonesj ljonesj is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2009
Location: Kingsport, TN
Age: 34
Posts: 111
Gender: Male
Vehicle: 2005 Dodge Ram Quad 1500
Trim Level: ST
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:14
ljonesj is on a distinguished road
Default

that may be part of the evap u see the fuel filter along the frame should be near the tank and yeah u can get it at the parts store and its round
Reply With Quote
  #7  
Old 06-23-2009, 12:28 PM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default

ok thanks for the help ill see if this stuff works
Reply With Quote
  #8  
Old 06-23-2009, 05:54 PM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default

so my buddy just stoped by and he thinks that it might be the injectors. do u guys think he is right ?
Reply With Quote
  #9  
Old 06-23-2009, 11:21 PM
chithead's Avatar
chithead chithead is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2008
Location: Landis, NC
Age: 33
Posts: 12,930
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: R/T Baby!!!
Color: Bright White
Rep Power: 16
Rep:2078
chithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond repute
Default

Might check the wiring on the injectors, make sure there is no buildup or any splits causing a short against the block.
Reply With Quote
  #10  
Old 06-27-2009, 06:07 PM
dodgeislife99 dodgeislife99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2009
Location: Owen Sound, Ontario, Canada
Age: 21
Posts: 11
Gender: Male
Vehicle: 2000 Dodge Ram 1500 SLT 5.9
Rep Power: 0
Rep:10
dodgeislife99 is on a distinguished road
Default

so i got new wires and plugs and it idles really low now like in between 600-750 rpm is there like and idle control that i could adjust on it ?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:35 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum