DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8


Notices

Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!
Factory Spec: 5.7-liter HEMI® V8 engine - 390 horsepower, 407 lb-ft of torque.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-30-2009, 10:01 AM
mrbrace's Avatar
mrbrace mrbrace is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2009
Age: 28
Posts: 12
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
mrbrace is on a distinguished road
Default 4 Wheel Drive Problem

So yesterday I was hauling some sod over to my brother in laws house (leftovers from soding my yard). I had to go through some weeks in the field behind his house so it was easier to carry them onto his yard. I put the truck into four wheel drive and off i went.

I didn't go fast at all and was just moving through the weeds without any problems. We unload the sod and drive the truck back through the weeds. After getting out of the field I put the truck back into 2H and for some reason it felt like the brakes were on (like I was trying to powerbrake). All four of the tires were squealing and the truck was hesitating. I parked it, put the bottom 4WD lever into neutral to see if it would stop, couldnt get it out of neutral once it was in there. I tried and tried pulling it back into 2H and it wouldnt go. I finally put the truck in drive and eased it into 2H only to hear a loud clunck (yes I had my foot on the brake).

The truck was still squealing the tires as if I was trying to power brake and it was hesitating so bad. I finally stomped on the gas and it broke free into 2H. Has anyone has this issue? Sensor? Linkage?

I am taking it in on Tuesday to the mechanic, just wanted to see if anyone had this issue.

TIA
Matt
__________________
03' Dodge RAM 1500 4X4 5.7L HEMI | Magnaflow | K&N Intake | 2" Leveling Kit
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:55 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum