Left Turn Signal Blinking Fast / Right OK - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 09-28-2009, 12:04 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 11
Rep:438
Quiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really nice
Default Left Turn Signal Blinking Fast / Right OK

I'm not sure on this one...maybe someone has similar issue.

I got pulled over the other day and used Hazards. Then the next day my left turn signal started blinking really fast. Light still working on the outside.

Right signal is working fine.

Then I pushed the hazards again. My right blinker indicator is working, but not the left. Seems to be some short. You think a short in wire or a short in mechanical piece?

Thanks all
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-28-2009, 06:45 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 53
Posts: 21,490
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 22
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Need to check the bulbs and make sure their good . Bad bulb will make it flash fast .
__________________
Reply With Quote
  #3  
Old 09-29-2009, 03:28 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 11
Rep:438
Quiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really nice
Default

You might have a bad connection at one of the bulb sockets. Check your bulbs and sockets.
Reply With Quote
 
  #4  
Old 09-29-2009, 06:28 PM
LS Eater's Avatar
LS Eater LS Eater is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2009
Location: Dallas, TX
Age: 29
Posts: 169
Gender: Male
Vehicle: 2011 Ram Crew Cab Cummins
Trim Level: Big Horn
Color: Pearl White
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:12
LS Eater is on a distinguished road
Default

The filament in the bulb is almost shot. Change the bulb and that will fix the problem!
Reply With Quote
  #5  
Old 09-29-2009, 09:58 PM
ras16ram's Avatar
ras16ram ras16ram is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2009
Age: 56
Posts: 4
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
ras16ram is on a distinguished road
Default

Like they said check all your bulbs and connections. Make sure you don't have any corrosion where the bulbs plug in.
Reply With Quote
  #6  
Old 09-30-2009, 10:06 AM
chithead's Avatar
chithead chithead is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2008
Location: Landis, NC
Age: 36
Posts: 12,929
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: R/T Baby!!!
Color: Bright White
Rep Power: 20
Rep:2078
chithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond reputechithead has a reputation beyond repute
Default

I would definitely agree with the bulb out, but I heard some years of the Ram have an indicator on the dash...
Reply With Quote
  #7  
Old 10-01-2009, 11:00 AM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 11
Rep:438
Quiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really nice
Default

Thanks all. I feel like such an idiot. It was just the bulb.

I'm also throwing a P1281 code I need to investigate that one too. Got another post on the mechanical area.

Honestly, I don't understand some of this Chrysler Engineering folks. I love my dad's truck, but I drove fords all my life and have to get used to the different engineering.
Reply With Quote
  #8  
Old 10-01-2009, 10:11 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 11
Rep:438
Quiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really niceQuiet Lunatic is just really nice
Default

P1281 - Engine is Cold Too Long; which means: Engine coolant temperature remains below normal operating temperatures during vehicle travel . Thermostat may be stuck open.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 07:10 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors