DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > V10 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-22-2009, 07:17 PM
snowplowguy snowplowguy is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2009
Location: Michigan
Age: 31
Posts: 6
Gender: Male
Vehicle: 1994 Ram (v10), 1997 Ram(v8)
Trim Level: ???
Color: green
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
snowplowguy is on a distinguished road
Default Gas/air/electric??? problem

Hey all, I bought a 1997 ram, got a great deal but need to get it running better. I think the guy that owned the truck before was trying to fix the same problem but gave up and let it sit. It drives decent but when it gets to the end of the gear it starts powering down itself and when you push the gas in further it starts popping like popcorn, my buddy said that its backfiring. When you push the pedal all the way down it will switch gears but only if it hits passing gear. It feels like its going to stall sometimes in idle but its intermitent. The code keeps says it needs an 02 sensor but one of my friends says that's because there's no cat on it. The computer's also saying that it's running rich. There was some kind of short on the wiring harness where 6 wires got burned up. As near as I can tell the wires mostly go to the daytime running light module that was fried but I haven't figured out if that's all the wires were for yet. Went to 6 junkyards looking for a daytime running light module and finally found one but the year must have been different because the wires were different colors so I didn't end up hooking it up and capped the wires so that they wouldn't short or drain the battery. I know that's a lot of info but I'm not sure what to try next. Already did new brakes, rotors, brake lines, pulled the tank and looks like fuel filter's fine, new plugs, new wires, new air filter, so I have some time and money into this truck already but I'm lost now. Any help would be greatly appreciated.
Reply With Quote
Sponsored links
  #2  
Old 11-23-2009, 12:06 AM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Wasn't aware that there were DRL on our trucks . Knew it was more common on the newer trucks . Got any pics of the burnt up wiring harness ?
__________________
Reply With Quote
  #3  
Old 11-23-2009, 12:09 AM
snowplowguy snowplowguy is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2009
Location: Michigan
Age: 31
Posts: 6
Gender: Male
Vehicle: 1994 Ram (v10), 1997 Ram(v8)
Trim Level: ???
Color: green
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
snowplowguy is on a distinguished road
Default

I'm pretty sure 97 was the first year they put it on, but I don't think it was on all of the 97's, no pics yet. I tried to get the connector to the DRL but the dealership only wanted to sell me the whole wiring harness for the truck and they wanted $500 for it.

Last edited by snowplowguy; 11-23-2009 at 12:12 AM. Reason: had more to say
Reply With Quote
  #4  
Old 11-23-2009, 12:11 AM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

I don't think I have ever seen a older Ram with DRL's .
__________________
Reply With Quote
  #5  
Old 11-23-2009, 12:40 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The dealer can order the connector itself, but not as a pigtail assembly. Your best bet is to scour the salvage yards and get one and splice it into your truck.
Reply With Quote
  #6  
Old 11-23-2009, 08:05 PM
snowplowguy snowplowguy is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2009
Location: Michigan
Age: 31
Posts: 6
Gender: Male
Vehicle: 1994 Ram (v10), 1997 Ram(v8)
Trim Level: ???
Color: green
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
snowplowguy is on a distinguished road
Default

I got one after the 6th junkyard, and it turned out to be a different year. The DRL module was the right part number but the wires were different colors, I'm going to have to get a new chilton manual to figure out the wiring, the one I have only covers up to '96. Any clue what else would cause this besides the wiring?? I'm thinking like a throttle control or something not allowing it to shift at the right time.
Reply With Quote
  #7  
Old 11-24-2009, 01:26 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

You need to get the engine problem diagnosed before you go after any transmission issues. Chances are fixing the engine will remedy the shifting issues. which O2 codes are you getting? Upstream codes shouldn't set for the cat being gone, but downstream codes will.
Reply With Quote
  #8  
Old 11-25-2009, 05:39 PM
snowplowguy snowplowguy is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2009
Location: Michigan
Age: 31
Posts: 6
Gender: Male
Vehicle: 1994 Ram (v10), 1997 Ram(v8)
Trim Level: ???
Color: green
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
snowplowguy is on a distinguished road
Default

Thanks for the help, you got me thinking now. I took 02 sensor to mean it senses the airflow to tell how the engine's performing, I didn't realize it tells the computer what to put out. Now you've got me wondering if that wire got fried with the daytime running light module. I need to check the wires again and get the wires and the 02 sensor problem solved.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:57 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum