Service 4wd light on new 2010 Sport - Page 4 - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2010 Dodge Ram Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #31  
Old 01-18-2011, 04:57 PM
Crash Crash is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2010
Location: Northern Ontario, Canada
Age: 57
Posts: 1,506
Gender: Male
Vehicle: 2016 Laramie Longhorn Limited
Trim Level: Laramie limited
Color: Black crystal pearl
Rep Power: 8
Rep:404
Crash is just really niceCrash is just really niceCrash is just really niceCrash is just really niceCrash is just really nice
Default update

So third trip to the dealer for this problem! they say it is the transfercase shift motor and it is on back order. They say three weeks to get one. I asked them if it could be the final drive control module and my service writer said "he never heard of that part!"
Reply With Quote
Sponsored Links
Advertisement
 
  #32  
Old 01-18-2011, 05:31 PM
Aries's Avatar
Aries Aries is offline
Dodge Ram Forum Senior Member
 
Join Date: Sep 2010
Location: Canada
Age: 56
Posts: 128
Gender: Male
Vehicle: 2010 Dodge Ram 1500 Quad Cab
Trim Level: Sport
Color: Flame Red
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Aries is on a distinguished road
Default

What does the 5 position selector have different than mine??
I have 2WD 4Auto 4LOCK and 4LOW That's 4 positions. I've seen some without the 4Auto but what do yours have different???
Tom
Reply With Quote
  #33  
Old 01-18-2011, 07:30 PM
Crash Crash is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2010
Location: Northern Ontario, Canada
Age: 57
Posts: 1,506
Gender: Male
Vehicle: 2016 Laramie Longhorn Limited
Trim Level: Laramie limited
Color: Black crystal pearl
Rep Power: 8
Rep:404
Crash is just really niceCrash is just really niceCrash is just really niceCrash is just really niceCrash is just really nice
Default

Quote:
Originally Posted by Aries View Post
What does the 5 position selector have different than mine??
I have 2WD 4Auto 4LOCK and 4LOW That's 4 positions. I've seen some without the 4Auto but what do yours have different???
Tom
that is the five position switch you have...you left out neutral. the fifth position is the 4auto setting, four positions do not have this setting
Reply With Quote
 
  #34  
Old 01-18-2011, 11:41 PM
Aries's Avatar
Aries Aries is offline
Dodge Ram Forum Senior Member
 
Join Date: Sep 2010
Location: Canada
Age: 56
Posts: 128
Gender: Male
Vehicle: 2010 Dodge Ram 1500 Quad Cab
Trim Level: Sport
Color: Flame Red
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Aries is on a distinguished road
Default

Thanks Crash.
Reply With Quote
  #35  
Old 02-10-2011, 11:14 PM
Caelum Caelum is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Alberta
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: Laramie
Color: Grey
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Caelum is on a distinguished road
Default

Quote:
Originally Posted by Caelum View Post
I have a 2010 Laramie, and in about a month I've had three issues with the Serv4wd. First the truck went into 4wd, but it would not come out. Dealer replaced the shift motor "actuator".

A few weeks later the light came on a gain, dealer found nothing, reset the computer. The next day it came on again, took it back. This time the dealer said it was a faulty engine coolant temperature sensor (they told me if this fault the computer would show a serv4wd). They replaced it, drove it for about 2000km with no problems.

Today, again 4wd light as soon as I shifted into 4wd, before even moving, and again it would not come out of 4wd. Dealer said the shift motor "actuator" was faulty and replaced again.

Very annoying! If this happens again I will have to bring up the drive train control module. Thanks for the thread!

Well it happened again, this time only a few days after the shift motor was replaced again. I took it to the dealer while the light was on and we went for a drive. I told the service guy about drive train control module, he didn't seem to care at the time.

So they keep the truck and call me and tell me they replaced the drive train control module! They told me that they had not had a truck with this problem so far. Anyways If any Canadians are interested the part number description was: Module 08-035-028, as per my work order.

I've run about three weeks and so far no problems, hopefully this will be the end of this.
Reply With Quote
  #36  
Old 02-11-2011, 03:26 AM
GRam's Avatar
GRam GRam is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2010
Location: Kamloops BC
Age: 48
Posts: 103
Gender: Male
Vehicle: 2011 Ram
Trim Level: Laramie
Color: Mineral Grey
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
GRam is on a distinguished road
Default

On way home from sledding last weekend, the EVIC lit up like the Griswolds house at xmas! Had ESP/Serv 4wd warning, traction control warning, abs warning, park assist wouldn't turn on, transfer case wouldn't shift into 4 low... dealer traced it back to the rear wheel speed sensor. Though how that effects transfer case shfting I have no idea?? Perhaps it has a speed reading to avoid engaging at too high of ground speed?
Regardless, had parts in stock and fixed me up in an hour!!
__________________
2011 HD StreetGlide, 103" 106 TQ
2012 Polaris Assault 800 101 TQ
2011 Cummins 800+ TQ

Torque, it's what moves you...
Reply With Quote
  #37  
Old 01-27-2013, 04:47 AM
dbakes dbakes is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Edmonton, AB
Posts: 1
Gender: Male
Vehicle: 2010 Ram 1500 Sport
Trim Level: SLT
Color: Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dbakes is on a distinguished road
Default

Having same problem. I was booked in but things went back to normal - I pushed the N button the last time and it worked. But this time it's not doing anything so I'm thinking that the N button was a coincidence and maybe the change for the better had more to do with fluctuation in the weather which, btw, was snowy blowy when 4W wasn't working and sunny and wet when it was...go figure. Today it's colder again, and 4WD SERV is back staring at me. Maybe there's a connection, maybe not - but from what I'm reading here it sounds like it's the module, regardless.

Glad I came here, now I'm armed with valuable information when it goes to the dealership. Of course, for the most part, ya can't tell a guy at the service counter what to look for, because they're the experts. Great thing about smart phones; I can bookmark this forum and shove it in his face (after telling him I don't have time to dick around). Ya, that'll work...

Cheers!
Reply With Quote
  #38  
Old 03-30-2016, 10:10 PM
Robyj33 Robyj33 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2016
Location: Manitoba
Age: 45
Posts: 1
Gender: Male
Vehicle: 2010 Dodge Ram 1500 SLT 4x4
Trim Level: 1500 SLT Crew cab.
Color: Black
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Robyj33 is on a distinguished road
Default

Just picked up my 2010 Ram 1500 SLT 1500 4x4 with the 5.7L Hemi.
The service 4wd light has come on but at the same time the ABS light and the Traction control light are on as well. They all come on together. They do go out as well. Just wondering if anyone has any thoughts on this, just a crazy sensor or do I have bigger problems? I have no other issues as this truck drives and feels tight like its brand new.
Thanks.
Reply With Quote
  #39  
Old 09-10-2016, 11:03 PM
checkeredSKIM89's Avatar
checkeredSKIM89 checkeredSKIM89 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2009
Age: 28
Posts: 13
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: SLT Big Horn
Color: Tan
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
checkeredSKIM89 is on a distinguished road
Default

Ive had my 2009 Ram 1500 HEMI for almost 2 years and a week ago the SERV 4WD light came on. So I took it into the dealer and they did there diagnostics and came back to say its the Transfer Case Shift Motor that has faulted and i stuck in 4WL. They want to charge $750 to replace but after watching a quick youtube video, seems pretty straight forward to replace.
My big question is do I buy it from Dodge Mopar for $450 or go with a Dorman or something else for about half that $200? I have had bad luck with Dorman in the past so I am second guessing not going mopar.
Reply With Quote
  #40  
Old 09-11-2016, 01:30 PM
Thunderhorse's Avatar
Thunderhorse Thunderhorse is offline
The Sound of Eight Hooves




 
Join Date: Jun 2013
Location: NC
Age: 26
Posts: 26,972
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Lone Star (MJX8)
Color: Bright White (PW7)
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 19
Rep:883
Thunderhorse is a splendid one to beholdThunderhorse is a splendid one to beholdThunderhorse is a splendid one to beholdThunderhorse is a splendid one to beholdThunderhorse is a splendid one to beholdThunderhorse is a splendid one to beholdThunderhorse is a splendid one to behold
Default

Quote:
Originally Posted by checkeredSKIM89 View Post
Ive had my 2009 Ram 1500 HEMI for almost 2 years and a week ago the SERV 4WD light came on. So I took it into the dealer and they did there diagnostics and came back to say its the Transfer Case Shift Motor that has faulted and i stuck in 4WL. They want to charge $750 to replace but after watching a quick youtube video, seems pretty straight forward to replace.
My big question is do I buy it from Dodge Mopar for $450 or go with a Dorman or something else for about half that $200? I have had bad luck with Dorman in the past so I am second guessing not going mopar.


This is a part that I'd buy OEM.

You may already know this, but Ram used the NVG 243 (part time) and NVG 246 (full time) transfer cases until mid-2010 when they switched from New Venture Gear to Borg-Warner transfer cases (44-44 full time, and 44-45 full time); yours should be a NVG 246. I am not sure why they changed suppliers but personally I think the NVG cases are better than the BWs. Make sure you are getting the part for the New Venture case and not a Borg-Warner which is more common since it has been used more years.
__________________

Thunderhorse:
2013 Ram 1500 Lone Star Quad Cab 4X4. Bright White (PW7), 345ci Hemi V8, 8HP70, 3.21 gears (LSD rear). Mods list
Colt:
2015 Durango SXT Southwest Heat RWD. White Knuckle (PW7), 220ci Pentastar V6, 845RFE, 3.45 gears (open). Huskyliners, Catch can. Thread
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:14 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors