DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-21-2010, 12:09 PM
Jimi2577 Jimi2577 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Posts: 2
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Jimi2577 is on a distinguished road
Default Throttle body issues

this is my first post . I have a 03 Ram 5.7 hemi ,When i'am driving my ram between 20-65 mph the lighting bolt light comes on (throttle body) ,, truck loses power no rpm u can punch it & it won't go any where untill u pullover & shut it off and it will reset the computer then it will run fine . Untill it doses it again . I have taken my truck to the dealer they don't know what's wrong with it . They always want to clean the throttle body . That works for a hour and does it again. Just looking for some info , i dont know what to do ,this happens 5-7 times when I drive it every day if anybody knows what's up with it let me know
Reply With Quote
Sponsored links
  #2  
Old 01-21-2010, 12:31 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Could be the APPS, throttle body, wiring or PCM.
Reply With Quote
  #3  
Old 01-21-2010, 06:36 PM
Jimi2577 Jimi2577 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Posts: 2
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Jimi2577 is on a distinguished road
Default Throttle body

Randy. What do those codes mean ?
Reply With Quote
  #4  
Old 01-21-2010, 07:27 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

You mean the acronyms? Accelerator Pedal Position Sensor and Powertrain Control Module.
Reply With Quote
  #5  
Old 04-29-2010, 10:14 PM
DodgeRamHD's Avatar
DodgeRamHD DodgeRamHD is offline
Dodge Ram Forum Member
 
Join Date: Apr 2010
Location: Cameron, TX
Age: 23
Posts: 53
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Color: Goldish
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:14
DodgeRamHD is on a distinguished road
Default

i get the same light randomly on the same truck as you but i lose my high gear and o/d. all i have to do is restart it and it runs fine again. I have been told it was a (speed sensor) but im not sure. idk maybe they can be linked idk maybe this will help a little im not sure.
Reply With Quote
  #6  
Old 06-30-2010, 10:36 PM
crash83's Avatar
crash83 crash83 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Location: Spring,Texas
Age: 39
Posts: 23
Gender: Male
Vehicle: 2004 Ram 1500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
crash83 is on a distinguished road
Default

Have this same problem on my 04 hemi,the dealer replaced the apps and the cam timing sensor,ran great for two weeks then Sunday lighting bolt was back.
The dealer is thinking that since they replaced the sensors and cleaned the throttle body they should have "relearned"the pcm.Its in there now getting double checked and the pcm is being updated.
Ill keep you posted as to the results.
Reply With Quote
  #7  
Old 07-02-2010, 12:26 AM
moparmike07's Avatar
moparmike07 moparmike07 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2010
Location: NY
Age: 24
Posts: 2,461
Gender: Male
Vehicle: 07 dodge ram 1500
Trim Level: st
Color: silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
moparmike07 will become famous soon enough
Default

still need more help or you got it ?
__________________

2007 dodge ram 1500 quad cab 4x4 5 percent tint all around 35 percent windshield, ported tb, diablo sport, arh headers, magnaflow dual exhaust, magnaflow y pipe, krc210x cam,nitrous,CNC ported head. 4.56 motive
Reply With Quote
  #8  
Old 07-02-2010, 10:14 AM
chefred112's Avatar
chefred112 chefred112 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2009
Location: NorCal
Posts: 5,718
Gender: Male
Vehicle: 2005 Dodge Ram
Trim Level: SLT
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:647
chefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to all
Default

I would get a new throttle body and rule that out as the issue..
__________________
-fast freddie-
one quick 05 hemi qc...with over 250k miles on odo... on the 5.7...stoker 6.4 now, new times coming
performance mods: yes 1/8 - 7.85 @ 93.20, 1/4 - 12.10 @ 113.96
2005 Dodge Ram 1500 QC SLT: 12.107 @ 113.960 MPH
Reply With Quote
  #9  
Old 07-13-2010, 12:57 PM
crash83's Avatar
crash83 crash83 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Location: Spring,Texas
Age: 39
Posts: 23
Gender: Male
Vehicle: 2004 Ram 1500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
crash83 is on a distinguished road
Default

Well my truck is still at the dealer beem there 2 weeks .
First they said cam sensor and crank sensor short .Then i called this morning and they said the truck was on hold waiting on another part.
Thank god for warranty.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:38 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum