DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-31-2010, 06:02 PM
mkarns mkarns is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Age: 53
Posts: 26
Gender: Male
Vehicle: 1997 Dodge Ram Ext. Cab 4x4
Trim Level: SLT
Color: Green/Silver
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
mkarns is on a distinguished road
Unhappy Ram Dead......No Juice.....Help!

I have a 1997 Ram 1500 4x4.

It has 150,000 miles on it and runs great.

Today I went out to start it and it turned over twice and then it was like a fuse shot.

No electricity anywhere......no lights......no radio......no nothing.

I checked the fuses and battery, all are ok.

Just ran it yesterday fine.....alternator was charging like it should.

Not sure what to check next.....please help....

I'm desperate.

Thanks,

M. Karns
Reply With Quote
Sponsored links
  #2  
Old 01-31-2010, 06:05 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Pull off both battery terminals and clean the posts and inside the terminals. If you have a voltmeter you should check power to the PDC and the brounds coming back to the battery.
Reply With Quote
  #3  
Old 01-31-2010, 07:18 PM
mkarns mkarns is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Age: 53
Posts: 26
Gender: Male
Vehicle: 1997 Dodge Ram Ext. Cab 4x4
Trim Level: SLT
Color: Green/Silver
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
mkarns is on a distinguished road
Default

It has a new battery, posts are clean.

What's the PDC?

Thanks......
Reply With Quote
  #4  
Old 01-31-2010, 08:26 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Just because it's a new battery doesn't mean it couldn't fail . Put a voltmeter across it anyway and check . Check your ground on the engine block also . You should have a small red cable coming off the positive battery terminal . Make sure that is secure , and clean .
__________________
Reply With Quote
  #5  
Old 02-06-2010, 01:38 PM
mkarns mkarns is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Age: 53
Posts: 26
Gender: Male
Vehicle: 1997 Dodge Ram Ext. Cab 4x4
Trim Level: SLT
Color: Green/Silver
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
mkarns is on a distinguished road
Default Update

I left the truck sit all week and went out today to check the terminals of the battery.

Guess what, the interior light comes on and the buzzer for the ignition switch works.......

Has the battery had a week to charge alittle?

I'll try to start it later on, keep ya posted.......
Reply With Quote
  #6  
Old 02-06-2010, 01:41 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Batteries don't charge themselves. You still need to check for voltage drops.
Reply With Quote
  #7  
Old 02-06-2010, 01:54 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,069
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2597
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

if the battery proves to be the problem, get it tested, new batteries can be duds too,
if the battery tests good, you may want to charge it with trickle charger
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #8  
Old 02-06-2010, 03:41 PM
mkarns mkarns is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Age: 53
Posts: 26
Gender: Male
Vehicle: 1997 Dodge Ram Ext. Cab 4x4
Trim Level: SLT
Color: Green/Silver
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
mkarns is on a distinguished road
Default

OK, went out and tried cranking the engine.

As soon as I turned the key to start lost all power......

When I put the key on the accessory mode, I have radio, buzzer, interior lights, etc.

But everytime I tried to start it I lost all power while the key was in the engine cranking mode.

Put a solar trickle charger on it plugged into the cigarette lighter.......(do they work?)

Thanks for all the help...

Oh, I don't have a voltmeter........
Reply With Quote
  #9  
Old 02-06-2010, 10:20 PM
deanthecrabman's Avatar
deanthecrabman deanthecrabman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2009
Location: St Petersburg, FL
Posts: 948
Gender: Male
Vehicle: 2001 Ram 1500 Quad 4WD 5.9
Trim Level: Quad cab
Color: Garnet red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 6
Rep:202
deanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura about
Default

Even if the battery shows 12V, it may not have the amperage to start. Make sure the battery carries a load. Sounds like you may have a problem in the ignition switch, as everything works in ACC, but not when you try to start. Anyone else?
Reply With Quote
  #10  
Old 02-06-2010, 10:35 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,069
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2597
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

possibly a starter solenoid
just another thing to check
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:44 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum