DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Towing


Notices

Towing 4th Gen Dodge Ram Towing Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-07-2010, 10:17 AM
mike223 mike223 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2010
Location: keswick Ontario
Posts: 12
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: 4x4 quad Cab
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
mike223 is on a distinguished road
Question Wiring schematic for trailer lights

Hey guys. Anyone know where to get and/or download a wiring diagram for the trailer light package. I do not have left brake or left signal working. I have a 2003 Ram 1500 Quad cab 4x4.
thanks guys
Mike
Reply With Quote
Sponsored links
  #2  
Old 04-07-2010, 11:18 AM
City Slicker City Slicker is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Posts: 11,861
Gender: Male
Rep Power: 13
Rep:1625
City Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant future
Default

Remerson is the man for uploading schematics. Once he sees this thread, hopefully he'll help you out
Reply With Quote
  #3  
Old 04-07-2010, 11:28 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Reply With Quote
  #4  
Old 04-07-2010, 01:09 PM
mike223 mike223 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2010
Location: keswick Ontario
Posts: 12
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: 4x4 quad Cab
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
mike223 is on a distinguished road
Default

Thanks guys. Hopefully will have a bit of time this weekend to take a look at it.
Reply With Quote
  #5  
Old 06-23-2010, 11:46 PM
Dazed and Confused Dazed and Confused is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Location: Louisiana
Age: 40
Posts: 5
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Trim Level: 4x4 quad cab Laramie
Color: Patriot Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Dazed and Confused is on a distinguished road
Default How did it go?

Quote:
Originally Posted by mike223 View Post
Hey guys. Anyone know where to get and/or download a wiring diagram for the trailer light package. I do not have left brake or left signal working. I have a 2003 Ram 1500 Quad cab 4x4.
thanks guys
Mike
Hey Mike did you ever come up with the solution? I am having the same problem with the same truck. I think it might be the relay but not sure which one it is. Any advice would be appreciated.
Anthony
Reply With Quote
  #6  
Old 06-24-2010, 02:38 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Quote:
Originally Posted by Dazed and Confused View Post
Hey Mike did you ever come up with the solution? I am having the same problem with the same truck. I think it might be the relay but not sure which one it is. Any advice would be appreciated.
Anthony
Not likely, but not impossible, that it's the relay. I'd be looking more at the fuse and the wiring at the trailer connector.

Fuse or relay, look in the TIPM cover, and there is a map of the fuses and relays.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #7  
Old 06-25-2010, 10:34 PM
Tonatom Tonatom is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Posts: 22
Gender: Male
Vehicle: 2003 Dodge Ram 4.7L
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Tonatom is on a distinguished road
Default

2003 Ram 1500

I am having this Problem too, the brake and signals for right/left are not working at the incoming wires to the trailer connector, I went and tested for signal/brake on the Yellow-pink and White-pink lines further back from the taillight split offs in the wire bundle. The taillights work fine at the trailer connector.

Fuse 46 and 47 have constant power to them when the hazards are on so can I assume the relay is bad (but no power to the yellow and white pink wires at the back) This truck has never previously had a trailer hooked up to it. But how do I tell if the relays are working or not that the fuse 46/47 go to?
I just put the big Reese hitch on it.

Which Relay on the IPM controls these left/right lines? Or are these internal relays in the Front Control Module?

I also have a brand new C1 connector (the 15pin on the IPM) to put in as a couple wires were corroded badly.) This too could be the problem.

Last edited by Tonatom; 06-25-2010 at 10:55 PM.
Reply With Quote
  #8  
Old 06-25-2010, 11:21 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Quote:
Originally Posted by Winchested View Post
2003 Ram 1500

I am having this Problem too, the brake and signals for right/left are not working at the incoming wires to the trailer connector, I went and tested for signal/brake on the Yellow-pink and White-pink lines further back from the taillight split offs in the wire bundle. The taillights work fine at the trailer connector.

Fuse 46 and 47 have constant power to them when the hazards are on so can I assume the relay is bad (but no power to the yellow and white pink wires at the back) This truck has never previously had a trailer hooked up to it. But how do I tell if the relays are working or not that the fuse 46/47 go to?
I just put the big Reese hitch on it.

Which Relay on the IPM controls these left/right lines? Or are these internal relays in the Front Control Module?

I also have a brand new C1 connector (the 15pin on the IPM) to put in as a couple wires were corroded badly.) This too could be the problem.
First I should correct my earlier reference to TIPM. In your model year, that did not exist, but rather there is an IPM and a FCM.

I would expect the cover for the IPM to have a legend that shows which relays are for the turn signals. Another potential source for this legend is the owners manual. The trailer light relays are triggered by the FCM in your truck, so if a relay is not working, it could be the relay, but could also be the lack of signal from the FCM. If you do not operation of either turn signal on the trailer, I would be inclined to blame the FCM, as it is unlikely that both relays would fail at the same time.

If you can locate the correct relay(s), you can test for signal from the FCM. First remove the suspect relay, then using a volt meter, connect the negative lead to relay socket 86, and the positive lead to relay socket 85. This should show 12V pulsing at the same rate as the signal lights flash. NOTE - I do not recommend using a test light for this test. I do NOT know what electronics the FCM uses to trigger the relay, but can assume it is a low current ground switch (ie open collector, etc), and testing with a device that exceeds it's rated current WILL damage it fatally! A proper voltmeter is a 'current safe' test. If you are not 100% familiar with using a voltmeter, then testing of the FCM should be left for a trained technician.

As for the C1 connector, I do not know which connector ties the FCM to the IPM. If it is C1, then bad or corroded connections here, could yield the results you are noticing.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #9  
Old 06-25-2010, 11:54 PM
Tonatom Tonatom is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Posts: 22
Gender: Male
Vehicle: 2003 Dodge Ram 4.7L
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Tonatom is on a distinguished road
Default

So the FCM is the computer controller for the IPM found that out.

I have read over 30 posts on all kinds of forums about the IPM and FCM ****ing up so badly that they have to replace both at a whopping $400-$700. I can't believe Chrysler got away with not recalling these parts. What ******* engineer puts a fuse box/computer under the hood completely exposed to weather and shit like this fusebox. Epic fail on Chrysler's part, good thing this isn't my truck and these issues have turned me 100% off of buying a new dodge ram.

Last edited by Tonatom; 06-26-2010 at 12:22 AM.
Reply With Quote
  #10  
Old 06-26-2010, 12:51 AM
Tonatom Tonatom is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Posts: 22
Gender: Male
Vehicle: 2003 Dodge Ram 4.7L
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Tonatom is on a distinguished road
Default

Anyone have a part number for the IPM and FCM 2003 Ram 1500 2wd 4.7 L auto w/ trailer wiring.

Or Can I just buy one of the aftermarket $50 controllers with the internal fuse/relay controls and run them right off of the rear tail lights?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:20 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum