DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 3rd Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-15-2010, 02:00 PM
Reaver33's Avatar
Reaver33 Reaver33 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2010
Location: San Diego
Age: 31
Posts: 15
Gender: Male
Vehicle: 2014 Ram 3500 MegaCab
Trim Level: SLT
Color: Black
Engine: 2013-20?? 409ci (6.7L) Cummins Turbo Diesel 385hp 850lb/ft (Aisin ASC69RC Automatic)
Rep Power: 0
Rep:10
Reaver33 is on a distinguished road
Default High AC pressure no cold????? wtf?

Hooked up a gauge and it read 105psi. Had that removed and new refrigerant put in the lp side. Vents blow like crazy but it's all hot air. Compressor doesn't seem to be kicking on either. Do I need a new compressor?
Reply With Quote
Sponsored links
  #2  
Old 05-15-2010, 02:26 PM
RansRAM's Avatar
RansRAM RansRAM is offline
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 54
Posts: 12,149
Gender: Male
Vehicle: 2010 RAM 1500
Trim Level: Quad Cab 4X4 Sport
Color: Brilliant Black
Rep Power: 15
Rep:2453
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Exclamation

What side was reading 105psi ?? If it's the high side it sounds like you may need more refrigerant. In order to get the compressor to come on you need to have enough refrigerant in the system. When the system is properly charged the low side should be around 30psi and the high side around 150psi with the compressor running. Be very careful not to overcharge. You need to slowly put refrigerant into the low side until the low (suction) pipe entering the compressor starts to get cold. (thats the side coming from the evaporater and is larger in size). Of course the compressor needs to be turning before the suction side will start to get cold. As you put refrigerant into the low side the compressor should start to cycle on and off. If this does not happen something else may be at fault.
__________________
BT CC / Hood Kit, LED Tails, Recon 3rd Brake & Xtreme LightBar, Black Aluminum Side Steps, Leer 700, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Front Tow Hooks and Bed Post Hide-a-Hooks, Tints (20% frt, 35% rear and slider), Painted Engine Cover/Brake Calipers, K&N Drop in,OEM Fender Flares/ bug deflector, FM 40, SC Cortex, Oracle H11 LED Heads, 4000k Putco Fogs, LED Interior Lights, Honeycomb Grill, Bilstien 5100's.
Reply With Quote
  #3  
Old 05-15-2010, 04:31 PM
Reaver33's Avatar
Reaver33 Reaver33 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2010
Location: San Diego
Age: 31
Posts: 15
Gender: Male
Vehicle: 2014 Ram 3500 MegaCab
Trim Level: SLT
Color: Black
Engine: 2013-20?? 409ci (6.7L) Cummins Turbo Diesel 385hp 850lb/ft (Aisin ASC69RC Automatic)
Rep Power: 0
Rep:10
Reaver33 is on a distinguished road
Default

Ok, the compressor was me just being a dumb ass. I thought the AC button was on and it wasn't. As soon as I saw it wasn't on I turned it on and the compressor engaged no problem. I put a can in and discovered my next issue. The two vents on the drivers side are much cooler now, however the passenger vents are still warm. And just so nobody asks this truck isn't equipped with dual climate control!! LOL!
Reply With Quote
  #4  
Old 05-15-2010, 06:59 PM
RansRAM's Avatar
RansRAM RansRAM is offline
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 54
Posts: 12,149
Gender: Male
Vehicle: 2010 RAM 1500
Trim Level: Quad Cab 4X4 Sport
Color: Brilliant Black
Rep Power: 15
Rep:2453
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Smile

There is another post that mentions problems with the blend and mode doors, located here http://www.ramforumz.com/showthread....highlight=door. This might be your problem.
__________________
BT CC / Hood Kit, LED Tails, Recon 3rd Brake & Xtreme LightBar, Black Aluminum Side Steps, Leer 700, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Front Tow Hooks and Bed Post Hide-a-Hooks, Tints (20% frt, 35% rear and slider), Painted Engine Cover/Brake Calipers, K&N Drop in,OEM Fender Flares/ bug deflector, FM 40, SC Cortex, Oracle H11 LED Heads, 4000k Putco Fogs, LED Interior Lights, Honeycomb Grill, Bilstien 5100's.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 03:16 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum