DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > Dodge Ram Knowledge Base


Notices

Dodge Ram Knowledge Base Here you can find owner submitted how-to's for performing various mods to your Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #261  
Old 10-04-2011, 12:58 AM
msjgrizz msjgrizz is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: TN
Age: 45
Posts: 6
Gender: Male
Vehicle: 2012 Dodge Ram
Trim Level: Express
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
msjgrizz is on a distinguished road
Default

Quote:
Originally Posted by ken99 View Post
The current part number for the Integrated Trailer Brake Module (ITBM) is 56029431AH. Unless Dodge has redesigned the integrated brake controller for 2012, this part should be correct. A bezel is also needed to match the dash color and part numbers vary by color choice. Any Dodge dealer can order these parts for you or you can go to one of many internet parts sites.
Thanks for the info Ken! Gave the dealer that part number and they said it was for up to 2011. But they also said that they have not been updated fully on the parts list for the 2012's.

Guess I will give them another month to get caught up. I just hope the wires are there to do the plug and play install.
Reply With Quote
Sponsored links
  #262  
Old 10-07-2011, 08:25 PM
gshelton777 gshelton777 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: Liberty Hill, Tx
Posts: 22
Gender: Male
Vehicle: 2011 Ram 1500 Sport 4x4
Trim Level: Sport
Color: Bright White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
gshelton777 is on a distinguished road
Default

Just added the OEM brake controller to my 2011 1500. Piece of cake. I suggest using a nut driver with a 7mm hex driver bit to loosen and reinstall the two screws holding the under-steering wheel panel. I believe the three screws I used were number 8 x 1/2" sheet metal screws.
__________________
Regards, Glenn
Reply With Quote
  #263  
Old 10-09-2011, 09:49 AM
msjgrizz msjgrizz is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: TN
Age: 45
Posts: 6
Gender: Male
Vehicle: 2012 Dodge Ram
Trim Level: Express
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
msjgrizz is on a distinguished road
Default

I also added the OEM Brake controller. Just really surprised how easy it was to install.
I installed mine in the dealer parking lot so I could be there to get them to flash it if it needed it. It did not need flashing.
A big thanks to all that took the time to post info about the OEM Brake controller!!!
Reply With Quote
  #264  
Old 10-10-2011, 03:21 PM
dmathewswpd51 dmathewswpd51 is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Location: NW Oklahoma
Posts: 4
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: TRX
Color: White
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dmathewswpd51 is on a distinguished road
Default

I have a 2010 Ram 1500 with the Factory Installed Trailer brake system. About a week ago I got a message to "service trailer brake system". Have pulled a trailer twice with no problems, truck just turned over 10,000 miles. The second time was after the service message came on. Any suggestions on how to clear this warning. System appears to be working as required. I've pulled the battery off for 1/2 an hour and put it back but indicator still on.

Thanks
Reply With Quote
  #265  
Old 10-18-2011, 01:49 AM
Bluebee Bluebee is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Posts: 19
Gender: Male
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bluebee is on a distinguished road
Default

Hey what's a reputable website to order the trailer brake and bezel parts? I've tried my stealership but they will only sell me the full kit at twice the price.....please pm if u know of a good site that carries the part, I can't seem to find one...I must be internet challenged.
Reply With Quote
  #266  
Old 10-18-2011, 06:03 PM
pjs1660's Avatar
pjs1660 pjs1660 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: lakewood, ohio
Age: 57
Posts: 311
Gender: Male
Vehicle: 2011 ram 1500 outdoorsman
Trim Level: slt outdoorsman
Color: green
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:137
pjs1660 will become famous soon enoughpjs1660 will become famous soon enough
Default

i got mine earlier this year from mopar-wholesale.com they had the controll on sale for about $95 and the bezel for about $5 it came from a dealer in tampa
Reply With Quote
  #267  
Old 10-21-2011, 12:00 PM
ken99 ken99 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Montana
Posts: 107
Gender: Male
Vehicle: 2010 Ram 1500 Crew 4x4
Trim Level: SLT
Color: Austin Tan Pearl
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:26
ken99 is on a distinguished road
Default

Quote:
Originally Posted by dmathewswpd51 View Post
I have a 2010 Ram 1500 with the Factory Installed Trailer brake system. About a week ago I got a message to "service trailer brake system". Have pulled a trailer twice with no problems, truck just turned over 10,000 miles. The second time was after the service message came on. Any suggestions on how to clear this warning. System appears to be working as required. I've pulled the battery off for 1/2 an hour and put it back but indicator still on.
I've been trying to determine what triggers this message. I found only one other instance on the Internet, and it was related to a wiring problem (a short?) with the 7 pin connector on the back of the truck. I would try using the same process to delete this message from the EVIC as the "oil needs changing" message. Turn the key to the on position (but do not start) and press the accelerator pedal three times. May/may not work, but it certainly would do no harm.

It also might have been better to submit this thread as a new post in one of the general discussion sections since I think more folks would have seen it. You might consider doing that if my suggestions don't work out.

Last edited by ken99; 10-21-2011 at 12:03 PM.
Reply With Quote
  #268  
Old 10-24-2011, 03:14 PM
Ironsides Ironsides is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2011
Posts: 145
Gender: Male
Vehicle: 2009 Dodge Ram 1500 CC 4X4
Trim Level: SLT Big Horn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:44
Ironsides is on a distinguished road
Default

Ken or Netman,

I wired an ITBC into my '09 Ram 1500 over the weekend. I don't have a trailer with electric brakes to test the controller on right now. I might have access to one later in the week, but for right now, I have no real way of testing the controller. When I start up my truck, all the lights on the controller come on for a few seconds, and then they all go off. After that, the controller doesn't display anything. I found this in the '10-'11 User Manual

"If no electrical connection is detected after the ignition is turned on, pressing the GAIN adjustment button or sliding the manual brake control lever will display the GAIN setting for 10 seconds and the 'Trailer Brake Status Indicator Light' will not be displayed."

When I press either of the gain adjustment buttons, or slide the manual lever, nothing happens. Is this typical for a truck that hasn't been programmed for the ITBC, and doesn't have a trailer connected, or is something not right? I have what I think is the latest controller, 56029431AH. Thanks.
Reply With Quote
  #269  
Old 10-24-2011, 07:50 PM
Ironsides Ironsides is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2011
Posts: 145
Gender: Male
Vehicle: 2009 Dodge Ram 1500 CC 4X4
Trim Level: SLT Big Horn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:44
Ironsides is on a distinguished road
Default

Small update: When the lights are on, the controller gain displays like the User Manual describes. I'm not sure if the controller shuts off when the lights are off, or if the display just turns off. I'll have to test it with an unloaded trailer later this week.
Reply With Quote
  #270  
Old 10-26-2011, 10:25 PM
ken99 ken99 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Montana
Posts: 107
Gender: Male
Vehicle: 2010 Ram 1500 Crew 4x4
Trim Level: SLT
Color: Austin Tan Pearl
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:26
ken99 is on a distinguished road
Default

When the ignition is turned on, the ITBM display will light up briefly and then go black. Pressing one of the gain control buttons or pressing on the brake over-ride level will display the present gain setting. With lights on, the +/- buttons should be lit. This is on my truck that I've never had the EVIC reprogrammed for the controller. Yes, connecting a trailer with electric brakes is the ultimate test.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:51 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum