DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram General Discussion
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Dodge Ram General Discussion General Chat about the Ram. Please look for other categories to post specific questions in.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-16-2010, 08:56 AM
DYNO DYNO is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2010
Posts: 34
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
DYNO is on a distinguished road
Default Reverse and Overdrive

Hi everyone. I have two questions:

1. I have a 2005 Dodge Ram 1500 4x4 Hemi. I noticed twice when I put it in reverse it does not catch and I have to put it into drive and back into reverse. Then it will reverse. Is this a common thing. I had a 2004 Z71 4x4 which I only had for two months and that would occasionaly do the same thing.


2. Father in law just purchased a 1998 Dodge Ram two wheel drive 4.7 engine. Apparently he has the option to engage the overdrive. Any thoughts when it comes to city driving.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 06-16-2010, 09:12 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member



 
Join Date: Nov 2009
Location: Tennessee
Age: 44
Posts: 13,211
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 15
Rep:1885
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

1. This is somewhat common because there have been engagement issues cause by filter problems. Try changing the fluid and both filters.

2. This is not possible because the 4.7 wasn't in production in '98. It wasn't offered in the Ram until 2002.

Last edited by RamTech; 06-16-2010 at 09:15 AM.
Reply With Quote
  #3  
Old 06-16-2010, 10:05 AM
chefred112's Avatar
chefred112 chefred112 is offline
Dodge Ram Forum Senior Member
 
Join Date: Feb 2009
Location: NorCal
Posts: 5,892
Gender: Male
Vehicle: 2005 Dodge Ram
Trim Level: SLT
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 10
Rep:656
chefred112 is a splendid one to beholdchefred112 is a splendid one to beholdchefred112 is a splendid one to beholdchefred112 is a splendid one to beholdchefred112 is a splendid one to beholdchefred112 is a splendid one to behold
Default

this sometimes happens with me. I have a habit now to let the truck warm up or even put it in neutral to build the line pressure up before I engage the gears...
__________________
-fast freddie- one quick 05 hemi qc...with over 250k miles on odo... on the 5.7, stoker 6.4 now...Inertia Motorsports 392 stroker
5.7 e.t.'s: 1/8 - 7.85@93.20, 1/4 - 12.10@113.96 juice - 12.96 NA... 6.4 e.t. 12.54@107 NA
2005 Dodge Ram 1500 QC SLT: 12.107 @ 113.960 MPH
Reply With Quote
  #4  
Old 06-17-2010, 12:02 AM
Ruffian11's Avatar
Ruffian11 Ruffian11 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2010
Location: Vancouver, BC
Age: 23
Posts: 1,358
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 6
Rep:140
Ruffian11 will become famous soon enoughRuffian11 will become famous soon enough
Default

I have notice that in my truck in the morning also....pop it into drive doesn't feel like it catches at all, give it some gas and im good to go!!
__________________
2005 SLT 1500 5.7L Hemi
5" Rough Country Lift, Procomp 8101 20x9 Rims, K&N CAI,Flowmaster Exhaust Cat-Back Dual Exit, 325/60/20 BFG KM2, Tonneau Cover, Bedlined, Grill Hella 500's!
Alpine CDA-9887 Headunit, Twister 300 Amp, Dual 10" MTX Thunders, Thunder Form Box
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:30 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors