DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-24-2010, 07:53 PM
EBK142 EBK142 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2009
Location: boston
Posts: 9
Gender: Male
Vehicle: 95 dodge ram, 95 honda accord.
Color: truck black, car green.
Rep Power: 0
Rep:10
EBK142 is on a distinguished road
Default Trailer turn signal not working

There was a short in the right trailer turn signal. There is now no power to the trailer plug for the right turn signal only, everything else is fine left turn signal works, right turn signal and right brake dont work on trailer only, works fine on truck. I am dumbfounded as to what could be causing this, any help?
Reply With Quote
Sponsored links
  #2  
Old 06-24-2010, 08:06 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Check your fuses. You probably blew out the right side fuse.
Reply With Quote
  #3  
Old 06-28-2010, 09:10 PM
Devster Devster is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2009
Age: 43
Posts: 1
Gender: Not Specified
Rep Power: 0
Rep:10
Devster is on a distinguished road
Default

usually a ground issue
Reply With Quote
  #4  
Old 07-14-2010, 09:15 PM
lonewolf lonewolf is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Age: 59
Posts: 7
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
lonewolf is on a distinguished road
Default

Quote:
Originally Posted by EBK142 View Post
There was a short in the right trailer turn signal. There is now no power to the trailer plug for the right turn signal only, everything else is fine left turn signal works, right turn signal and right brake dont work on trailer only, works fine on truck. I am dumbfounded as to what could be causing this, any help?
im having the same problem only on the left side checked fuses there ok
Reply With Quote
  #5  
Old 03-28-2011, 06:28 PM
rjr1214 rjr1214 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2011
Location: St Charles, MO
Age: 30
Posts: 4
Gender: Male
Vehicle: 2004 Dodge Ram Cummins
Color: Blue
Engine: 2004-2004 359ci (5.9L) Cummins ISB 600 24-Valve Diesel I6 325hp 600lb/ft (6-Speed Manual)
Rep Power: 0
Rep:10
rjr1214 is on a distinguished road
Default

I am having the same problem on the left side trailer lights... no parking light, no signal, no brake on left side... all right side trailer functions are ok, everything on the truck works (there is a different wiring system for the trailer that is separate from the truck tail lamps). Did you ever resolve the issue? I'd like to know where the problem was.
Reply With Quote
  #6  
Old 03-30-2011, 12:21 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

I can't offer much help to the OP. I don't have any wiring diagram for your model year, and can only offer the same advice you have received from RamTech. Have you checked the output at the trailer plug to determine that it's definitely the truck? Most often the trailer wiring is the problem...seldom the truck, and if the truck, it's usually a blown fuse caused by the trailer wiring.

Quote:
Originally Posted by lonewolf View Post
im having the same problem only on the left side checked fuses there ok
What year is your truck? I may have a wiring diagram and can offer some fuse #'s or things to check.

Quote:
Originally Posted by rjr1214 View Post
I am having the same problem on the left side trailer lights... no parking light, no signal, no brake on left side... all right side trailer functions are ok, everything on the truck works (there is a different wiring system for the trailer that is separate from the truck tail lamps). Did you ever resolve the issue? I'd like to know where the problem was.
I noticed your truck is a 2004. There are a numerous fuses at play.
Fuse 15 (50A) Trailer Park lamps - pre relay
Fuse 33 (20A) Trailer Park lamps - post relay
Fuse 46 (15A) Trailer Left turn
Fuse 47 (15A) Trailer Right turn

Based on your description of your problem, I think the problem is in the trailer. If the Park (tail marker) light works on the right side, then the left side issue has to be in the trailer as this is a common circuit that splits in the trailer. After fixing this, the left turn/brake light might also start functioning. First place I'd look in the trailer in the ground for the left side lighting.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #7  
Old 03-30-2011, 12:35 AM
GTyankee's Avatar
GTyankee GTyankee is online now
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,567
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2608
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

is there a possibility that 2 or more pins in the trailer connections are different than the trucks pins

you might try a different trailer, or use a friends trucks
we run into this problem often when switching one trailer to another on construction sites
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #8  
Old 03-19-2012, 02:54 PM
SwampCaptain SwampCaptain is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: Pearl River, Louisiana
Age: 37
Posts: 3
Gender: Male
Vehicle: 2004 Dodge Ram 1500 4x4
Trim Level: SLT
Color: Navy Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
SwampCaptain is on a distinguished road
Default Right side trailer lights not working due to Tipm possibly being out.

I am not sure if the OP ever found a solution to his issue, but I had same issue and came to the unfortunate conclusion it was my (t.i.p.m.) totally integrated power module. Apparently, although it is fused, the software has a counter that only allows a certain amount of faults before it shuts down that circuit. In my case, and many others I've read, the right side trailer blink/stop light. Can be left also, just depends on which one reaches that limit of faults first. I have read that it can be re-flashed, but isn't guaranteed to work and costs about $125 ish.. The new Tipm cost about $700ish..
So, until i save up that kind of money to have normal working trailer lights, i will spend about $16 on a normal taillight adapter to work my trailer off of my regular taillights and have fully functioning trailer lights at a much cheaper price. Just protect that line so faults don't get sent back to tipm from any shorts in trailer and that circuit gets shut down also.. I searched and read for about a week to figure all this out.
After i made sure all fuses were good, I used another truck on trailer to verify it was my truck and not trailer! Then I traced my factory truck side green wire all the way back to the under hood fuse box using test light to find it was dead even where it came out fuse box. I know this is reviving an old thread, but I hope this helps any future people searching same issue.. Drew

Last edited by SwampCaptain; 03-19-2012 at 02:58 PM. Reason: add paragraphs for easier reading
Reply With Quote
  #9  
Old 03-19-2012, 03:42 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Your 04 Ram does not have a TIPM. The power distribution is handled through the IPM (Integrated Power Module) and FCM (Front Control Module).

The FCM supplies the trailer light signals to operate the relays in the IPM. Each trailer lighting circuit is handled through a relay and is individually fused. There is no overload sensing or protection other than the fuses.

If the FCM is bad, no surprise. They are a common point of failure and cost about $150. The only thing the IPM does is provide a wire path for the trailer circuits, so failure at this point is 'possible' but highly unlikely.

In 2006, they introduced the TIPM that did electronic switching of the trailer lighting circuits. The TIPM does have load sensing to save itself from destruction in the event of a severe over load like a dead short in the wiring. The TIPM can be reset by removing the battery cable for a minimum of 10 minutes.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #10  
Old 03-19-2012, 06:55 PM
SwampCaptain SwampCaptain is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: Pearl River, Louisiana
Age: 37
Posts: 3
Gender: Male
Vehicle: 2004 Dodge Ram 1500 4x4
Trim Level: SLT
Color: Navy Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
SwampCaptain is on a distinguished road
Default ipm/fcm

Thanks Brad, I was about update my post again, cause I continued searching and just read that same thing on dodgetalk. I appreciate your in here as well.. I am still in awe that they wouldn't just leave this kind of vulnerable circuit fused with a user changeable relay since it is trailer wiring we are talking about..
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:07 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum