rust repair panels from LETP - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Exterior Modifications - Body Mods - Body Kits


Notices

Custom Dodge Ram Exterior Modifications - Body Mods - Body Kits All custom mods on the outside of your Dodge Ram. Custom Dodge Ram Body Kits, Custom Paint, Grilles, Camper Tops, Bed Liners, etc.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 06-28-2010, 09:50 AM
raider9701 raider9701 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2009
Age: 38
Posts: 4
Gender: Male
Rep Power: 0
Rep:10
raider9701 is on a distinguished road
Default rust repair panels from LETP

I have a 2000 Dodge Ram 1500 and started having bad rust problems. Both door bottoms (which are rusting out for everyone), rocker panels, and tailgate were really looking bad. I shopped around and wound up buying them from LETP at www.fixmyrust.com. They are a newer company with real good prices. I plan on having my truck done by the end of July, if I can get my brother to help me. I also might get a Timbren set from them before winter as I can install those myself. Now I just need to get the interior of my truck looking good!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-20-2011, 07:23 PM
Daves Ram Daves Ram is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: Plymouth, MA
Age: 63
Posts: 1
Gender: Male
Vehicle: 2000 Ram 1500
Color: Silver
Engine: 1994-2001 239ci (3.9L) Magnum V6 175hp
Rep Power: 0
Rep:10
Daves Ram is on a distinguished road
Default

2000 Ram 1500 V6 3.9 engine, two issues:

1. Loosing coolant, radiator, hoses, pump, and connections good, pressured checked to 140lb with no leaks. Adding pint to overflow bottle every two weeks, where is it going?
2. Windshield wipers when turned off stop in up position, same when windshield washer used, how do i fix this?

Thanks for the help.

God bless,

Dave
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:52 PM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors