DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8


Notices

Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!
Factory Spec: 5.7-liter HEMI® V8 engine - 390 horsepower, 407 lb-ft of torque.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-15-2010, 01:09 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default AEM brute force issue

Hi,


Today I had a garage install an aem brute force cai.

I got home and wanted to show my wife the new cai(3 hrs later) and noticed that my coolant level was at the add line. I just had my oil changed and all fluid levels were great.

Could this of happened during the install?

Any info would be appreciated.
Reply With Quote
Sponsored links
  #2  
Old 08-15-2010, 01:17 AM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default

I did this install on my 2010 R/T a couple of weeks ago. The CAI should have absolutely no bearing on your coolant level at all. Did you see a leak somewhere? How does it sound when it's running? I would just watch the coolant level the next couple of days and add water if you need to but if you don't see any leak then you probably didn't damage a hose by mistake so I think it's just a coincidence.
Reply With Quote
  #3  
Old 08-15-2010, 02:21 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

Maybe coolant leaking into the gaskets then? Oil is clear, will check for smoke in morning.
Reply With Quote
  #4  
Old 08-15-2010, 02:24 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

I can just add water to the res? I live in canada, but its summer here... should be no issues, eh? lol
Reply With Quote
  #5  
Old 08-15-2010, 09:58 AM
moparmike07's Avatar
moparmike07 moparmike07 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2010
Location: NY
Age: 25
Posts: 2,493
Gender: Male
Vehicle: 07 dodge ram 1500
Trim Level: st
Color: silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
moparmike07 will become famous soon enough
Default

Quote:
Originally Posted by tdawgg View Post
Hi,


Today I had a garage install an aem brute force cai.

I got home and wanted to show my wife the new cai(3 hrs later) and noticed that my coolant level was at the add line. I just had my oil changed and all fluid levels were great.

Could this of happened during the install?

Any info would be appreciated.
are you sure you didnt pull the wire for the coolant

Quote:
Originally Posted by tdawgg View Post
Maybe coolant leaking into the gaskets then? Oil is clear, will check for smoke in morning.
i dont think did you for some reason drain the coolant

Quote:
Originally Posted by tdawgg View Post
I can just add water to the res? I live in canada, but its summer here... should be no issues, eh? lol
ya you should be fine
__________________

2007 dodge ram 1500 quad cab 4x4 5 percent tint all around 35 percent windshield, ported tb, diablo sport, arh headers, magnaflow dual exhaust, magnaflow y pipe, krc210x cam,nitrous,CNC ported head. 4.56 motive
Reply With Quote
  #6  
Old 08-15-2010, 10:51 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

Started it up this morning and a tiny bit off white smoke right after ingnition, but nothing substantial.

No smoke but there is drops of water coming out the the magnafows when i rev to 3000 rpm.

Oil is clear.
Reply With Quote
  #7  
Old 08-15-2010, 10:55 AM
erm
Guest
 
Posts: n/a
Default

Condensation is normal in the exhaust system. It does not mean you are losing coolant.

Was the engine cold when you noticed the coolant level?
Reply With Quote
  #8  
Old 08-15-2010, 11:05 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

3 hrs after running, but my driveway is on a grade, went down to the road and the coolant is up a bit but still pretty much at the add line.

I hear a little knocking, but ive always heard a little knocking from the time i bought it. Ive read that hemis are known for this.
Reply With Quote
  #9  
Old 08-15-2010, 11:29 AM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

My OBD2 isnt picking up any codes at all. Would it be picking up something if there was a major problem?
Reply With Quote
  #10  
Old 08-15-2010, 12:44 PM
tdawgg tdawgg is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 9
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
tdawgg is on a distinguished road
Default

So when I ren theres no smoke at all but when the rpms go back to idle i see a little white smoke.

Sorry for all the questions guys.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:19 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum