DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-19-2010, 10:56 PM
chapala01 chapala01 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2010
Posts: 1
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
chapala01 is on a distinguished road
Default 2008 Dodge Ram 1500 - battery

Hello -

I have had several problems with my truck battery.

. dead battery jumped started by Dodge
. two weeks later, dead battery...towed in to Dodge and battery replaced (2) months ago
. dead battery and jumped started
. towed in to Dodge and checked voltage regulator..no problems Later the same day my wife called the Dodge Rep and she explained in ALL TRUCKs you should start your vehicle at least once every (3) days and allow the engine to run for 15 minutes.

I then called Ford and Cherolet Truck dealers and was told there was no need to start their trucks every (3) days to keep their batteries up.

Has anyone had a similar experience with their Dodge Truck batteries<


Thanks,
Reply With Quote
Sponsored links
  #2  
Old 08-19-2010, 11:05 PM
RootBeer RootBeer is offline
Dodge Ram Forum Senior Member!

 
Join Date: Jun 2010
Location: Boise, ID
Age: 57
Posts: 7,179
Gender: Male
Vehicle: 2011 Chevy 3500HD
Rep Power: 10
Rep:1287
RootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud of
Default

Starting it every 3 days is hogwash. There's something draining that battery.
__________________
Brian:
"A veteran - whether active duty, retired, national guard, or reserve - is someone who, at one point in his or her life, wrote a blank check made payable to The 'United States of America', for an amount of 'up to and including my life.'"
Reply With Quote
  #3  
Old 08-19-2010, 11:16 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Sounds like it could be a current draw , possible a bad battery (have seen it before even though it's new) , no or low amperage output from the alternator . Glad you joined us and welcome to the Z for Rams from Baltimore . If you could go to the top of the page to the User Cp and complete your profile that would be great . Helps us see what you have when your posting a question or comment . Do you have any pictures of your truck ? Have you done any mods or have plans for any ? Any of your friends have Rams ? Tell them about us . We would love to have them . You will find this site is full of a lot of talented people . So if theres any question that you need answered , just shoot away . Talk to ya soon . Tom
__________________
Reply With Quote
  #4  
Old 08-19-2010, 11:17 PM
wermbang wermbang is offline
Banned
 
Join Date: Jun 2009
Location: Iowa
Posts: 10,365
Gender: Male
Vehicle: 2001 Dodge Ram 4X4 Quad Cab
Trim Level: Sport- Off Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:1930
wermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant futurewermbang has a brilliant future
Default

Hello and welcome to the site!
Reply With Quote
  #5  
Old 08-19-2010, 11:49 PM
CajunDodge's Avatar
CajunDodge CajunDodge is offline
Administrator




 
Join Date: Jan 2009
Location: Morgan City, LA
Age: 38
Posts: 45,015
Gender: Female
Vehicle: 2008 Dodge RAM 1500
Trim Level: ST SWB Regular Cab
Color: Bright Silver Metallic
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 36
Rep:4010
CajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond reputeCajunDodge has a reputation beyond repute
Default

Hello and welcome to the forum, glad to have you! Sorry to hear about your problem, must be one heck of an annoying inconvenience there, but I agree, something is not right there. I had a slow drain on the battery in my '81 D150 and granted that truck was much older, I never could find the cause, so the only thing I found to do if I wasn't going to drive it or start it up, was disconnect the battery. You might try that until you can figure out what's wrong, but good luck and be sure to keep us posted! Lots of great people and info here, so look forward to seeing you around the Z and I hope you enjoy the site!

- Cajun
__________________
CajunDodge - 2008 Dodge RAM 1500 ST SWB, Bright Silver Metallic, Magnum V-6

New to RamForumZ? Introduce yourself in the NEWBIE CHECKIN!
Need help? PM me or leave a message on my PROFILE PAGE!
Enjoy RamForumZ? Support your forum and become a SITE SUPPORTER today!
Like a member's post? Let 'em know and add some REP POINTS!
Please be sure you understand the Ram ForumZ RULES!

Who Dat Nation Super Bowl XLIV Champions - Geaux Saints!!!

ASE certified Automotive Parts Specialist
Reply With Quote
  #6  
Old 08-20-2010, 11:52 AM
City Slicker City Slicker is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Posts: 11,861
Gender: Male
Rep Power: 13
Rep:1625
City Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant future
Default

Welcome to the forum!
Reply With Quote
  #7  
Old 08-20-2010, 12:16 PM
dodgeman70592's Avatar
dodgeman70592 dodgeman70592 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2009
Location: Youngwood, PA (currently)
Age: 34
Posts: 5,642
Gender: Male
Vehicle: 2008 Dodge Ram
Trim Level: Custom
Color: Patriot Blue
Engine: 2007-2011 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 11
Rep:1648
dodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant futuredodgeman70592 has a brilliant future
Default

Welcome to the Z!!! Glad to have ya aboard!

I agree with the above posts as well. It's possible the battery is no good even though it's new, there could be something drawing current while you arent in the truck as well. Did you try putting it on a charger? The charging systems in our trucks are different then older vehicles, meaning they are good for "surface charging". By actually putting the battery on a good trickle, you will deduct some variables. I had a similar problem, and jumpstarting (which will get ya going) is not enough, the charging system will keep it stable, but not allow a full recharge. So, you end up jumpstarting constantly.

My advice.....either get the battery checked for bad cell(s), or put it on a charger and see what happens. If the battery checks out good, then you may have to chase down the draw. Autozone offers free battery and alternator testing, just FYI....
__________________

2008 Dodge Ram 2500 4x4 CTD.....lightly modded

2008 Dodge Challenger SRT-8 #3560.....lightly modded
2013 Jeep Wrangler Rubicon....lightly modded (yeah right, it's a Jeep!)
2010 Jeep GC SRT-8.....lightly modded
Reply With Quote
  #8  
Old 10-06-2010, 01:06 AM
Hemi Rammer Hemi Rammer is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Posts: 1
Gender: Male
Vehicle: 2008 Dodge
Rep Power: 0
Rep:10
Hemi Rammer is on a distinguished road
Default 08 1500 Ram battery

Hi there,
Any luck getting your truck fixed yet? I am having the same problem. I have a 08 Ram 1500 and it just started randomly going dead on me. I had the dealer check it out and they cannot find anything wrong with it. I started monitoring the voltage with my volt meter everyday before going to bed and when I saw the voltage going down I checked for a draw and found a 2.5 amp draw. I pulled fuses until it went away and it was fuse number 11 which basically controls every module inside the truck (int. lighting, keyless entry, radio, satellite, bluetooth). I have no idea how I am going to track down which one it is or if it is the wiring. It is still under warranty but I don't know if the dealer will take what I found serious and how long it would take for it to happen to them. I have had it go for weeks with no problem and then it will do it everyday. I make sure there is nothing on when I park the truck and pop the hood so I don't disturb anything when I check the battery hood lamp is also unplugged. I am starting to suspect the radio but would hate to replace it since it is the 6 disc MP3 with Nav. Not sure if this will help you at all but is what I found so far with mine. Good Luck.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:15 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum