DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-13-2010, 08:50 PM
09 Hemi 09 Hemi is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2009
Posts: 15
Gender: Male
Rep Power: 0
Rep:14
09 Hemi is on a distinguished road
Default

What's the deal with that? The manual says charging system issue. Its got 22k miles, no problems starting or running. What would make this light turn on?

I took it to autozone to see if it was throwing a code but it came up negative. The voltage gauge was right on the first line on the left. Yesterday I went to pick it up from my wifes work to take it to the dealer and find that the light is off and the volt gauge is in the middle where its supposed to be. If it comes back on ill be taking it to the dealer asap.

Not sure where my original thread went but long story short, 09hemi 22k miles battery light came on and the voltage guage was reading low. Starting having trouble starting it, would make a grinding sound. Took it to the dealer and had the following done, found P2504 charging sys tem output high, excessive resistance in 918 feed circuit (tipm module cable loose). Next issue is transmission makes grinding noise when put into reverse, they found it to be vibration from driveshaft (which I don't think it is) and ordered me a new one. They also performed several recalls on it, HVAC control head reflash, abs module reflash, inspect loose door modling (they scratched my tint!), reseal high mounted brake light (and left the water damaged bulb in it!), inspect and retorqued toe cam bolts. ALL of that in only 22k miles! My next truck will definitly be a Ford....

Last edited by BlueJet; 09-23-2010 at 09:06 PM.
Reply With Quote
Sponsored links
  #2  
Old 09-14-2010, 07:10 PM
erik108's Avatar
erik108 erik108 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2009
Location: Waltham,MASSACHUSETTS
Age: 46
Posts: 315
Gender: Male
Vehicle: 2010 slt quad cab
Trim Level: slt
Color: mineral gray
Rep Power: 0
Rep:18
erik108 is on a distinguished road
Default

is the alternator charging ok, ? maybe a loose battery cable ? loose connection
Reply With Quote
  #3  
Old 09-14-2010, 07:19 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Check and see if it's charging . Should be 13.5 - 14.5 across the battery terminals . NOTE : WARNING : DO NOT REMOVE THE BATTERY CABLES FROM YOUR VEHICLE(S) WHILE RUNNING TO SEE IF IT IS CHARGING . YOU CAN AND WILL DO SEVERE DAMAGE TO THE ELECTRICAL SYSTEM .
__________________
Reply With Quote
  #4  
Old 09-14-2010, 09:36 PM
moparornocar72's Avatar
moparornocar72 moparornocar72 is offline
Dodge Ram Forum Member


 
Join Date: Aug 2010
Location: Auburn, AL
Age: 25
Posts: 3,666
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Big Horn
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 7
Rep:630
moparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to all
Default

If you dont feel like going to the dealership first swing by autozone or advance or w/e you have and let them run a test on it so you know somewhat is going on before going to the dealership, usually the light means the alternator isn't getting enough volts to it or isn't putting out enough. GOOD LUCK!
__________________
14.268 @ 95 MPH Full Trim

Proudly Sponsored by Bully's Performance
Reply With Quote
  #5  
Old 09-14-2010, 10:00 PM
RansRAM's Avatar
RansRAM RansRAM is offline
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,394
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 15
Rep:2463
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

^^^^^ What he said ^^^^^^ The light will come on when the alternator fails to put out enough current to maintain a charge on the battary. Sounds unusual for an 09 with only 22k on it.
__________________
New Signature Pic Pending
Shorty Antenna, Recon 3rd Brake & Xtreme LightBar, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Tints (20% frt),Bug deflector, LED Interior Lights,.
Reply With Quote
  #6  
Old 09-16-2010, 12:47 PM
CORUPTWJ's Avatar
CORUPTWJ CORUPTWJ is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2009
Location: Westerville, OH
Age: 95
Posts: 147
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: St
Color: Red
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:37
CORUPTWJ is on a distinguished road
Default

Could even be a bad battery tempature sensor.
Reply With Quote
  #7  
Old 09-16-2010, 03:47 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

According to the diagrams I'm looking at, battery temp sensors are no longer used. I haven't taken the battery out of a DS so I can't say this with 100% certainty.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:09 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum