DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-19-2010, 12:46 AM
Megaman Megaman is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: Canada
Age: 37
Posts: 2
Gender: Male
Vehicle: 2005 Dodge Ram
Trim Level: SLT
Color: Grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Megaman is on a distinguished road
Default Shifter Display on console & Intermittent Wiper Issue

Hello everyone!! Yes I'm new here and have had my Hemi for over a year now. Love the truck. Well as for my issues, my " P R N D 2 1" display does not work. A while ago it would fade on and off...and now it does not even display anything at all now. The backlights on the tach and speedometer work fine and the KMS/Trip display work fine. Kinda odd. As for my wiper issue. The low/high setting work fine but when its on any stage in the Intermittent mode fast/slow its possessed. It will wipe either 3 times or once or twice and I do not have the rain sensing windshield. The high beam and back to low beam and windshield spray work fine. Please help!
Reply With Quote
Sponsored links
  #2  
Old 10-19-2010, 09:44 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member



 
Join Date: Nov 2009
Location: Tennessee
Age: 45
Posts: 13,768
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 15
Rep:1909
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The cluster could be the source of both problems but I'm thinking the wiper issue will be a seperate problem. You need to get the cluster and BCM scanned for codes to start with.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 06:33 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors