DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical


Notices

Electrical 1st Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-21-2010, 11:38 AM
BHB BHB is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 11
Gender: Male
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
BHB is on a distinguished road
Default Have 12v, Nothing when I turn the key...

Hey guys,

I have a 1991 W150 5.2L. Recently I got in, turned the key & nothing happened; no dash lights, no radio lights, seat belt buzzer, no ECU start-up, etc. My first thought was the battery was dead, but upon inspection the battery is fine and all other lights work (headlights, interior lights, etc).

My first thought was the ignition switch was shot, so I replaced that and.... still nothing. No change.

Can anyone help clue me in on what might be wrong? Is there an ignition fuse somewhere that I can't find?

Thanks!
__________________
1991 W150 5.2L 4x4
Reply With Quote
Sponsored links
  #2  
Old 11-21-2010, 11:43 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

I don't have a diagram handy for your truck but you should start checking fuse links, fuses and connections. If you have a test light, this can help you find where you;re losing power.
Reply With Quote
  #3  
Old 11-21-2010, 12:15 PM
BHB BHB is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 11
Gender: Male
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
BHB is on a distinguished road
Default

All fuse look good (as far as I can tell) and the fuse box has 12v. Everything works except what comes on with the key. So blower motor motor works, hazard lights work, pwr locks work. Radio doesn't, windows don't, etc.

Messed up thing is: I just checked for power at the ignition switch and I have 12v coming into the switch.

Does that mean that the new ignition switch I got is faulty????

*$@#&%!!!
__________________
1991 W150 5.2L 4x4
Reply With Quote
  #4  
Old 11-21-2010, 12:36 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Check and see what's coming out of the switch and go from there.
Reply With Quote
  #5  
Old 11-21-2010, 01:18 PM
BHB BHB is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 11
Gender: Male
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
BHB is on a distinguished road
Default

Hmmm...

OK. I tested the new switch for continuity in all key placements. They all check out perfectly according to the book. Ran ground straight from the battery to the switch and still nothing.

So I have power to the switch, the switch tests perfectly, and I have a good ground, and all fuses look good.

Where the sweet hell does that leave me???
__________________
1991 W150 5.2L 4x4
Reply With Quote
  #6  
Old 11-21-2010, 01:25 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 19,069
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 20
Rep:2615
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

check for power at the starter solenoid would be my guess
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #7  
Old 11-21-2010, 01:35 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

Before getting into this too deeply , pull your battery cables loose from your battery and clean them . Even though you have some accessories working you could have a dirty enough connection thats not allowing enough current to flow through .
__________________
Reply With Quote
  #8  
Old 11-21-2010, 02:08 PM
BHB BHB is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 11
Gender: Male
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
BHB is on a distinguished road
Default

Thanks for the input guys.

I'm doubting the starter solenoid because I'm not even getting dash lights. But the headlights work and are very strong.

I misspoke earlier: I do have exactly one wire coming out of the ignition switch working: the one that powers the windows & the blower motor is working. All else (radio/dash lights/ignition) gets me nothing in any key position. All fuses for the non-working items are good.

I'f flummoxed...
__________________
1991 W150 5.2L 4x4
Reply With Quote
  #9  
Old 11-21-2010, 06:20 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

You should have several fusible links by the starter relay . They look like regular pieces of wire that burn . They may be marked . Pull on the wire itself and see if they pull apart .
__________________
Reply With Quote
  #10  
Old 11-22-2010, 01:44 PM
BHB BHB is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 11
Gender: Male
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
BHB is on a distinguished road
Default

Fixed.

All the fusible links were good, but I noticed that they all came back together into one wire that went directly to the + size of the battery. That wire had a single connector in it right next to that, when pulled apart, turned out to be really corroded. Cleaned that up and she started right up.

My only guess as to what was happening is that I was getting 12v @ the ignition switch, but it somehow wasn't enough (or enough amps) or something to jump the relays when the switch was turned to power anything...
__________________
1991 W150 5.2L 4x4
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:45 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum