DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-17-2011, 06:33 AM
delineated's Avatar
delineated delineated is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Mesa
Posts: 3
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: SLT Laramie
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
delineated is on a distinguished road
Default 99 1500 5.9 Overdrive Lock-up Problem.

Hello. I have a 99 5.9 with a overdrive issue. Was out one Saturday driving and noticed that I lost overdrive. Drove it home, let it sit till the next day. Had to get to work so drove it to work, when I left the house the truck would shift into OD fine. I drove on the highway for a little bit and when I got off it would no longer go back into overdrive. Same thing when I left. Seems like it will shift into overdrive 1 or 2 times and the next time it downshifts it will not upshift back into overdrive or lock up. Now I put the truck into the shop, had the trans completely rebuilt, he said he changed some solenoids, and I took it to the dealer to have it reflashed. Now the truck shifts like a brand new trans, except no overdrive lock-up. Same thing, drive for a few miles, then none. It will shift into 4th if I turn off the o/d switch I think. I know it acts different if I turn it off. Even my mechanic is scratching his head. What a nightmare. Thanks for reading.
Reply With Quote
Sponsored links
  #2  
Old 01-17-2011, 10:33 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by delineated View Post
It will shift into 4th if I turn off the o/d switch I think. I know it acts different if I turn it off.
It's going into overdrive with the switch in the off position? Have you had the TCM scanned? It also sounds like you may have a fluid overheating issue which will inhibit a shift into overdrive.
Reply With Quote
  #3  
Old 01-17-2011, 01:17 PM
delineated's Avatar
delineated delineated is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Mesa
Posts: 3
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: SLT Laramie
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
delineated is on a distinguished road
Default

No overdrive but it feels like it has one more gear if I leave the od switch off. I am taking it back to the mechanic today after work and he wants to change the computer out....I already took it to the dealer and had it flashed to the newest thing. One thing I havent mentioned is that the last battery that was in there leaked all over the wiring harness underneath it. When I bought it there was a CEL and had to take it in to get that fixed. It was a frayed wire underneath the battery. So we think it has something to do with that. I just dont understand why it would shift when I first take it out. Thanks for your reply.
Reply With Quote
  #4  
Old 01-19-2011, 05:15 PM
delineated's Avatar
delineated delineated is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Mesa
Posts: 3
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: SLT Laramie
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
delineated is on a distinguished road
Default

Turned out to be the, "Battery Temp Sensor"... Now for the water pump!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:00 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum