DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-22-2011, 10:58 AM
LukeSSmith81 LukeSSmith81 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Age: 33
Posts: 4
Gender: Male
Vehicle: 2007 Ram 4.7 SLT 4x4
Trim Level: SLT Big Horn
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
LukeSSmith81 is on a distinguished road
Default Cat problem I think P0430

My CEL came on the other day when it was snowing and I drove home in 4wd at about 50mph. I had checked and it was p0430. It said cat efficaincy low bank 2. Possible causes were missfire which I just put new plugs in 3 weeks ago, bad cat convertor, large vacuum leak or oil leaking into rings. I have noticed a rough idle when its cold out when first started. I have had the truck for 3 months and it seems to be fine maybe a loss of power on freeway but that might just be the 4.7. If it is the Cat I have heard by law you get a 8 yr 80mile warrenty on them. In the manual it says 5yr 50k. Does anyone know which is correct and any ideas on problem.
Reply With Quote
Sponsored links
  #2  
Old 01-22-2011, 12:25 PM
Valve's Avatar
Valve Valve is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2010
Location: Philadelphia,Pa
Age: 41
Posts: 249
Gender: Male
Vehicle: 2005 Dodge Ram 1500 Quad 4x4
Trim Level: Laramie
Color: Mineral Grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 4
Rep:141
Valve will become famous soon enoughValve will become famous soon enough
Default

possibly a O2 sensor.
Not sure on law for cat's warranty.
__________________


Line-X : Extang : Python 990 SSLCD : Tailgate Lock with Doors :
Fog Light Toggle Bypass : AeroTurbine at3030 : Tint match rear QC : SilentArmors on stock 20s(nitto and wheels in Future)
2005 Dodge Ram Service Manual
Reply With Quote
  #3  
Old 01-22-2011, 01:48 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Most likely the converter is failing. Your extended federal emissions warranty should cover the repair.
Reply With Quote
  #4  
Old 01-22-2011, 04:39 PM
Burkdadhemi's Avatar
Burkdadhemi Burkdadhemi is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2008
Location: Alabama
Age: 54
Posts: 555
Gender: Male
Vehicle: 2008 Dodge Ram 1500 4X4
Trim Level: Laramie
Color: Brilliant Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:100
Burkdadhemi will become famous soon enoughBurkdadhemi will become famous soon enough
Default

Thats the rear 02 sensor code, it's ether the sensor or the cat. Check the connection.
__________________


MagnaFlow
Airaid Jr Kit
D/S Predator
Amsoil
Reply With Quote
  #5  
Old 01-22-2011, 09:00 PM
vinces2500 vinces2500 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Pittsburgh, PA
Age: 48
Posts: 1
Gender: Male
Vehicle: 1997 ram 2500
Color: red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
vinces2500 is on a distinguished road
Default

Quote:
Originally Posted by LukeSSmith81 View Post
My CEL came on the other day when it was snowing and I drove home in 4wd at about 50mph. I had checked and it was p0430. It said cat efficaincy low bank 2. Possible causes were missfire which I just put new plugs in 3 weeks ago, bad cat convertor, large vacuum leak or oil leaking into rings. I have noticed a rough idle when its cold out when first started. I have had the truck for 3 months and it seems to be fine maybe a loss of power on freeway but that might just be the 4.7. If it is the Cat I have heard by law you get a 8 yr 80mile warrenty on them. In the manual it says 5yr 50k. Does anyone know which is correct and any ideas on problem.
8 year 80,000 US wide
Reply With Quote
  #6  
Old 01-23-2011, 09:56 AM
LukeSSmith81 LukeSSmith81 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Age: 33
Posts: 4
Gender: Male
Vehicle: 2007 Ram 4.7 SLT 4x4
Trim Level: SLT Big Horn
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
LukeSSmith81 is on a distinguished road
Default

I had another idea. Since I was in 4wd does anyone think a hub may have unsealed since they are on vacuum and threw the code? One of the possibilties was large vacuum leak.
Reply With Quote
  #7  
Old 01-23-2011, 10:09 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Vacuum is no longer used on front axle disconnects. Even if it were the problem, the downstream sensor wouldn't throw an efficiency code. Vacuum leaks are pretty much a non-factor in fuel curve calculations with a speed density fuel system.
Reply With Quote
  #8  
Old 01-23-2011, 04:32 PM
repairman003 repairman003 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Location: Nova Scotia Canada
Posts: 4
Gender: Male
Vehicle: 2003 Ram 1500 4x4 4.7 Quad
Trim Level: SLT
Color: Green Almond Bottom
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
repairman003 is on a distinguished road
Default

Where it is the rear sensor sometimes slush from the road gets splashed on them and they cool off to quick setting a code. Clear the code and see if it sets again.Then you may have a sensor or cat. problem.
Reply With Quote
  #9  
Old 01-23-2011, 04:34 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by repairman003 View Post
Where it is the rear sensor sometimes slush from the road gets splashed on them and they cool off to quick setting a code. Clear the code and see if it sets again.Then you may have a sensor or cat. problem.
You'll have to explain how that works to me. I don't see how it could set a cat efficiency code.
Reply With Quote
  #10  
Old 01-24-2011, 05:05 PM
LukeSSmith81 LukeSSmith81 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Age: 33
Posts: 4
Gender: Male
Vehicle: 2007 Ram 4.7 SLT 4x4
Trim Level: SLT Big Horn
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
LukeSSmith81 is on a distinguished road
Default

So I took it in to have it checked out since I paid for an extended warrenty. It was the p0430 code and they ran some tests and it was slightly out of line. They called the Dealer and they said they put out an update for the PCM to extend the range for the rear sensor to prevent it from throwing the code again. It is fixed for now but the tech told me to watch for it again because if it goes off again he said I have 80k on Cat for warrenty and want to make sure it gets replaced before that expires.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:34 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum