DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Towing


Notices

Towing 3rd Gen Dodge Ram Towing Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-23-2011, 06:03 PM
jonnydd jonnydd is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Posts: 2
Gender: Male
Vehicle: 2007 Dodge Ram 1500
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jonnydd is on a distinguished road
Default My Trailer brakes have stopped working

My Trailer brakes have stopped working. I have a Husky Quest brake controller which has worked perfectly for the first 8 months I owned it. On our last trip, when we went to leave, the display on the brake controller was not lighting up and the trailer brakes were not activating. When I press the manual override button on the brake controller, it does then light up on the display, but does not seem to activate the brakes. I checked the voltage at the tow plug (with no load) and with or without the brakes actuated, the voltage is about 4.4 volts DC. Does any one know what this voltage should be both with brakes on and off? Any suggestions anyone has on troubleshooting this is appreciated. I am just trying to avoid paying the dealer and having it in the shop.

Thanks,

Jonnydd
Reply With Quote
Sponsored links
  #2  
Old 01-23-2011, 06:09 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

At maximum power on the brake controller, you should have something close to battery voltage. The symptoms you describe make me think it's related to the wiring going to the stop lamp switch or the switch itself. Are you using the blue factory plug in to connect to the controller?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:21 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum