DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-26-2011, 06:57 PM
crogers1 crogers1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Colorado
Posts: 2
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
crogers1 is on a distinguished road
Default 2007 Ram Headlight issue

Hi Folks,
Thought I'd pick the brain pool here. I have a 2007 Ram SLT 4WD extended cab. Last Saturday evening while heading to Denver on I-25, the headlights (low beams) started flashing off and on. Occasionally they stayed off for quite a while. Luckily, my fogs still worked. Not certain about the high beams. I didn't think to try them at that time. Had it in to the dealer who cannot reproduce the problem, so they will do nothing.
Any suggestions?
Reply With Quote
Sponsored links
  #2  
Old 01-26-2011, 07:05 PM
erm
Guest
 
Posts: n/a
Default

Sounds like there is a short developing in the wiring harness somewhere.

Did any other items blink, i.e., cabin lights, instrument lights, etc...?
Reply With Quote
  #3  
Old 01-26-2011, 07:08 PM
crogers1 crogers1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Colorado
Posts: 2
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
crogers1 is on a distinguished road
Default

No, only the headlights were affected.
Reply With Quote
  #4  
Old 06-16-2012, 11:07 AM
brbrem's Avatar
brbrem brbrem is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: Tucson, Az
Posts: 11
Gender: Male
Vehicle: 2004 ram 1500
Rep Power: 0
Rep:10
brbrem is on a distinguished road
Default

I have the same problem! Did you ever find the cause??
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:15 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum