DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > Cummins Diesel Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-27-2011, 08:11 PM
mhillips mhillips is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Age: 24
Posts: 2
Gender: Male
Vehicle: 2001 Dodge Ram 2500
Rep Power: 0
Rep:10
mhillips is on a distinguished road
Default Problems with power

I have a 2001 Dodge Ram 2500 Cummins, and the last few nights while driving my truck I've noticed the headlights dim out every so often and when that happens the battery meter on the dash drops to about 9 or 10 and picks back up after a little bit. Yesterday I was driving around and my check gauges light came on and the power gauge dropped all the way. I drove the truck back home, which was like a twenty minute drive, and it made it without dying. I popped the hood and cleaned all the corrosion off of the terminals and the cables and started my truck. It was at about 12 volts and it ran fine for the rest day.

This morning I started her up again and everything was looking okay for about ten or fifteen minutes and then the check gauges light came on again. I drove it for about fifteen minutes until I noticed all the displays were flashing in and out. So, I pulled over and checked the batteries again. After cleaning them a second time, I could not get the truck to start. When I put the key in the ignition without starting it I got about 11 volts or so but when I tried to start it the truck would click until the power meter dropped all the way again. So I got it jump started and took it to a kragens nearby, like a mile away, and halfway there the gauges light came on again and the power dropped, but I got it there.

So I got the batteries out and took them into kragens and they tested them, Both batteries were in okay condition and I had them charge them for me. The batteries are old as shit, seeing how I have not replaced them and I've had this truck since either 2003 or 2004, but the guys at kragens said I should be able to putt around town with them. So I put the batteries in and the truck stated fine but after about five minutes or so in the parking lot the gauges light turned on again and the displays stated flickering. I asked someone inside if they could take a peek at it, so we started it and they checked the battery power and he said they were low but they were okay. I let the truck run for about ten minutes and decided to take her home.

On the way home, probably like 10 minutes in, the gauges light came on and the power dropped again. So I dragged it home and turned it off. I immediately tried to turn it on and it worked, with the power meter being up at like 12 volts or so. So I have some questions.

1. I know the batteries are super old and way past their prime, do you think it is the batteries?

2. Is the alternator jacked up? I blew my turbo out about a month ago and it blew oil everywhere and I tried to clean it up the best I could but the alternator is dirty than shit, could that have something to do with it? I wouldn't think so because it has been running fine for a month and I figure the dirt would have not made it work right from day one if that were the case.

I'm not sure what to do here. It looks like replacing the alternator will be cheaper than buying two new batteries, but the batteries are easier to replace. It's like the alternator is not charging the batteries while I drive, so that makes me believe its the alternator, but then again after draining the batteries while driving I can get tuck to start up again sometimes with 9-12 volts. Any help or ideas would be greatly appreciated.
Reply With Quote
Sponsored links
  #2  
Old 01-27-2011, 11:47 PM
erm
Guest
 
Posts: n/a
Default

It sounds like the alternator is not charging or is charging intermittently due to contamination of the windings.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering and Braking Problems 2006 Dodge 2500 Mega Cab aliciahammerich Custom Chassis - Drive Line - Suspension - Wheels and Tires - LOWERING or STANDARD 7 06-22-2013 12:22 PM
power door lock problems purodude Newbie Checkin! 18 01-23-2011 12:27 PM
power loss problems, and other questions lukc22 5.9L V8 Specific Topics 10 09-01-2010 09:25 PM
air ram power wire 4doordodge4life Dodge Ram Parts and Accessories for Sale - Trade - Want To Buy! 10 04-26-2010 10:37 AM
Won't Start!!! Please Help racer965 Electrical 13 01-21-2010 04:10 PM


Advertisement






All times are GMT -4. The time now is 11:56 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum