DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > V6 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-04-2011, 06:36 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default ABS Speed Sensor Problem?

New to this forum and my first post.

My ABS dash light and BRAKE light used to come on periodically but now stay on all of the time (been waiting for them to just burn out but they won't cooperate).

On top of that, my cruise control hasn't worked for several years now (I suppose about as long as the above lights have been staying on).

Finally, my speedo is now periodically not moving until I get going a little bit.

I stumbled on a post elsewhere on the net that seemed to describe the problems I'm having exactly. Posters said that the ABS Speed Sensor that is attached to the rear differential is the culprit. Some said they replaced this part and all was good.

Any experience/opinions with this issue and the fix?

BTW, I've got a 1999 2500 Ram with the 5.9 turbo diesel engine.

Thanks!

Gary
Reply With Quote
Sponsored links
  #2  
Old 02-04-2011, 09:04 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

It's common failure on trucks with some age on them. Get the ABS scanned and if you get the speed sensor code, give it a shot.
Reply With Quote
  #3  
Old 02-05-2011, 03:30 PM
gwtaz gwtaz is offline
Dodge Ram Forum Member
 
Join Date: Oct 2010
Location: Houston, TX
Posts: 51
Gender: Male
Vehicle: 1998 Dodge Ram 1500
Engine: 1994-2001 239ci (3.9L) Magnum V6 175hp
Rep Power: 0
Rep:35
gwtaz is on a distinguished road
Default

Same problem and it was fixed by replacing the rear axle speed sensor. DIY in my driveway for about $30
Reply With Quote
  #4  
Old 02-05-2011, 03:55 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default

First the good news. After struggling a bit to get the old sensor out, I put the new one in and it seems to have solved the ABS and Brake dash light problem.

The not so good news, or so it seems, is that the new sensor didn't fix my cruise control problem. I got excited during my test drive because the cruise control actually did work for the first time in years. However, after that one success it stopped working. The cruise light now comes on on the dash, but it doesn't engage when I hit the set button. Maybe the sensor fixed part of problem (i.e. allowing the cruise light to activate), but I guess there's another problem somewhere else.

Any suggestions about what other common problems there have been on 1999 Ram cruise controls?

Thanks!

Gary
Reply With Quote
  #5  
Old 02-07-2011, 02:22 AM
gwtaz gwtaz is offline
Dodge Ram Forum Member
 
Join Date: Oct 2010
Location: Houston, TX
Posts: 51
Gender: Male
Vehicle: 1998 Dodge Ram 1500
Engine: 1994-2001 239ci (3.9L) Magnum V6 175hp
Rep Power: 0
Rep:35
gwtaz is on a distinguished road
Default

Did you scan the truck and get a code? (OBD-II)
Reply With Quote
  #6  
Old 02-07-2011, 12:48 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default

No, it hasn't been scanned. A guy at our local NAPA store tells me that if I don't have a trouble light on the dash a code won't come up. Is that true? I also called our local Dodge dealership (the guy was a butt on the phone so I can guess how it will go if I bring him my truck-he wants $102 just to diagnose the problem-the same guy said he's NEVER heard that flashing the computer will fix a cruise control although I've read at least one post on this forum from someone who said it fixed theirs?)

The NAPA guy told me if I turn the ignition switch on and off three times a code might show up on the dash. I guys it's worth a try.

I've got an appointment with the above butt guy (we only have one Dodge dealer in this area) for this afternoon if I can't figure out the problem myself by then.....
Reply With Quote
  #7  
Old 02-07-2011, 02:32 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default

Well, so much for that theory. Turning the key on and off several times did not yield any codes.

I know I should take the driver's side battery and tray and to see what I can see. Man, I hate to do that, though. I'm a lot lazier about car repairs than I used to be. Guess that's how Dodge can get away with charging a small fortune to dx things for the lazy 8>)!
Reply With Quote
  #8  
Old 02-07-2011, 03:44 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by kuhnsmith View Post
No, it hasn't been scanned. A guy at our local NAPA store tells me that if I don't have a trouble light on the dash a code won't come up. Is that true? I also called our local Dodge dealership (the guy was a butt on the phone so I can guess how it will go if I bring him my truck-he wants $102 just to diagnose the problem-the same guy said he's NEVER heard that flashing the computer will fix a cruise control although I've read at least one post on this forum from someone who said it fixed theirs?)

The NAPA guy told me if I turn the ignition switch on and off three times a code might show up on the dash. I guys it's worth a try.

I've got an appointment with the above butt guy (we only have one Dodge dealer in this area) for this afternoon if I can't figure out the problem myself by then.....
Parts people work in parts stores for a reason - they aren't technicians. He's wrong about codes not being stored if no MIL lamp is on.
Reply With Quote
  #9  
Old 02-08-2011, 12:34 AM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default Update...

OK, I was at the Dodge dealer's service dept. today for a couple of hours. What they say they found is a bad brake switch. Seems I've read about that being an issue somewhere on this forum. Anyway, they didn't have the switch and it will be here tomorrow. Everything else checked out ok. No codes were found. Hopefully, the new switch will solve the problem and life will be blissful (or at least the long boring stretches I often drive where I REALLY miss the cruise control)!

I love my truck and it's been really dependable for the last 6+ years that I've had it. Just seems they put too many fancy electrical components in them that eventually go bad. But then, I guess that's not exactly a news flash, huh?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed sensors Really need help! jnr7510 5.2L V8 Specific Topics 7 10-20-2010 05:38 PM
2007 Ram 1500 5 Speed Auto Transmission Landngroove 5.7L V8 Specific Topics 2 09-20-2010 07:03 PM
Low Speed Knock... please help!! Buster96u 5.2L V8 Specific Topics 1 09-06-2010 05:11 PM
Speed Gun for sale Dann Miscellaneous For Sale 11 01-11-2010 10:04 PM
High speed bus, or low speed bus? smartel 2009 Dodge Ram Forum 3 06-14-2009 12:46 PM


Advertisement






All times are GMT -4. The time now is 09:37 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum