DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-23-2012, 10:20 AM
alorio1 alorio1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: La.
Age: 65
Posts: 2
Gender: Male
Vehicle: 1998 Dodge Ram 1500 SST
Trim Level: SST
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
alorio1 is on a distinguished road
Default Abs and brake light on issue fixed

My ABS and brake light stated coming on 3 weeks ago. I read up on all the possibilties that would cause this problem which was speed sensor in the differental, so I replaced it but the ABS and brake light still came on and I had no cruise control either. I replaced the pump and module over the left fender with no success. A friend of mine said his buddy who runs a small shop for auto repairs just got a new Snapon scanner that read everything on a car or truck and he was intrested in helping me trouble shoot the ABS problem wanting to check his scanner out also. The scanner read 3 codes which I probably set off when replacing the pump and bleeding the brake system. After the codes were cleared I test drove the truck and same thing happened. He then scanned the ABS system again and it said BRAKE LIGHT SWITCH CLOSED. We pressed the brakes and the brake lights were working just fine. Then we inspected the wires going to brake light switch and everything was in order. We then decided to replace the switch any way. Upon removal of the switch the was a 6 wire plug to the switch. After removing the switch the plunger was stiff and barely moved as if the sping was boken internally. We replaced the switch and cleared the code one again and now my ABS light problem has gone. Who would have ever thought a brake light switch would have caused this problem ?
Reply With Quote
Sponsored links
  #2  
Old 11-23-2012, 11:22 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member



 
Join Date: Nov 2009
Location: Tennessee
Age: 44
Posts: 13,212
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 15
Rep:1885
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

I would - but I've been in the repair business nearly 20 years...
Reply With Quote
  #3  
Old 04-09-2013, 02:34 PM
pen101 pen101 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: North Bay Ontario
Age: 52
Posts: 1
Gender: Male
Vehicle: 2004 doge ram 1500 4x4
Trim Level: Base
Color: Blue
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
pen101 is on a distinguished road
Default

If anybody watching this post....
Take truck off road for winter, "just winter beat it" left cab light on last month and battery went dead, recharged battery and on the "blindside" of the tray was a two bolt 1" square aftermarket thingy (I believe this to be part of the trailer package) I noticed after hitting it that I was not the first to hit (band-aided with silicone) it, but the "bi-metal" thingy underneath came flying out.
Turn my key to the on position and my speedo goes between 35-40kmh, and my abs and brakelight are both on.
No codes, slipt her out for a quick ten minute jog on the highway, speedo works fine but those two lights did not go out neither did any codes come up.(my cheepo code reader says computer yet to set?)
I'll throw a sticker on her and take her for another spin before I take the 55.00 out of pocket for the rear diff speed sensor which is my question...is there anyway to test this unit...by Ohms or voltage?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:36 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors