DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-14-2011, 03:01 AM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default truck wont run po300 please help and please read

i have spent lots of money on this thing and working on it when i need to be working on my openwheel dirt car.seems like i get one thing fixed then it's another thing i have code's po174,po157 and po300 at first the thing would die everytime i stoped the rpm's drop and it has got worse now it spits and sputters and missis and lost power i changed all plug's and egr valve and took out all 02 sensors and cleaned them and cleaned the throttle body.this truck did this same thing in the winter of 08 took it to dodge and they said the passenger side was dead and they never seen a hemi do this they thought the timing chain broke and wanted to tear it down so i took my truck and went home and changed all the plugs and egr valve and it fixed it been fine for the last 2 years till now and nothing seems to help please help me i dont have the funds to go buy another tote the note truck i have been thinking about cutting the cat's off it to see if that would fix it but i dont hear them making noise when i hit them but i almost think they are plugged or the torque converter is not kicking in N when i stop but that should not make it miss pop and bang and run lean i can push the gas with it in gear and foot on brake and hold it at 1500 rpm but it surges from 1100 to 1500 its that bad thanks im out of ideas
Reply With Quote
Sponsored links
  #2  
Old 02-14-2011, 08:23 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

P0157 indicates that the 2/2 signal circuit has low voltage at the PCM because it's either shorted to ground or the sensor is bad. The list of causes for the P0174 is much more extensive but a shorted signal wire is also a possible cause. Start by checking the wiring from the PCM to the passenger side sensors.

Last edited by RamTech; 02-14-2011 at 08:27 AM.
Reply With Quote
  #3  
Old 02-16-2011, 02:53 AM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default

checked it again...went to town today to get some more new spark plugs truck ran good till i left the part store pulled out onto the road it was doing something new turning 4500 rpm at 35 mph no missing,sputtering nothing. i knew i could not make it home like that then she just shut down died. pulled off road to start it back nothing but clicking noises when i turn the key and it had a bad burning smell smelled like tranny fluid. hooked jumper cables to it still nothing checked the battery good as can be.got under it with wife turning key and the clicking noise is coming from starter.so i thought starter must have hung and burnt it up.took starter off jumped it it works fine. also guages are acting crazy spiking up about half way then droping...what do i do now. im so close to throwing 5gal fuel on it and throwing a match to it. and then throwing the title on it to......thanks

Last edited by TEAMTITAN70; 02-16-2011 at 02:56 AM.
Reply With Quote
  #4  
Old 02-16-2011, 07:29 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Check the battery cables and grounds. Make sure all the connections are clean and tight.
Reply With Quote
  #5  
Old 02-16-2011, 03:11 PM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default

trust me i have checked all electrical about 100 times even replaced the battery bolts and cleaned the wire's and terminals.when i would unplug the computer it would turn off check motor light and truck would run good for about 10 miles then it would come back on and start its stupid stuff.
Reply With Quote
  #6  
Old 02-16-2011, 03:17 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

What codes are currently active?
Reply With Quote
  #7  
Old 02-16-2011, 03:29 PM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default

the ones i listed po174,po157 and po300 there is no way to get it scanned again i had to have it towed in yesterday.when you switch the key the guages jump all over the place then when u turn it over nothing but clicking and guages flickering and jumping all over.battery is good starter was making the clicking noise but it test good
Reply With Quote
  #8  
Old 02-16-2011, 08:36 PM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default

well i put the starter back on same problem then i hooked my battery charger to the battery it showed it was dead let it charge about a hour then she cranked up unhooked the n battery cable she died i guess it must have a bad alternater because if it was charging it should keep running.i guess this alternater has been going out it just took it long enough and was making everything act up because of low voltage what do you think ram tech?
Reply With Quote
  #9  
Old 02-16-2011, 09:03 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

It's possible. I don't recommend unhooking the battery while it's running to check the altertnator because of the potential of damaging a module. Pull the alternator and have it bench tested.
Reply With Quote
  #10  
Old 02-17-2011, 10:59 PM
TEAMTITAN70 TEAMTITAN70 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2011
Age: 30
Posts: 33
Gender: Male
Vehicle: 2004 dodge ram 5.7 hemi 4x4
Color: red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
TEAMTITAN70 is on a distinguished road
Default

alternator came back good so i put it back on. battery is charging put truck in gear and it will not move at all here a while back i had code p2706 and po700 which was the transmission solenoid pack i changed filters and oil and it worked till the other day when it acted up again.so i have tore the pan back off and pulled the valve body and have the solenoid pack here in the house.so i guess my question is if that solenoid pack finally went out all the way would that have caused the truck to have high rpm and shut down and can i take this solenoid pack to a transmission shop and them test it to make sure it dont work with it out of the truck.thanks
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:19 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum