DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-17-2011, 05:29 PM
Ramzy Ramzy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: edmonton
Age: 23
Posts: 19
Gender: Male
Vehicle: 2004 Dodge Ram 1500 sport Hemi
Trim Level: Hemi
Color: Black on black
Rep Power: 0
Rep:10
Ramzy is on a distinguished road
Default Had a wheel balance done know my speedo doesnt work!!

Okay so just today i had my wheels balanced and obviously the person who balanced them at kal tire was a young adolecent kid that probably knows nothing about trucks... Anywho he balanced the tires which is great buuut.. My speedo no longer works and now i have an ABS park brake light on in my dash cluster.. Can someone plz help. I need to tell this kid so he can reverse or fix it seeing as how this was caused by him.
Reply With Quote
Sponsored links
  #2  
Old 02-17-2011, 07:50 PM
Ramzy Ramzy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: edmonton
Age: 23
Posts: 19
Gender: Male
Vehicle: 2004 Dodge Ram 1500 sport Hemi
Trim Level: Hemi
Color: Black on black
Rep Power: 0
Rep:10
Ramzy is on a distinguished road
Default

okay most likely its not because of the tire balancing.. Just cause i found out where the speed sensor's are but i still do need alot of help! What can i do to get my speedometer working?
Reply With Quote
  #3  
Old 02-17-2011, 08:38 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

First thing to do would be to find out which speed sensor is at fault. Since the speedo is out, I would venture a guess that it's the output speed sensor on the side of the transmission.
Reply With Quote
  #4  
Old 02-18-2011, 12:23 PM
Ramzy Ramzy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: edmonton
Age: 23
Posts: 19
Gender: Male
Vehicle: 2004 Dodge Ram 1500 sport Hemi
Trim Level: Hemi
Color: Black on black
Rep Power: 0
Rep:10
Ramzy is on a distinguished road
Default

So would replacing it or removing it and cleaning it change things for me??
Reply With Quote
  #5  
Old 02-18-2011, 12:24 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Can't say for sure without running the actual diagnostics for whatever code is stored.
Reply With Quote
  #6  
Old 02-18-2011, 01:41 PM
Ramzy Ramzy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: edmonton
Age: 23
Posts: 19
Gender: Male
Vehicle: 2004 Dodge Ram 1500 sport Hemi
Trim Level: Hemi
Color: Black on black
Rep Power: 0
Rep:10
Ramzy is on a distinguished road
Default

i checked the codes through my scanner and got speed sensor out of range, with 0508 or something like that, and well as transmission codes that looked like 0807 or 0708. But of course im stupid and deleted it off of the computers storage base
Reply With Quote
  #7  
Old 02-18-2011, 03:04 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

None of those P codes appear to be related to speedo operation.
Reply With Quote
  #8  
Old 02-18-2011, 07:32 PM
Ramzy Ramzy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: edmonton
Age: 23
Posts: 19
Gender: Male
Vehicle: 2004 Dodge Ram 1500 sport Hemi
Trim Level: Hemi
Color: Black on black
Rep Power: 0
Rep:10
Ramzy is on a distinguished road
Default

okay I have proper "P" code.
So i got the engine light to come back on again so i recorded it properly this time and I recieved "P0501" Vehicle range sensor A range/ Performance.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where Do You Work??? MADDOG Off Topic Discussion 424 08-30-2014 07:13 PM
steering wheel has slight cockeye after 3in BL Inferno Custom Chassis - Drive Line - Suspension - Wheels and Tires - LIFTING - Dodge Ram 4x4, 2x4 6 02-04-2011 03:13 PM
When Ipod plays right speakers don't work.. But with Radio/CD all work??? JBSPartans05 Custom Dodge Ram Interior Modifications - Custom Audio / Video 8 10-01-2010 05:02 PM
Parttime Speedo Dragonslayer Electrical 8 09-08-2010 10:43 PM
steering wheel radio controls strang3majik Custom Dodge Ram Interior Modifications - Custom Audio / Video 3 05-23-2010 02:54 PM


Advertisement






All times are GMT -4. The time now is 08:59 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum