DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-19-2011, 09:12 PM
2003BlackRam 2003BlackRam is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Posts: 1
Gender: Male
Vehicle: 2003 Dodge Ram
Rep Power: 0
Rep:10
2003BlackRam is on a distinguished road
Default Having starting problems

Ok I have a 2003 Ram 1500 with a 4.7 with about 63,000 miles. It was my dad's truck since it was new. He drove it easy and was never rough or anything on it. Ok all that aside, lately its been having a hard time starting. I can turn the key on and off three or four times and then it will start but run rough for a second. That made me think that its the fuel pump, so I changed it. Immediately it started starting on your first crank. Thought my problem was fixed, a few days later the problem came back. But before i changed the fuel pump I had 1 code pop up for a day and then it went away and hasnt come back since. It was a P0301 which was a misfire in cylinder 1. Did my new fuel pump take a crap on me almost immediately or is there another problem? Also, when i checked my fuel pressure before i changed the pump it was only like 45psi which is only slightly low, and I made the mistake of not checking my fuel pressure right after the swap so im not sure of what it was right after.

And now even sometimes when I turn the key on and off 3 or 4 times it still has to crank for a few second before it fires and runs rough. Whats the deal?
Reply With Quote
Sponsored links
  #2  
Old 03-19-2011, 09:03 PM
Rammy03's Avatar
Rammy03 Rammy03 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: NC
Posts: 16
Gender: Male
Vehicle: 2003 Dodge Ram
Trim Level: SLT
Color: Tan
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Rammy03 is on a distinguished road
Default

I recommend you take off the valve cover where piston one is located and check the valve springs. Rams have had a problem with breaking valve springs, it causes the valve not to seat properly and idle and run rough. I had the same code on mine, except mine was P0308. Best of luck!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HID problems starting to unfold ScaleAton Custom Dodge Ram Interior and Exterior Lighting 6 01-17-2011 07:39 AM
starting problems!! moparmuscle Electrical 7 11-29-2010 02:50 PM
New here looking for Help !! starting problems lil bit Newbie Checkin! 18 03-19-2010 10:00 PM
Problems starting rnhansen 5.7L V8 Specific Topics 8 12-09-2009 09:29 PM
problems with starting jason75 Electrical 1 11-24-2008 06:17 PM


Advertisement






All times are GMT -4. The time now is 05:51 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum