DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-08-2011, 08:19 PM
chadartfunkal chadartfunkal is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2011
Location: florida
Posts: 3
Gender: Male
Vehicle: 1996 ram 1500
Trim Level: basic
Color: green
Engine: 1995-1997 318ci (5.2L) Natural Gas V8 200hp 430lb/ft
Rep Power: 0
Rep:10
chadartfunkal is on a distinguished road
Default 1996 ram 1500 transmission problem

My transmission started to have a slow shift , i imediately went to patrs store put in new filter and new fluid , ran it up and down road worked great made 6-8 trips letting it shift down ect , a little later ran into town pulled out from stop sign something stalled my truck went to start it and it was acting like battery was low , pushed it across road and tryed it started perfect but now i have no transmission nothing no reverse no nothing and it seems like its in neutral in every gear , funny thing is no noises at all just acts like its in neutral all the time it doesnt even try to shift , linkage is shifting on the outside but it does nothing any ideas to what happened will be truely appreciated

Last edited by chadartfunkal; 03-08-2011 at 08:21 PM. Reason: misspelling
Reply With Quote
Sponsored links
  #2  
Old 03-08-2011, 08:37 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Could be a torque converter or pump from the sound of it.
Reply With Quote
  #3  
Old 03-09-2011, 08:04 AM
98redbull2's Avatar
98redbull2 98redbull2 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2010
Location: samaria MI
Age: 21
Posts: 416
Gender: Male
Vehicle: 1998 Dodge Ram 1500 4x4
Trim Level: SLT Laramie quad cab
Color: red
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:52
98redbull2 will become famous soon enough
Default

transmission must of lost all pressure some how.
__________________
REDBULL: Red 1998 Dodge Ram 1500 SLT Laramie, 5.2L
Reply With Quote
  #4  
Old 11-15-2012, 08:33 PM
09harley 09harley is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Posts: 1
Gender: Male
Vehicle: 1996 ram 1500
Rep Power: 0
Rep:10
09harley is on a distinguished road
Default

Quote:
Originally Posted by chadartfunkal View Post
My transmission started to have a slow shift , i imediately went to patrs store put in new filter and new fluid , ran it up and down road worked great made 6-8 trips letting it shift down ect , a little later ran into town pulled out from stop sign something stalled my truck went to start it and it was acting like battery was low , pushed it across road and tryed it started perfect but now i have no transmission nothing no reverse no nothing and it seems like its in neutral in every gear , funny thing is no noises at all just acts like its in neutral all the time it doesnt even try to shift , linkage is shifting on the outside but it does nothing any ideas to what happened will be truely appreciated
Check for a transmission fuse or relay. Also it could be the ignition switch.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Ram 1500 5 Speed Auto Transmission Landngroove 5.7L V8 Specific Topics 2 09-20-2010 06:03 PM
1998 Ram 1500 electrical problem wyldelee Electrical 1 03-24-2010 11:00 PM
Dodge 1500 Transmission problems Woodyyyy 5.2L V8 Specific Topics 11 03-21-2010 10:55 AM
Largest tires and rim for 1996 1500 Lionheart Dodge Ram General Discussion 0 02-15-2009 08:27 PM
getting rid of my 1996 Dodge Ram 1500 johnnie_5 Newbie Checkin! 7 08-19-2008 04:37 PM


Advertisement






All times are GMT -4. The time now is 10:34 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum