DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram General Discussion
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Dodge Ram General Discussion General Chat about the Ram. Please look for other categories to post specific questions in.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-13-2011, 05:00 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default HID issue that needs fixing FAST please

For all you lighting pros...

Ran into an issue installing my lights. Got half way done (passenger side fog and low beam) installing my 6k lights. Specifically bought from hidextra.com cause of some reviews shows no flickering of the lights..
For those with a 4th generation truck 4 lamp, I bought just low beam kit n fogs, no high beams...you remember seeing those two circular pieces that twist that seal the outside of the housing. I cut a small hole in the low beam circular cap to feed the wiring and the bulb from HID kit. I didn't have to cut, splice, etc it was all plug and play and easy to figure out (I'm not light savy at all)

Put it all back together to test out the lights and they work. However the fogs 9145 bulbs are perfect n bright. The low beams H11 are bright but they start flickering / dimming. They do have moments where no flickering is going on and its perfect then it goes back to it. THE WEIRD thing, is when my truck is completely off and I turn my lights on, all lights work fine. As soon as I turn on my truck the passenger side starts to flicker/dim. I made sure to mount the ballasts in the same spots as the driver side. So I start thinking to myself, maybe its a bad ballast? On the flip side, a bad ballast would probably not allow the HID to run properly while my truck is off right? Could it be a bulb? Same thing, why would it be perfect when the truck is off? I am lost and annoyed with this passenger side low beam light

What did I do wrong or what can I do to fix it?

Fast replies are appreciated lol I am on shift tomorrow at the fire dept and would love for my lights to run good before I gotta be gone for 24 hours.
Reply With Quote
Sponsored links
  #2  
Old 03-13-2011, 08:22 PM
Big Daddy's Avatar
Big Daddy Big Daddy is offline
Dodge Ram Forum Senior Member


 
Join Date: Dec 2009
Location: Sweet Home Alabama
Age: 63
Posts: 1,025
Gender: Male
Vehicle: 2009 Crew Cab / 3.92 rear end
Trim Level: SLT Big Horn
Color: Stone White
Rep Power: 7
Rep:917
Big Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to beholdBig Daddy is a splendid one to behold
Default

Sounds like what my HID's did when I installed them except the fogs went in several months after the low beams (I didn't do highs). Got the flickering with engine running, didn't get the flickering on just battery on both installations. After a few crank cycles they did sort themselves out though. My thoughts is the computer had to learn the differences in power requirement from the standard to the HID's. Once it sorted it out I haven't had any more problems. Give it a few cycles and see what happens. And with that said if it doesn't work out on its own I'm pretty much useless on the problem so maybe someone else will chime in pretty soon.
__________________
Big Daddy

Marching to Mamasita's beat for a real real long time...
____________________

Dennis
Reply With Quote
  #3  
Old 03-16-2011, 12:53 PM
Barnyard's Avatar
Barnyard Barnyard is offline
Dodge Ram Forum Senior Member
 
Join Date: Oct 2009
Location: Katy, TX
Age: 42
Posts: 1,417
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Sport
Color: Bright White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 6
Rep:209
Barnyard has a spectacular aura aboutBarnyard has a spectacular aura aboutBarnyard has a spectacular aura about
Default

Quote:
Originally Posted by sryken89 View Post
For all you lighting pros...

Ran into an issue installing my lights. Got half way done (passenger side fog and low beam) installing my 6k lights. Specifically bought from hidextra.com cause of some reviews shows no flickering of the lights..
For those with a 4th generation truck 4 lamp, I bought just low beam kit n fogs, no high beams...you remember seeing those two circular pieces that twist that seal the outside of the housing. I cut a small hole in the low beam circular cap to feed the wiring and the bulb from HID kit. I didn't have to cut, splice, etc it was all plug and play and easy to figure out (I'm not light savy at all)

Put it all back together to test out the lights and they work. However the fogs 9145 bulbs are perfect n bright. The low beams H11 are bright but they start flickering / dimming. They do have moments where no flickering is going on and its perfect then it goes back to it. THE WEIRD thing, is when my truck is completely off and I turn my lights on, all lights work fine. As soon as I turn on my truck the passenger side starts to flicker/dim. I made sure to mount the ballasts in the same spots as the driver side. So I start thinking to myself, maybe its a bad ballast? On the flip side, a bad ballast would probably not allow the HID to run properly while my truck is off right? Could it be a bulb? Same thing, why would it be perfect when the truck is off? I am lost and annoyed with this passenger side low beam light

What did I do wrong or what can I do to fix it?

Fast replies are appreciated lol I am on shift tomorrow at the fire dept and would love for my lights to run good before I gotta be gone for 24 hours.
I had the same issues with my HIDeXtra kits. Ended up fixing it by going with a relay harness for the lows. This by-passes the TIPM and supplies power to the lights directly from the battery. You still use the switch as the relay trigger so everything looks stock from the outside too. I called HID eXtra and complained and she sent me the relay harness for free.

Good luck.
__________________
Yard Fear the government that fears your gun!
Undercover Tonneau, Raptor Step Bars, Volant CAI, Cabin Air Filter Add, Debadged, 5000K HID Lows & Fogs, Custom "Hitch Cubby"
Reply With Quote
  #4  
Old 03-16-2011, 01:20 PM
916Timmy's Avatar
916Timmy 916Timmy is offline
Dodge Ram Forum Senior Member

 
Join Date: Oct 2010
Location: Oklahoma City
Age: 30
Posts: 5,700
Gender: Male
Vehicle: 2010 Ram 1500 Quad Cab
Trim Level: SLT Big Horn
Color: Bright Silver Metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 9
Rep:1443
916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of916Timmy has much to be proud of
Default

http://ramforumz.com/showthread.php?t=70224
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hmmmmmm.....HID Relay Buzzing Ramathorne Custom Dodge Ram Interior and Exterior Lighting 29 03-19-2013 10:14 PM
Dealerships: A User’s Guide RootBeer Dodge Ram Knowledge Base 3 05-04-2012 05:03 PM
Bought new HID bulbs but have problems str8hemi Custom Dodge Ram Interior and Exterior Lighting 9 09-28-2011 02:39 PM
Help hid conversion kit wont work on fog lights pacificflip72 Custom Dodge Ram Interior and Exterior Lighting 22 02-09-2011 12:20 PM
Vibration Issue WickedSix 5.7L V8 Specific Topics 5 01-12-2011 11:30 PM


Advertisement






All times are GMT -4. The time now is 04:57 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors