DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram – 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-28-2011, 10:30 PM
mudgoat mudgoat is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2011
Location: Calgary
Age: 27
Posts: 4
Gender: Male
Vehicle: 2010 dodge ram 1500 sport
Trim Level: Sport
Color: Red
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
mudgoat is on a distinguished road
Default jet performance 180 thermostat question

This weekend i installed one of the jet performance thermostats, I have the stage 1 chip in my truck already. Everything seemed to work fine for the 1 or 2 i was out after installing it, but now today in the morning my truck wouldn't blow hot air and it would spike up to really hot then go back down to the medium mark then the hot air would blow, then i look down and the needle is half way between cold and medium temperature and it was blowing hot air, but then it would go back up and it would blow cold air for a bit.

Basically the temperature gauge is all over the place, and the heat is cold and hot, So i am wondering if anyone else has had the same problem as me at all when installing this or what You think could be causing this. I did put the little pin at 12 o'clock as i seen on a how to video on you tube. and the reason i changed it was because it was leaking from that housing, and it always smelt like burnt coolant, since then its stopped leaking and doesn't smell anymore.

Now i might have a big air lock but the radiator hose is full of coolant, however it hasn't sucked much out of the coolant reservoir either since i installed the new thermostat, which seems kinda weird.

Anyways if someone could give me some advice or if they have had similar problems. That would be appreciated.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 03-28-2011, 11:13 PM
jpaul51's Avatar
jpaul51 jpaul51 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2010
Location: Lubbock, TX
Age: 33
Posts: 1,299
Gender: Male
Vehicle: 2009 Ram 2500 Megacab
Trim Level: SLT
Color: Red
Engine: 2007-2011 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 5
Rep:167
jpaul51 has a spectacular aura aboutjpaul51 has a spectacular aura about
Default

Hmmmmm.... I am running that same thermostat and have had 0 issues. At running temp my gauge reads about half way between cold and half. Have you tried taking off the radiator cap and starting it up and letting it run till it reaches temp and see if the radiator level drops at all? Air in the line is the only thing that I could think of, but I am not a mechanic. I only lost about half a gallon of coolant during my swap, so I ran it to temp with cap off and added new coolant so there would be no air in the line. Hope you get that worked out. May be a defective thermostat.
__________________
2007 Ram 1500 QC - SOLD and bought a 2009 4x4 Megacab 2500 with 6.7 Cummins. Full Sinister EGR/Throttle Valve/dpf deletes, 4" Turbo back exhaust, Banks cold air intake, EFI Live tuning by Anarchy Diesel running 100hp Street tune. Peragon bed cover.
Reply With Quote
  #3  
Old 03-30-2011, 07:30 AM
chopperman chopperman is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Age: 25
Posts: 8
Gender: Male
Rep Power: 0
Rep:10
chopperman is on a distinguished road
Default

Classic example of air in the system. You introduced air into the system as soon as you took off the thermostat. Check your overflow tank to see if the level rises or not. Most likley going to have to purge the air out of it, not hard to do.
Reply With Quote
  #4  
Old 04-01-2011, 12:48 PM
ike43's Avatar
ike43 ike43 is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2010
Location: kingston on canada
Posts: 37
Gender: Male
Vehicle: 2006 1500 4x4
Trim Level: quad
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
ike43 is on a distinguished road
Default

i installed mine about a month ago and it was always steady between cold and half on the gauge, but now it moves alot from 180 to 200 when idleing, i seems that the tstat is closing and opening too much it should stay open when at 180 , it drops fast when it reaches 200 i suspect faulty t stat
Reply With Quote
  #5  
Old 04-10-2011, 01:24 AM
tmerritt530's Avatar
tmerritt530 tmerritt530 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2009
Location: Goddard, KS
Age: 25
Posts: 232
Gender: Male
Vehicle: 2004 Ram 1500 4.7L "H/O"
Trim Level: SLT
Color: Graphite Metallic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 6
Rep:91
tmerritt530 will become famous soon enough
Default

Hope you go this resolved by now...

It won't pull from the bottle very well when there is still air in the system. after the truck has cooled off, check the level and top off as necessary until the level no longer goes down. You can also run it up till the thermostat opens with the cap off to get any air out of the block.
__________________
2004 SLT RCSB 4.7L | 3.92 | OEM Off-Road wheels | Goodyear SilentArmor 285/70R17's | dumped magnaflow | H/O cams | H/O cyl heads | 10" Rockford Fosgate P1
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pcd performance stage 1 chip ? question nitro1965 Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 3 01-09-2012 12:43 AM
2002 RAM 1500 5.9L 4x4 Performance chip question MPG and HP chrome Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 18 02-08-2011 12:25 PM
Diesel Tunes Performance Chip knsram Dodge Ram General Discussion 5 02-04-2011 12:08 PM
Question on performance parts 2011 Dodge Ram R/T el RT7 Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 14 01-25-2011 06:45 PM
Have a question about my superchips programmer OTwoRam Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8 3 08-21-2009 12:16 AM


Advertisement






All times are GMT -4. The time now is 08:49 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum