DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2011 Dodge Ram Forum


Notices

2011 Dodge Ram Forum For specific discussion of the 2011 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-13-2011, 02:30 PM
garner's Avatar
garner garner is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Harker Heights, TX
Age: 19
Posts: 972
Gender: Male
Vehicle: 2012 Dodge Ram lonestar
Trim Level: Lonestar
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:46
garner is on a distinguished road
Default Resetting the evic

This afternoon my average mpg on the evic went from 15.0 to 14.4 in less than half a mile(no I didn't reset it). Seems like this has to be an error in the system, is there a way to reset it? I heard about disconnecting the battery, but don't remember which cable to unhook and for how long. Do you guys think disconnecting the battery would fix this?
__________________
2012 Ram 1500 lonestar crew cab
Gone but not forgotten:
First 2011 Ram R/T in Texas
Best time: 14.7402 @87.53 on bald goodyear fortera sl 285 45 22 in 2500 DA. Corrected to 14.301 @ 90.28
Reply With Quote
Sponsored links
  #2  
Old 07-13-2011, 03:22 PM
Upstater's Avatar
Upstater Upstater is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Upstate NY
Age: 54
Posts: 667
Gender: Male
Vehicle: 2010 Dodge Ram Hemi SLT 4x4
Trim Level: Bighorn
Color: Stone White
Rep Power: 4
Rep:132
Upstater will become famous soon enoughUpstater will become famous soon enough
Default

Quote:
Originally Posted by garner View Post
This afternoon my average mpg on the evic went from 15.0 to 14.4 in less than half a mile(no I didn't reset it). Seems like this has to be an error in the system, is there a way to reset it? I heard about disconnecting the battery, but don't remember which cable to unhook and for how long. Do you guys think disconnecting the battery would fix this?
I have a 2010 but I would imagine that they might be very similar. The mileage displays are a projection based on driving habits, so don't get too concerned. For example, when i start my truck on a cold morning I can watch the mileage counter click down almost like clockwork when the truck is idling; this doesn't happen once it warmed up, and after driving for a few miles it quickly recovers.

As far as resetting, on the '10's it's a simple as pushing the "right" button on the steering wheel.
Reply With Quote
  #3  
Old 07-13-2011, 03:25 PM
garner's Avatar
garner garner is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Harker Heights, TX
Age: 19
Posts: 972
Gender: Male
Vehicle: 2012 Dodge Ram lonestar
Trim Level: Lonestar
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:46
garner is on a distinguished road
Default

Quote:
Originally Posted by Upstater View Post
I have a 2010 but I would imagine that they might be very similar. The mileage displays are a projection based on driving habits, so don't get too concerned. For example, when i start my truck on a cold morning I can watch the mileage counter click down almost like clockwork when the truck is idling; this doesn't happen once it warmed up, and after driving for a few miles it quickly recovers.

As far as resetting, on the '10's it's a simple as pushing the "right" button on the steering wheel.
I've never seen mine drop this quick so it's worrying me. And yeah I know how to reset the avg mpg, done that when I didn't want to a couple of times lol. Just wondering if there was a way to like reset the whole evic so that the "glitch" will be fixed
__________________
2012 Ram 1500 lonestar crew cab
Gone but not forgotten:
First 2011 Ram R/T in Texas
Best time: 14.7402 @87.53 on bald goodyear fortera sl 285 45 22 in 2500 DA. Corrected to 14.301 @ 90.28
Reply With Quote
  #4  
Old 07-13-2011, 04:00 PM
snrusnak's Avatar
snrusnak snrusnak is online now
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: Orlando
Age: 27
Posts: 13,345
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: SLT
Color: White
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 12
Rep:1385
snrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud ofsnrusnak has much to be proud of
Default

The less miles you have driven since you reset the mileage it will be more sensitive to change. For example: right after filling up and resetting, if I sit in traffic for 1 mile, I basically get 0 mpg, if I jump on the highway right away I get basically like 0 mpg on the on ramp then after a mile or two of cruising its back above ten and increasing .1 every second... You can disconnect neg battery cable for 30 min this resets everything in the truck basically.
__________________
Sean

Breathing in and out is good enough for me.
Reply With Quote
  #5  
Old 07-13-2011, 04:04 PM
garner's Avatar
garner garner is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Harker Heights, TX
Age: 19
Posts: 972
Gender: Male
Vehicle: 2012 Dodge Ram lonestar
Trim Level: Lonestar
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:46
garner is on a distinguished road
Default

I haven't hit the reset button for about 2 weeks. And I'll go disconnect the neg battery cable and see if that helps
__________________
2012 Ram 1500 lonestar crew cab
Gone but not forgotten:
First 2011 Ram R/T in Texas
Best time: 14.7402 @87.53 on bald goodyear fortera sl 285 45 22 in 2500 DA. Corrected to 14.301 @ 90.28
Reply With Quote
  #6  
Old 07-13-2011, 05:03 PM
LeKy411's Avatar
LeKy411 LeKy411 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Chicago, IL
Age: 28
Posts: 461
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Sport
Color: Blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:100
LeKy411 will become famous soon enoughLeKy411 will become famous soon enough
Default

Quote:
Originally Posted by garner View Post
I haven't hit the reset button for about 2 weeks. And I'll go disconnect the neg battery cable and see if that helps
I think you are too concerned, it varies on your driving habits. Mine went from 14.5 to about 12.9 in 30 miles worth of driving. The reason being that I wasn't doing my regular commute, but stopping at stores doing a lot of on and off plus constant traffic because most intersections lost power around here.

EVIC is just a little estimator that worries people, mine will hit zero and yet I still have enough gas to go an extra 30 miles. Best method is to hand calculate it. Any abnormal driving habits and your EVIC compensates for it. Mine changes when I run the A/C.
__________________
Reply With Quote
  #7  
Old 07-13-2011, 05:04 PM
LeKy411's Avatar
LeKy411 LeKy411 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Chicago, IL
Age: 28
Posts: 461
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Sport
Color: Blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:100
LeKy411 will become famous soon enoughLeKy411 will become famous soon enough
Default

Quote:
Originally Posted by garner View Post
This afternoon my average mpg on the evic went from 15.0 to 14.4 in less than half a mile(no I didn't reset it). Seems like this has to be an error in the system, is there a way to reset it? I heard about disconnecting the battery, but don't remember which cable to unhook and for how long. Do you guys think disconnecting the battery would fix this?
If you really want, disconnect the negative battery terminal for 30 minutes. That should clear it fairly well and then it will show 15.5 (default after reset) before it adjusts so you will probably still be confused as to why its dropping.
__________________
Reply With Quote
  #8  
Old 07-13-2011, 08:21 PM
garner's Avatar
garner garner is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Harker Heights, TX
Age: 19
Posts: 972
Gender: Male
Vehicle: 2012 Dodge Ram lonestar
Trim Level: Lonestar
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:46
garner is on a distinguished road
Default

I know the evic changes but mine has never changed by .6 mpg in less than half a mile. Only time it changes rapidly is after reset or when I'm going 106 and hitting speed limiter. Neither of which I did in this less than half a mile. I put the neg cable back on and now it's reading 16 mpg
__________________
2012 Ram 1500 lonestar crew cab
Gone but not forgotten:
First 2011 Ram R/T in Texas
Best time: 14.7402 @87.53 on bald goodyear fortera sl 285 45 22 in 2500 DA. Corrected to 14.301 @ 90.28
Reply With Quote
  #9  
Old 09-26-2011, 11:08 AM
cyberpine cyberpine is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2010
Location: Miami, FL
Age: 46
Posts: 209
Gender: Male
Vehicle: 2010 Dodge Ram Quad Cab Hemi
Color: Black
Rep Power: 0
Rep:53
cyberpine will become famous soon enough
Default

I drive about 12 miles to work like 60% city and 40 slow high way.. I sometimes reset my evic as I'm leaving to see what th average MPG might. My averages can vary alot and has been getting better.. but still not where I would hope. Usually around 12.5mpg

I've seen it drop from 13.5 to 12.5 just driving up 7 floors of parking garage at the end of the trip.

And on the subject.. I'm just hitting 10k miles and just had my 3rd oil change. On some other forum I read that I should reset something .. maybe my idle for better readings or mpgs .. by holding down the trip button and then turn the key to the right on notch while parked When I did the dash RPM or speedometer (maybe both), it then does some kind of clock motion to let you its processed your request. Before doing this last night I also reset my EVIC to 0.. then got a got a phone call and forgot about it. Later that night took a very aggressive drive accross town without looking at the EVIC. This morning as I left for work, it was raining hard and traffic was a mess.. I looked at my EVIC and it read 16mpg avg??? kinda confused by this ..and it did not seem to move, so I reset it to 0.. expecting a really bad avg today as traffic was terrible.. but I got 15mpg when I usually get around 12.5. I may just be breaking in still. I thought I was going to get 18mpg, but my mpg dropped a fulll 3 mpg in stop and go traffic in the last 4 miles.

I might be obsessing over this .. but if I could get this truck to do 17mpg avg it would be awsome given it's size, weight and hp.
__________________
http://www.cyberpine.com
2012 Red Ram 1500 Hemi Regular Cab.
** PLEASE HELP .. Can I run 18x9 -12mm offset 4.5 Backspacing with 325/60/18 on a stock (no lift no level) 2wd 4th Gen RAM w/o rubbing? PLS MSG ME!
Reply With Quote
  #10  
Old 09-26-2011, 11:18 AM
JasonK94Z JasonK94Z is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Kansas City (Olathe), KS
Age: 40
Posts: 95
Gender: Male
Vehicle: 2011 Dodge Ram Outdoorsman
Trim Level: Quad Cab Outdoorsman
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:30
JasonK94Z is on a distinguished road
Default

I no longer watch that display for mpg. I keep it on the trans temp as another temp gauge to watch for good measure.
__________________
2011 Dodge Ram Quad Cab Outdoorsman
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
is EVIC accurate? FireWire 2011 Dodge Ram Forum 10 04-28-2011 01:52 PM
2010 EVIC Display??? Airdog 2010 Dodge Ram Forum 8 09-06-2010 08:44 AM
Intergrated Trailer Brake Controll on the EVIC CanadianInfernoRed 2010 Dodge Ram Forum 7 08-27-2010 07:28 PM
"Hidden" EVIC functions??? tat2dwiseguy 2009 Dodge Ram Forum 14 07-26-2010 12:38 PM
EVIC Fuel Consumption problem ajr7678 2010 Dodge Ram Forum 4 07-13-2010 01:32 AM


Advertisement






All times are GMT -4. The time now is 12:38 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum