DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-19-2011, 12:12 AM
devsoul's Avatar
devsoul devsoul is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Indiana
Age: 43
Posts: 14
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Sport
Color: Yellow
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
devsoul is on a distinguished road
Default Sucking sound after running

I am in need of some advice. My truck runs rough and is sucking massive amount of air through the IAC. It always starts and idles fine but after a few minutes it starts to run rough and sounds like there is a major vacuum leak, which goes away after another minute or two. I have changed the IAC, post converter O2 sensor and cut a section of my converter open to see if it was plugged(in which case it was completely hollow). I have just recently changed plugs(from originals to a plus four), before all this started. I originally had three codes, p0420, p1195 and p1762. Now i only get p0420 cat. effect. I also sea foamed the entire system through the brake booster line because i ran a can in my fuel one time and the problem went away.

Any advice would be greatly appreciated!
Reply With Quote
Sponsored links
  #2  
Old 07-19-2011, 02:00 AM
atvfamly atvfamly is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: southeast MI
Age: 41
Posts: 15
Gender: Male
Vehicle: 1999 Dodge Ram Sport
Color: Banana
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
atvfamly is on a distinguished road
Default

Hey, I seen that you said you changed the "post converter" O2 sensor. Did you mean pre converter, or was it the one after the cat? I had very similar issues and changed the O2 sensor before the cat, along with everything involved with the cooling system (coolant flush, hoses, coolant temp sensor, stat), but I'm pretty sure it was the O2 sensor that cured my problem.
Reply With Quote
  #3  
Old 07-19-2011, 09:51 AM
devsoul's Avatar
devsoul devsoul is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Indiana
Age: 43
Posts: 14
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Sport
Color: Yellow
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
devsoul is on a distinguished road
Default

It was the one after the converter. I was getting a catalyst effect code so I thought that was the one to change.

It does seem to either be temp. or time related. It is very consistant when it happens. Also now that I am runing the A/C all the time, I can hear the IAC open and shut when driving. It also runs rough when this is happening.

I had the thought it might be my temp. sensor, but I hate chasing my tail and spending the money on things I don't need to replace.
Reply With Quote
  #4  
Old 07-19-2011, 10:03 AM
devsoul's Avatar
devsoul devsoul is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Indiana
Age: 43
Posts: 14
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Sport
Color: Yellow
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
devsoul is on a distinguished road
Default

I drove it in to work this morning with the converter still open and had the same issue. Apparently the exhaust was not plugged.
Reply With Quote
  #5  
Old 07-19-2011, 10:06 AM
RedRam10's Avatar
RedRam10 RedRam10 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2010
Location: North Carolina
Age: 57
Posts: 8,240
Gender: Male
Vehicle: 2010 Ram Quad Cab 4x4
Trim Level: Big Horn
Color: Inferno Red Pearl
Rep Power: 10
Rep:743
RedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to behold
Default

Hi and a warm Carolina welcome to the best RAM ForumZ on the web. How about posting a few photos of your truck? I'd like to reccomend a solution but don't have one for you, however, I will askmthat you jump over to the Newbie Checkin and introduce yourself. See you round the site.
__________________
New to RamForumZ? NEWBIE CHECKIN!
Reply With Quote
  #6  
Old 07-19-2011, 10:12 AM
atvfamly atvfamly is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: southeast MI
Age: 41
Posts: 15
Gender: Male
Vehicle: 1999 Dodge Ram Sport
Color: Banana
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
atvfamly is on a distinguished road
Default

I know what you mean, hate to spend money on something that doesn't need fixing. When i changed my pre-cat O2, it also helped my mpg. I was told that the pre-cat one monitors how rich or lean the engine is running by what it senses. With my sensor being bad, it never told the IAC (idle air controller) on the back of the throttle body to lean out as the engine warmed up, which led to me having to raise the engine speed up to about 2k on the tach until it reached operating temp and would smooth out its idle. Otherwise it would run real rough, like it had a huge cam in it, all rough and lumpy. Sounds weird, but true.
Reply With Quote
  #7  
Old 07-19-2011, 10:24 AM
atvfamly atvfamly is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: southeast MI
Age: 41
Posts: 15
Gender: Male
Vehicle: 1999 Dodge Ram Sport
Color: Banana
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
atvfamly is on a distinguished road
Default

Maybe it has something to do with the fact that both of our trucks are 99 Ram Sports with the wonderful 5.9 in my young sons favorite color "banana"!
Reply With Quote
  #8  
Old 07-19-2011, 10:47 AM
devsoul's Avatar
devsoul devsoul is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Indiana
Age: 43
Posts: 14
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Sport
Color: Yellow
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
devsoul is on a distinguished road
Default

Wouldn't a bad O2 sensor throw a code? The only code I get is effect catalyst effect.
Reply With Quote
  #9  
Old 07-19-2011, 11:47 AM
atvfamly atvfamly is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: southeast MI
Age: 41
Posts: 15
Gender: Male
Vehicle: 1999 Dodge Ram Sport
Color: Banana
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
atvfamly is on a distinguished road
Default

Mine would once in a while, but sometimes be months in between throwing a code.
Reply With Quote
  #10  
Old 07-19-2011, 11:48 AM
atvfamly atvfamly is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: southeast MI
Age: 41
Posts: 15
Gender: Male
Vehicle: 1999 Dodge Ram Sport
Color: Banana
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
atvfamly is on a distinguished road
Default

What code (number) is it throwing out?
Reply With Quote
Reply

Bookmarks

Tags
5.9l, iac, o2 sensor, rough running, vacuum

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sucking sound??? bigred0603 4.7L PowerTech V8 Specific Topics 9 03-06-2011 12:58 PM
Resolved - rear end loose metal sound, reverse rubbing, burning smell jjsmithii 5.7L V8 Specific Topics 2 02-25-2011 02:13 AM
help..noticable different sound in engine nitro1965 5.7L V8 Specific Topics 4 01-19-2011 03:17 AM
Loud Whomping Sound, i'm completely stumped. Any ideas??? stlpunk13 Suspension 7 11-11-2010 03:26 PM
Headlights and running lights wont work at the same time, but work Indivdually??? komodo1982 Electrical 16 12-21-2009 08:53 PM


Advertisement






All times are GMT -4. The time now is 02:43 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum