DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-14-2011, 08:38 PM
mtmer1 mtmer1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Posts: 1
Gender: Male
Vehicle: 1996 Ram
Rep Power: 0
Rep:10
mtmer1 is on a distinguished road
Default bought a '96 ram, needs some work

I just picked up a '96 dodge ram ext cab 4x4 with 177k miles. 5.2L with an auto. It needs some work but I only paid $800 for it. First, the oil pressure gauge doesn't work. It's not reading at 0, it just doesn't work and the needle is well below 0. Where can I start at to get it working again? I am kind of thinking the pressure sensor is bad, where is it located? The 4wd doesn't work. When you put it in 4wd the front drive shaft locks in so I was thinking it is the in the front axle. Is it the same setup like a 90s jeep wrangler with the vaccum diagram and sliding collar? The cruise control doesn't work. If you turn it on the light comes on but if you try to set it at a speed it doesn't work. Finally, the transmission was supposedly rebuilt, there's no paperwork though. It seems to shift ok, I know these are pretty notorious for failure. Anything I can do to help it out? The fluid looks good, doesn't smell burnt.
Reply With Quote
Sponsored links
  #2  
Old 08-19-2011, 10:50 PM
RedRam10's Avatar
RedRam10 RedRam10 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: North Carolina
Age: 57
Posts: 8,240
Gender: Male
Vehicle: 2010 Ram Quad Cab 4x4
Trim Level: Big Horn
Color: Inferno Red Pearl
Rep Power: 10
Rep:743
RedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to beholdRedRam10 is a splendid one to behold
Default

Welcome to the site; I don't have an answer so, it's time to .................... this back to the top! Drop by the Newbie Checkin and introduce yourself. Hope to see you around!
__________________
New to RamForumZ? NEWBIE CHECKIN!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where Do You Work??? MADDOG Off Topic Discussion 424 08-30-2014 07:13 PM
New Member, First Ram- Wipers don't work elliottw Electrical 3 07-19-2011 01:26 PM
My first post... About my Ram and Work Done ramvan2500 Newbie Checkin! 14 04-24-2011 07:23 PM
reasonably priced HID kits that work. HELP! himynameis Dodge Ram Forum CANADA 4 03-16-2011 07:37 PM
Why doesnt it work piratesofwar Newbie Checkin! 14 07-15-2010 04:31 PM


Advertisement






All times are GMT -4. The time now is 09:45 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum