DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-16-2011, 01:59 PM
Vic842's Avatar
Vic842 Vic842 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Leominster, MA
Age: 38
Posts: 13
Gender: Male
Vehicle: 2000 Dodge Ram 1500 5.9L
Trim Level: SLT Laramie
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Vic842 is on a distinguished road
Default Intermittent and Windshield Washing Problem

Hey everyone

Basically I cant wash my windshield... When I push in the the washer button nothing happens... What should happen is the washer fluid sprays and the wipers turn on... I get nothing...

Didnt know I could fail state inspection because of this...

Also my intermittent wipers dont work, I have high and low speeds that work fine...

Could this be a Fuse? Switch? I am thinking its this because the wipers dont even go when i try to wash the windshield...

Any help would be awesome
Thanks,

Vic
Reply With Quote
Sponsored links
  #2  
Old 08-16-2011, 03:01 PM
Upstater's Avatar
Upstater Upstater is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2011
Location: Upstate NY
Age: 54
Posts: 667
Gender: Male
Vehicle: 2010 Dodge Ram Hemi SLT 4x4
Trim Level: Bighorn
Color: Stone White
Rep Power: 5
Rep:132
Upstater will become famous soon enoughUpstater will become famous soon enough
Default

Quote:
Originally Posted by Vic842 View Post
Hey everyone

Basically I cant wash my windshield... When I push in the the washer button nothing happens... What should happen is the washer fluid sprays and the wipers turn on... I get nothing...

Didnt know I could fail state inspection because of this...

Also my intermittent wipers dont work, I have high and low speeds that work fine...

Could this be a Fuse? Switch? I am thinking its this because the wipers dont even go when i try to wash the windshield...

Any help would be awesome
Thanks,

Vic
Hi Vic,

I'm no mechanic but I'm guessing the multifunction switch went bad. I had it happen twice on an '07.

Hope you get it resolved!
Reply With Quote
  #3  
Old 08-16-2011, 03:34 PM
platinuminjected's Avatar
platinuminjected platinuminjected is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2010
Location: Fort McMurray Alberta
Age: 30
Posts: 7,790
Gender: Male
Vehicle: 2009 dodge ram 1500
Trim Level: Sport
Color: Brilliant Black
Rep Power: 9
Rep:713
platinuminjected is a splendid one to beholdplatinuminjected is a splendid one to beholdplatinuminjected is a splendid one to beholdplatinuminjected is a splendid one to beholdplatinuminjected is a splendid one to beholdplatinuminjected is a splendid one to beholdplatinuminjected is a splendid one to behold
Default

as for it not spraying washer fluid pop open the hood and see if its spraying somewhere where it shouldnt be and check to make sure the hoses are all connected and as for the intermitten id agree with the above that its prolly in the switch
__________________
MODS... tinted windows,cf dash kit,6000 k fogs and low beam,heavy duty rubber mud flaps,recon tails 3rd break,L.E.D liscenceplate,reverse lights,factory side steps,afe intake,bakflip toneau cover,magnaflow exhaust,diablo predator,33' trail grapplers,bilstein 5100's,laminx head/fogs,shorty antenna,
Reply With Quote
  #4  
Old 08-18-2011, 12:27 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,790
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 22
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Do you have any other issues like the Dome light not working, or the headlight minder not working (sets off the dinger if you leave the lights on and open the drivers door), or the wipers don't park properly when shut off, or heated seats don't work properly, or headlights don't stay on for a minute or so if you shut the truck off before turning the headlights off.

Part of the wiper circuit uses the central timer module as do the other things I mentioned here. Although it is not like to be the issue, it doesn't hurt to rule it out before buying parts.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #5  
Old 08-18-2011, 07:04 AM
Upstater's Avatar
Upstater Upstater is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2011
Location: Upstate NY
Age: 54
Posts: 667
Gender: Male
Vehicle: 2010 Dodge Ram Hemi SLT 4x4
Trim Level: Bighorn
Color: Stone White
Rep Power: 5
Rep:132
Upstater will become famous soon enoughUpstater will become famous soon enough
Default

Quote:
Originally Posted by brad12kx View Post
Do you have any other issues like the Dome light not working, or the headlight minder not working (sets off the dinger if you leave the lights on and open the drivers door), or the wipers don't park properly when shut off, or heated seats don't work properly, or headlights don't stay on for a minute or so if you shut the truck off before turning the headlights off.

Part of the wiper circuit uses the central timer module as do the other things I mentioned here. Although it is not like to be the issue, it doesn't hurt to rule it out before buying parts.
I did not know this... good advice!
Reply With Quote
  #6  
Old 08-18-2011, 08:56 AM
Vic842's Avatar
Vic842 Vic842 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Leominster, MA
Age: 38
Posts: 13
Gender: Male
Vehicle: 2000 Dodge Ram 1500 5.9L
Trim Level: SLT Laramie
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Vic842 is on a distinguished road
Default Nope...

Thanks Brad... But all of those things that you had mentioned work properly...

I bought the new multi switch... And will be checking if there are any fuses that are for the washer fluid pump, or whatever...

Hoping the switch does the trick...
Reply With Quote
  #7  
Old 08-22-2011, 09:19 AM
Vic842's Avatar
Vic842 Vic842 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Leominster, MA
Age: 38
Posts: 13
Gender: Male
Vehicle: 2000 Dodge Ram 1500 5.9L
Trim Level: SLT Laramie
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Vic842 is on a distinguished road
Default Re-assessing situation...

Hey Brad and Everyone,

I went out and bought the Multi switch for my wipers/blinkers/etc and replaced the old one and Intermittent wipers and washing my windshield still dont work...

After further review, like you had mentioned, my chimers for leaving my interior light on, leaving my headlights on, leaving keys in the ignition when I open the doors, actually do not work...

I checked the fuses at the end of the dash and in the wipers spot was a 20A fuse and according to the panel it should be a 25A fuse, would this have made a big difference?

If the fuse wasnt a possibility, I had spoken to someone and they suggested it was probably the "intermittent governor" which I would think is the same as the "central timer module"... Where can I find one of these? Dealership? Autozone type place?

Thanks for the help guys

Vic
Reply With Quote
  #8  
Old 08-22-2011, 11:57 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,790
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 22
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Before you go out and buy a central timer module (CTM) (I believe this will be a dealership part), check Fuse 11 (10amp), Fuse 6 (25amp) and Fuse 13 (10A). These fuses should be located in the junction box on the left side of the dash. All 3 fused circuits are used by the CTM.

The windshield washer pump is not controlled or even sensed by the CTM, so this has me curious. The wash switch is sensed by the CTM, but only for the purpose of turning the wipers on. The fact that you do not have washers spraying is a different issue. I have to wonder at this point if the washer pump is not working and it is only a coincidence at this time.

BTW - how wiring savvy are you? After check the fuses, the rest of the tests will require a volt meter and an understanding of how to use it.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #9  
Old 08-23-2011, 09:56 AM
Vic842's Avatar
Vic842 Vic842 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Leominster, MA
Age: 38
Posts: 13
Gender: Male
Vehicle: 2000 Dodge Ram 1500 5.9L
Trim Level: SLT Laramie
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Vic842 is on a distinguished road
Default Mechanically v. Electrically

I will check the fuses at lunch today...

As far as wiring goes, I am not well versed at all with automobile electricals... I do know how to take directions and could probably figure it out, I have just never needed the knowledge and no one has ever told me about it much...

I can definitely get a hold of a volt meter...

The thing about the washer pump... I brought the truck back to the guy who I bought it from (he is a mechanic) and I asked him about this stuff and he checked out the washer fluid pump by messing with some plug or something that when I turned the truck on after that the washer fluid just sprayed constantly and then we turned it off and the fluid stopped... (not sure what that test was) but he said that meant that the pump should be okay... Have you heard of some sort of test like this before?

Vic
Reply With Quote
  #10  
Old 08-23-2011, 10:23 AM
Vic842's Avatar
Vic842 Vic842 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Leominster, MA
Age: 38
Posts: 13
Gender: Male
Vehicle: 2000 Dodge Ram 1500 5.9L
Trim Level: SLT Laramie
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Vic842 is on a distinguished road
Default Unplugged Washer Pump

Just got off the phone with him to see what he did exactly...

Apparently the washer pump was unplugged and he plugged it back in and it sprayed fluid non-stop... Then he unplugged it again to stop it from spraying...
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
error code list moparmike07 Dodge Ram Knowledge Base 16 02-15-2014 04:16 PM
Intermittent Wiper issue crazygreek89 Electrical 2 04-30-2011 10:43 PM
Shifter Display on console & Intermittent Wiper Issue Megaman Electrical 1 10-19-2010 09:44 AM
Windshield Wiper Problem galaine57 Cummins Diesel Specific Topics 4 09-20-2010 12:43 PM


Advertisement






All times are GMT -4. The time now is 06:57 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors