DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-24-2011, 04:29 PM
diceteach diceteach is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: las Vegas
Posts: 6
Gender: Male
Vehicle: 1994 dodge ram
Color: black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
diceteach is on a distinguished road
Unhappy Truck stalls after new drive belt?

It's a 94 dodge ram 1500 2wd 5.2 - A mechanic i'm not!! This is our third vehicle i purchased so i would quit borrowing trucks from friends. Everything was fine with this truck until I replaced the drive belt and battery. Now the idle is low (500 rpm) and it stalls under load when and only after it gets warmed up. Runs great when it starts up first thing in the morning. After it gets to operating temperature it starts to stall. Can a new drive belt screw things up like this? A new battery? (somehow messing with the computer system?)
I read the thread below and will look into vacuum leak and EGR valve. http://www.ramforumz.com/showthread.php?t=67666

Any advice will help. Thanks gang

Last edited by diceteach; 08-24-2011 at 05:54 PM.
Reply With Quote
Sponsored links
  #2  
Old 08-24-2011, 05:59 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by diceteach View Post
It's a 94 dodge ram 1500 2wd 5.2 - A mechanic i'm not!! This is our third vehicle i purchased so i would quit borrowing trucks from friends. Everything was fine with this truck until I replaced the drive belt and battery. Now the idle is low (500 rpm) and it stalls under load when and only after it gets warmed up. Runs great when it starts up first thing in the morning. After it gets to operating temperature it starts to stall. Can a new drive belt screw things up like this? A new battery? (somehow messing with the computer system?)
I read the thread below and will look into vacuum leak and EGR valve. http://www.ramforumz.com/showthread.php?t=67666

Any advice will help. Thanks gang
Take a voltmeter and connect it to the batteries terminals and read the voltage with the engine running the voltage should be around 13.5 or higher with the engine running this will tell you what voltage the alternator is producing because the alternator voltage should always be higher then the batteries if the vehicle was off so anyways try that. I don't think this is much a alternator issue but just try it anyways because you state everything just dies and sounds like alternator could be it because if the alternator can't keep the battery charged then the battery would drain and then the voltage to the computer will be to low and the computer will cut power and wamm bamm good bye car stalls.
Reply With Quote
  #3  
Old 08-24-2011, 06:14 PM
diceteach diceteach is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: las Vegas
Posts: 6
Gender: Male
Vehicle: 1994 dodge ram
Color: black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
diceteach is on a distinguished road
Default

thank you RamVan2500, I will. I might add that when the new battery went in, pepboys checked the alternator and claimed it was fine.
Reply With Quote
  #4  
Old 08-24-2011, 06:18 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by diceteach View Post
thank you RamVan2500, I will. I might add that when the new battery went in, pepboys checked the alternator and claimed it was fine.
Well their is an old saying " You want it done right, do it yourself" Well it's true, I had some tires mounted and didn't want to deal with installing the wheels myself this time and well they took the center caps off the wheels and they didn't put them on with all the mounting screws, they also didn't torque the lug nuts to 150 ft/lbs like they should have instead they torqued them 100 ft/lbs. I do all my own work but this time I wanted a brake so I just said ok let them do the fronts anyways, just check the voltage it's a good place to start remember to do it with the car on, if that all checks out then I can skip that electrical problem and look up some TSB's and see if their is a TSB then if not we can move to maybe a mechanical issue, Sometimes it's something simple like the Throttle body and IAC Valve need cleaning but it seems this stalling started after only a belt replacement and battery replacement however you can never be so sure.
Reply With Quote
  #5  
Old 08-24-2011, 06:22 PM
diceteach diceteach is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: las Vegas
Posts: 6
Gender: Male
Vehicle: 1994 dodge ram
Color: black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
diceteach is on a distinguished road
Default

It started immediately after the belt and battery change. Never had this issue beforehand.
Reply With Quote
  #6  
Old 08-24-2011, 06:24 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by diceteach View Post
It started immediately after the belt and battery change. Never had this issue beforehand.
Well first just check the alternator for the sake of it, if this checks out voltage should be around 13.5 or higher. If that checks out then your belt tensioner might be bad this is a common issue especially with vehicles around our age of 15,16 the tensioner and it's pulley gets hung up. Hey also check to make sure you router the belt properly also.
Reply With Quote
  #7  
Old 08-24-2011, 06:35 PM
diceteach diceteach is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: las Vegas
Posts: 6
Gender: Male
Vehicle: 1994 dodge ram
Color: black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
diceteach is on a distinguished road
Default

Just finished voltmeter check with neighbor, all ok. Also cut back battery wires and upgraded terminals. Belt is correct size and is on correctly no doubt. I will replace vacuum lines and clean throttle body next.
Reply With Quote
  #8  
Old 08-24-2011, 06:38 PM
diceteach diceteach is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: las Vegas
Posts: 6
Gender: Male
Vehicle: 1994 dodge ram
Color: black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
diceteach is on a distinguished road
Default

What has us stumped is that the truck runs great cold.
Reply With Quote
  #9  
Old 08-24-2011, 06:38 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by diceteach View Post
Just finished voltmeter check with neighbor, all ok. Also cut back battery wires and upgraded terminals. Belt is correct size and is on correctly no doubt. I will replace vacuum lines and clean throttle body next.
Ok after you try all this and still no good then check the belt tensioner like I said common problem. The worst of the worst in this issue would be that PCM had had it's days but I doubt that. I need you to do me a favor though I need you to look on the drivers side door pillar for the white federal sticker it will say the vin and tire pressure etc.. I need you to tell me what date the vehicle was manufactured so I can lookup the TSB's.
Reply With Quote
  #10  
Old 08-24-2011, 06:43 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by diceteach View Post
What has us stumped is that the truck runs great cold.
Ha ha, Runs great until up to temperature ok this pretty much is giving me an idea you do have a computer bound issue. I would probably first start with the air charge sensor that is screwed onto the intake manifold. Then check the coolant temperature sensor which is located on the left side of the coolant outlet housing on the block behind the accessories bracket. If the engine stalls out when it warms up then it's probably a faulty sensor of sort probably temperature but again clean the IAC Valve located on the throttle body this controls the air during idle and while driving until engine cools. You might just have a faulty sensor I know it would be odd of this because it only just started after a battery and belt but 1994 and well electronics don't last very long especially the IAC's those die after a while but I'm going to rule out as much as I can to help you.
Reply With Quote
Reply

Bookmarks

Tags
dodge truck 1500 4.7

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to keep your Ram rust free for years? Find out how, in here. ArmyofOne Dodge Ram Detailing and General Maintenance Forum 16 02-13-2014 02:27 AM
The third truck break in Seattle uktitus Off Topic Discussion 7 07-24-2011 07:00 PM
Truck dying- fuel pump? Please help :) thaduke2003 5.9L V8 Specific Topics 17 03-23-2011 11:05 PM
Returning member with 2nd truck - 1992 Dodge D250/350 w/ 5.9L Cummins Turbo Diesel Mavericke Newbie Checkin! 14 03-21-2011 11:19 PM
truck height 09 vs 11 2 wheel drive tnmopar Dodge Ram General Discussion 5 12-12-2010 08:52 PM


Advertisement






All times are GMT -4. The time now is 04:05 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum