DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > Dodge Ram Knowledge Base


Notices

Dodge Ram Knowledge Base Here you can find owner submitted how-to's for performing various mods to your Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Total Load Control!
AutoAnything
Addictive Desert Designs!
FGT Motorsport
Bayou Goat Mounts
tonneaucovered.com
Mopar Online Parts!

Reply
 
Thread Tools
  #1  
Old 06-21-2016, 10:35 AM
jacoba13 jacoba13 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2016
Location: Savannah
Age: 39
Posts: 4
Gender: Male
Vehicle: 1989 Dodge D-150
Color: red and white
Engine: 1989-1992 360ci (5.9L) LA V8 190hp
Rep Power: 0
Rep:10
jacoba13 is on a distinguished road
Default 1989 D-150 318 TBI Stalls after engine good and heated

Brief history is I bought this truck a year ago with about 120K on it. I believe it was garaged and didn't run for quite some time. Of course it ran fine on the way home. Its not an every day driver so it was some time before the issues began. Originally it began to stall on short trips around town so. Checked battery, timing, distributor, fuel filter, pressure from tank, compression, plugs, wires, coil. Replaced distributor points, coil, fuel filter, valve springs, computer, fuel pressure regulator, and ran sea foam thru tank and throttle body. Now she runs great for a while around town but begins to stall without the accelerator pressed. Once stalling begins it becomes progressively harder to start. Also I feel there is a strong fuel odor from the exhaust. I've taken it to two different mechanics and this is as far as I've come. Would greatly appreciate some advice or direction.
Reply With Quote
Sponsored links
  #2  
Old 06-21-2016, 09:57 PM
airforce26yrs's Avatar
airforce26yrs airforce26yrs is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2013
Location: Michigan
Age: 69
Posts: 521
Gender: Male
Vehicle: 2015 Ram 1500 Crew Cab
Trim Level: Outdoorsman
Color: Blue Streak
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:49
airforce26yrs is on a distinguished road
Default

Not sure if this will help, but on a 1990 custom van I had with the 318 I had a similar problem. Van would start and run fine until it started getting warm then would stall out. It seemed like it was flooding out from too much gas. I did a lot stuff to it and could not figure it out so it went to the dealer. What happened was a temp sensor (not sure which one) reversed its polarity and was making the system call for more gas the hotter it got (at least that is what the dealer told me and gave me a/the bad sensor back) Just an idea.
Reply With Quote
  #3  
Old 06-22-2016, 07:48 AM
jacoba13 jacoba13 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2016
Location: Savannah
Age: 39
Posts: 4
Gender: Male
Vehicle: 1989 Dodge D-150
Color: red and white
Engine: 1989-1992 360ci (5.9L) LA V8 190hp
Rep Power: 0
Rep:10
jacoba13 is on a distinguished road
Default

I appreciate the advice. I forgot to add that to the original post but that was an issue I had in the beginning. I had to replace the sensor and the harness.
Reply With Quote
  #4  
Old 06-22-2016, 10:33 AM
jacoba13 jacoba13 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2016
Location: Savannah
Age: 39
Posts: 4
Gender: Male
Vehicle: 1989 Dodge D-150
Color: red and white
Engine: 1989-1992 360ci (5.9L) LA V8 190hp
Rep Power: 0
Rep:10
jacoba13 is on a distinguished road
Default

In addition to original post I recently attempted to clean the EGR valve and realized someone attempted to delete it with a solid piece of gasket material. I've since read up on the why. Now my question is could that cause my issue?

Last edited by jacoba13; 06-22-2016 at 10:34 AM. Reason: misspellling
Reply With Quote
  #5  
Old 06-22-2016, 10:49 AM
Desert Ram's Avatar
Desert Ram Desert Ram is offline
WATASHA OUTLAW



 
Join Date: Dec 2014
Location: Phoenix, AZ.
Posts: 8,549
Gender: Male
Vehicle: '14 RAM 1500 R.Cab 4X4 Shorty
Trim Level: TRADESMAN
Color: FLAME RED
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 6
Rep:254
Desert Ram is a jewel in the roughDesert Ram is a jewel in the roughDesert Ram is a jewel in the rough
Default

Not sure if yours has one, I had a '72 Dart with a 318 and
it did the exact same thing, My neighbor at the time was
a die hard Mopar fan and told me to get a new blast resistor
Problem Solved and he also suggested to keep on in the glove box
__________________
**********************************************
" I've always been Crazy, But it's kept me from going Insane "
**********************************************
Reply With Quote
  #6  
Old 06-22-2016, 11:59 AM
jacoba13 jacoba13 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2016
Location: Savannah
Age: 39
Posts: 4
Gender: Male
Vehicle: 1989 Dodge D-150
Color: red and white
Engine: 1989-1992 360ci (5.9L) LA V8 190hp
Rep Power: 0
Rep:10
jacoba13 is on a distinguished road
Default

Appreciate the input I'll check that out.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 09:45 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
vB.Sponsors