DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram – 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-17-2011, 07:07 PM
mike333h mike333h is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: La Grange, North Carolina
Age: 36
Posts: 10
Gender: Male
Vehicle: 2006 Dodge Ram
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
mike333h is on a distinguished road
Default ETC light and LIMP MODE

Hey everyone,
I am posting this to try and help anyone that may be affected by this issue. Here is an explanation of what I encountered and what I have found to be the issue thus far as I think I have found the problem. Also I am trying to help anyone from spending hundreds of dollars on unnecessary expense bills. I truly hope this helps some people with this issue or at least give some direction to start looking.

I was driving about 45 to 50mph and hit a small puddle of water/bump in the road. My 2006 Ram 5.7 Hemi shut down and the electronic throttle cont light came on. I stopped and restarted and the motor was in limp mode. I rough idled back to the house about 2 miles and shut the truck off. Check engine light was on but could get no codes to kick out???? Come back out a bit later and start the truck, everything is running fine and no trouble lights on. Start driving and hit a bump in the road truck cuts out and same issue only this time I get codes to kick out. Crank shaft position sensor low voltage, oil press circuit 1 low voltage and throttle position sensor low voltage. I clean and wiggle the battery terminals and seems like they are the culprit because the truck runs great now…..well upon further investigation one of the negative terminal rings is completely corroded through so I change both terminals + and -. Certain that I have corrected the issue not even two miles down the road truck cuts out and goes into limp mode after restart. FML is all I can think. Well now I will stop boring ya’ll with this story and show you what I have found after hooking up to a diagnostic machine and finding out there were voltage fluctuations in the 5v source. Hope all can see the pictures of what Dodge’s brilliant engineers’ have done in routing wires. Oh and if you can’t tell the colors in the pics the 5v supply is the Pink and yellow wire.

Again I am just posting this to try and help someone who poss. has the same issues I was having. I had to put up with this issue for about a month now and just happened to get lucky in finding the culprit without a lot of money spent.

The location of the chaffed wire is right at the bend of the wire bundle bending back to the Crankshaft Position Sensor on the inboard side of the oil filter. And the pics of the chaffed area are after the repair.

Mike


Reply With Quote
Sponsored links
  #2  
Old 09-17-2011, 07:20 PM
mike333h mike333h is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: La Grange, North Carolina
Age: 36
Posts: 10
Gender: Male
Vehicle: 2006 Dodge Ram
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
mike333h is on a distinguished road
Default

Also for anyone changing their oil next time just check to see if there is chaffing going on here.
Reply With Quote
  #3  
Old 09-17-2011, 10:37 PM
AndyXplorer's Avatar
AndyXplorer AndyXplorer is offline
Dodge Ram Forum Member
 
Join Date: Aug 2011
Location: Worcester
Age: 32
Posts: 54
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:39
AndyXplorer is on a distinguished road
Default

nice write up man, im gonna have to check that next time i change the oil. Was the black corrugated plastic covering completeley worn thru? ill tape it up next time i go under
Reply With Quote
  #4  
Old 09-17-2011, 10:53 PM
mike333h mike333h is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: La Grange, North Carolina
Age: 36
Posts: 10
Gender: Male
Vehicle: 2006 Dodge Ram
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
mike333h is on a distinguished road
Default

Quote:
Originally Posted by AndyXplorer View Post
nice write up man, im gonna have to check that next time i change the oil. Was the black corrugated plastic covering completeley worn thru? ill tape it up next time i go under
Thanks, and yes the plastic was completly wore through. I did notice that on the front of the block there was a grey plastic clamp that went into the engine block that was broke. But looking at it before it broke it was actually pulling harder on the wire bundle against the sharp bend by the oil filter.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode toddler 5.7L V8 Specific Topics 0 03-12-2009 03:03 PM


Advertisement






All times are GMT -4. The time now is 06:22 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum