DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2010 Dodge Ram Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Place your Ad Here!

Reply
 
Thread Tools
  #1  
Old 09-29-2011, 05:43 PM
ToDieFor71 ToDieFor71 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2011
Location: Elizabeth, PA
Age: 27
Posts: 28
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Outdoorsman
Color: Mineral Gray Metallic
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
ToDieFor71 is on a distinguished road
Default Cruise control problem

Ok so I'm having problems with my cruise control sometimes it works sometimes it won't usually if I get in my truck and turn it on right away it'll stay on and I can use it whenever but if I drive for 10 mins or so it won't come on when I hit the button it won't light up on the bash or anything anyone else had a similar problem like this?
Reply With Quote
Sponsored links
  #2  
Old 09-29-2011, 05:46 PM
erm
Guest
 
Posts: n/a
Default

Nope, I've not had that happen to me ever. Sorry, I can't help ya with that one. Good luck!
Reply With Quote
  #3  
Old 10-09-2011, 08:06 PM
rettus72 rettus72 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2011
Location: wa
Age: 42
Posts: 5
Gender: Male
Vehicle: 2010 ram 1500
Trim Level: slt
Color: white
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
rettus72 is on a distinguished road
Default

mine will light up, but not work. no idea why. any help would be great, thanks
Reply With Quote
  #4  
Old 10-09-2011, 08:15 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Senior Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 26,740
Gender: Male
Vehicle: 2016 Ram Ecodiesel 2 whl drive
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 26
Rep:2890
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

I also don't have an issue
I just push the button, get up to the speed that i want & tap the lever downwards

after that i can slow down by tapping the lever down
after i use the brakes, i just tap the lever UP & it resumes cruise control, or if no brakes were used, tapping upwards increases the speed a bit
pulling the lever towards you, disables it
__________________
2016 Ram 3.0 diesel 3.55 w/LSD, G2 tonneau, Line-X, Weathertech mats, Mag-Hytec differential cover, Nfab bars, CB radio, Autonet wi-fi router, EGR bug deflector
Reply With Quote
  #5  
Old 10-13-2011, 02:12 PM
DirtyBeret's Avatar
DirtyBeret DirtyBeret is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2011
Location: Colorado
Posts: 1
Gender: Male
Vehicle: 2003 Dodge Ram 1500 4X4
Trim Level: SLT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
DirtyBeret is on a distinguished road
Default Cruise Control Shuts Down the truck...

I have a 2003 Dodge Ram 1500 5.7L. When I activate the cruise control, It shuts down the whole truck sometimes (displaying while in motion. The speed limit is 75MPH and I'll set my cruise to 80MPH. When it shuts down, I just turn the key back once and turn it back to the on position while still in motion. This only occurs in cruise control, and sometimes.... I use only premium gas.... What may be the cause of this??
Reply With Quote
  #6  
Old 10-13-2011, 05:23 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Senior Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 26,740
Gender: Male
Vehicle: 2016 Ram Ecodiesel 2 whl drive
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 26
Rep:2890
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

http://www.google.com/#hl=en&sugexp=...w=1024&bih=550

Old cruise control fix
__________________
2016 Ram 3.0 diesel 3.55 w/LSD, G2 tonneau, Line-X, Weathertech mats, Mag-Hytec differential cover, Nfab bars, CB radio, Autonet wi-fi router, EGR bug deflector
Reply With Quote
  #7  
Old 10-16-2011, 04:58 PM
rettus72 rettus72 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2011
Location: wa
Age: 42
Posts: 5
Gender: Male
Vehicle: 2010 ram 1500
Trim Level: slt
Color: white
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
rettus72 is on a distinguished road
Default

so after the dealership visit, i have the speed control module, (there term not mine) out as well as the ESP traction control module. (both being replaced) wow on a 2010?
Hopefully this works.
thanks for the help
Reply With Quote
  #8  
Old 10-16-2011, 05:24 PM
RansRAM's Avatar
RansRAM RansRAM is online now
Addicted to the Z

 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 57
Posts: 14,249
Gender: Male
Vehicle: 2017 RAM 2500 Laramie
Trim Level: Crew Cab 4X4 Laramie
Color: PXR Black
Engine: 2013-20?? 409ci (6.7L) Cummins Turbo Diesel 370hp 800lb/ft (6-Speed Automatic)
Rep Power: 19
Rep:2477
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

Quote:
Originally Posted by rettus72 View Post
so after the dealership visit, i have the speed control module, (there term not mine) out as well as the ESP traction control module. (both being replaced) wow on a 2010?
Hopefully this works.
thanks for the help
Wow, let us know if it works now. Hope their not just randomly trying stuff, sometimes their to quick to just swap the whole module.
__________________


Contact us via email at
sales@revelperformance.com
Reply With Quote
  #9  
Old 10-18-2011, 11:47 AM
TylerB's Avatar
TylerB TylerB is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Daytona Beach, FL
Age: 31
Posts: 51
Gender: Male
Vehicle: 2011 Ram Express
Color: Mineral Grey Metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:25
TylerB is on a distinguished road
Default

I had a problem with the cruise control on my 2010. The cruise icon would light up, but you could not set a speed. Turned out to be a faulty brake pedal switch that wouldn't extend out completely and my truck thought I always had my foot on the brake. Didn't figure it out till someone I knew was following me and let me know that it looked I was driving like a geezer double footing the pedals.
Reply With Quote
  #10  
Old 07-24-2015, 07:32 PM
Jesselee's Avatar
Jesselee Jesselee is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2015
Location: Calgary Alberta Canada
Age: 29
Posts: 1
Gender: Male
Vehicle: 2006
Trim Level: Reg cab short box
Color: Blak
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Jesselee is on a distinguished road
Thumbs up Stupid electrical / trans problems

Hey all , I am having the same problem , the cruse will only turn on sometimes and if I set it I only get about 4 min of cruse before it drops out , and advise would be great , thanks
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control X3RX3SRagDoll Electrical 4 03-24-2011 10:43 PM
cruise control 4rheel Electrical 1 03-18-2011 08:50 AM
Cruise Control on but doesnt set jaym40998 Newbie Checkin! 10 11-23-2010 08:48 PM
cruise control and airbag interesting tidbit mAs Electrical 2 08-14-2010 06:48 PM
cruise control bigredram Electrical 1 01-11-2009 03:25 PM


Advertisement








All times are GMT -4. The time now is 04:55 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors