DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-20-2011, 10:09 PM
DodgeGuy85's Avatar
DodgeGuy85 DodgeGuy85 is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2010
Location: West Boynton Beach,Fl
Age: 29
Posts: 83
Gender: Male
Vehicle: 1996 ram 2500 4X4
Trim Level: SLT
Color: Blue
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
DodgeGuy85 is on a distinguished road
Default Get 1 thing fixed then something else goes wrong...Need help !

Hey guys well I'm back again with yet another issue with my truck I swear if I had a grenande I would blow this thing sky high ! I currently have 238,xxx miles on my truck and just changed the trans fluid about 2 weeks ago due to getting into some deep water.I changed fluid,filter and still have some water in it i'm sure from it being in torque convertor anyways pulling out of driveway this morning I noticed when I put it in drive it did'nt want to go anywhere until It finally caught.The fluid level is fine and then it was shifting fine once I got moving and made it to work with no problems then on my way home leaving a from a light it would'nt shift into 2nd until like 3,100 rpms and started shifting hard so checked fluid again which was still fine a little milky too.So I babyed it home.Kinda wonder if it's the "TPS" that's going bad which is why it's shifting funny along with still having some water in it.Would a bad "TPS" cause shifting problems I think it would. I've also heard that changing fluid after a long time is sometimes a bad thing not sure though but I had to get the water out. I hope it did'nt screw up the tranny by doing so. I also started hearing a weird noise when I was pulling into my neighborhood which the only way I can describe is the way when the power steering fluid is low and you get that whining noise and it's not doing it when I'm turning the wheel.It's doing it in park and neutral when I revv it up. not sure if it's a pully bearing going bad but not sure how that would sound.I noticed that my power steering fluid was really low and like it also had some water in it. but it's not making any noise when I turn the wheel.Just when I'm in park or neutral and revving it up. any ideas what this noise can be ? I swear I go one step forward then get pushed 2 back ! thanks for any help on this guys ~Ronnie~

P.s I forgot to mention that I also hear the noise when I'm driving...I parked in my driveway and just revved up the motor and was hearing the noise and also when I put it into neutral same noise without touching steering wheel.any ideas ? I know that my truck has an exhaust leak could it just be from the leak getting worse and its making a louder noise when I rev it up but like I said it sounds like a whine not a squeal or anything like that. I wish there was a way to upload a video of the sound...

Last edited by DodgeGuy85; 10-20-2011 at 11:32 PM.
Reply With Quote
Sponsored links
  #2  
Old 10-21-2011, 10:34 AM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 914
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

I cant help with trans. But it sounds like if you got water in power steering pump it needs to be changed out it might be ready to burn bearing, blow seals out. Id try draining it out replace fluid and add power steering stop leak to save seals and bearing if its to late.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
One thing after another. ssteadman09 4.7L PowerTech V8 Specific Topics 5 03-14-2010 12:44 AM
Wrong octane... oops mgrasber Custom Dodge Ram Performance Mods - Engine - 5.2 Liter V8 3 12-29-2009 01:57 PM
What did I do wrong? Quiet Lunatic Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8 6 07-14-2009 10:19 AM
WTF is this thing?! RamDrvr1500 Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8 13 06-12-2009 09:49 AM
overhead temp thing? nlh8584 Electrical 2 04-27-2009 10:29 AM


Advertisement






All times are GMT -4. The time now is 02:54 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum