DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram – 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-29-2011, 01:09 PM
hymnatr hymnatr is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2011
Location: California
Age: 34
Posts: 7
Gender: Male
Vehicle: 2011 dodge ram 1500 sport crew
Color: Metallica Black
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
hymnatr is on a distinguished road
Default Heated Steering Wheel Problem

I've had my truck since April and have only had to use the heated steering wheel a couple of times. It's starting to get colder here and all of the sudden it's not working anymore. I turn it on, the light turns on, I hear it click and then it turns off. If I try and turn it on again the light turns on and off after about 5 seconds. It's 50 degrees right now and when it was working it was warmer out.

Any help or ideas?
Thanks
Reply With Quote
Sponsored links
  #2  
Old 11-02-2011, 11:52 PM
hymnatr hymnatr is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2011
Location: California
Age: 34
Posts: 7
Gender: Male
Vehicle: 2011 dodge ram 1500 sport crew
Color: Metallica Black
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
hymnatr is on a distinguished road
Default

No one has any ideas?
Reply With Quote
  #3  
Old 11-03-2011, 12:16 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Any chance you have the AC button pushed?
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #4  
Old 11-03-2011, 03:17 AM
mrcivic's Avatar
mrcivic mrcivic is offline
Dodge Ram Forum Member
 
Join Date: Apr 2011
Location: Ontario, Canada (Barrie area)
Posts: 58
Gender: Male
Vehicle: 2011 Dodge Ram Crew Laramie
Trim Level: Laramie
Color: Mineral Gray Metallic
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
mrcivic is on a distinguished road
Default

Brad might have something there, it could be something simple might be worth a read in the owners manual if you haven't already done that. If you have it should be worth a trip to the dealer, maybe a faulty relay or something.
Good luck.
Reply With Quote
  #5  
Old 11-05-2011, 11:03 AM
hymnatr hymnatr is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2011
Location: California
Age: 34
Posts: 7
Gender: Male
Vehicle: 2011 dodge ram 1500 sport crew
Color: Metallica Black
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
hymnatr is on a distinguished road
Default

I did read the manual and the only thing it said was that it might be to warm, well it was 44 this morning. As far as the a/c goes i had the heaters and the seat warmers on and it still didn't work. Was tring to not go to the dealership and hope it was something simple but I guess I'm going to have to.
Reply With Quote
  #6  
Old 11-05-2011, 01:36 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Unfortunately, it looks that way. There is everything from the control module to the clock spring to the heating element itself. Hopefully the dealer will tell you what the actual problem was. It would good information to have for the future if there is a 'common' point of failure that can be passed on to members in the years to come.

Keep us posted.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #7  
Old 01-23-2012, 10:07 PM
Mikecadt Mikecadt is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2010
Location: Glen Allen, VA
Age: 48
Posts: 2
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Inferno Red Crystal Pearl
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Mikecadt is on a distinguished road
Default

Brad,

Just wondering if you ever got your heated steering wheel issue resolved. I have an 09 and just started to have the same exact problem. It was working last week, went to turn it on this morning(34 degrees out in VA) and the light would come for about 2 secs and go back out. Fuse 36 looks to be the fuse for it and it was fine.

Let me know . Thanks
Reply With Quote
  #8  
Old 01-23-2012, 11:15 PM
Troy. Troy. is offline
Dodge Ram Forum Junior Member
 
Join Date: Oct 2011
Location: Saskatchewan, Canada
Posts: 37
Gender: Male
Vehicle: 2011 Ram
Trim Level: Sport CC 4x4
Color: Bright silver metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Troy. is on a distinguished road
Default

I actually had this problem one night last week, it was about -40*C so naturally I used the remote starter to start the truck. (heated seats and steering wheel come on automatically at a certain temp. as you know) I can't remember if I had started it twice or not from the remote, but anywho, I jumped in and the steering wheel was ice cold, tried the button and got the same results described above... Gave me a sick feeling thinking that I'd have to take my baby into the dealer. Needless to say, I shut the truck off and restarted it, worked fine since then. I don't normally use the heated steering wheel except for the first little bit of driving, then shut it off.

Not sure if this is a temperature related issue or what?
Reply With Quote
  #9  
Old 01-24-2012, 02:11 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Wasn't mine with the problem, but rather hymnatr. He hasn't posted on the forum since his last post here. Would like to know what the dealer did to repair his.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #10  
Old 01-24-2012, 01:07 PM
rcgreg rcgreg is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: calgary
Posts: 90
Gender: Male
Vehicle: 2012 Longhorn
Trim Level: longhorn
Color: Black/gold trim
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
rcgreg is on a distinguished road
Default

Hmmm, it sounds as if there is a short in the heating element, causing the breaker to trip after a few seconds, Then the breaker resets itself.



I'm afraid a trip to the dealer is needed to be sure - could be a sensor problem also - but you need to be able to query the computer codes to see. Have you checked your EVIC to see if there are any messages on it? Not sure if the system would do that - but it would be a nice feature if it did.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Swapping Infinity head units, & steering wheel audio controls Danstona Custom Dodge Ram Interior Modifications - Custom Audio / Video 12 02-21-2013 09:42 PM
Steering wheel Qúestion ccga3359 Dodge Ram General Discussion 4 04-22-2011 10:52 PM
built in steering wheel controls Skillets Custom Dodge Ram Interior Modifications - Custom Audio / Video 2 04-16-2011 02:25 PM
4 Wheel Drive problem...I think!?! zxtuner85 5.7L V8 Specific Topics 5 12-16-2010 07:50 AM
Steering problem?? patrickh Suspension 2 02-12-2010 10:09 PM


Advertisement






All times are GMT -4. The time now is 03:29 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum