DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-26-2011, 06:58 PM
eunospeed eunospeed is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2011
Location: Lexington, KY
Posts: 26
Gender: Male
Vehicle: 2004 Ram 1500
Trim Level: ST
Color: Champagne
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:10
eunospeed is on a distinguished road
Default Replaced altenator and now...........

Guys, truck died while I was driving home on Monday night. Shut off in the middle of the road at night ;-( From the symptoms I was confident it was the altenator. Had it checked and the guys at Oreily's said it was bad so I bought a new one. Installed it today and I'm having the same symptoms as I was before. I let it idle for close to an hour, checked the voltage at the battery terminals and it showed around 14 volts (while running), so I think eveything is good. Then I notice all my lights are flickering and the dash voltage gauge is showing just a tick below the halfway mark. It WILL NOT restart, same as before. The battery shows green and is also showing 12 volts at the terminals. Any idea what else it could be? Can the battery show 12V and still be way down on amps? I would think if things were working correctly it would have charged while idling for close to an hour.
Reply With Quote
Sponsored links
  #2  
Old 11-26-2011, 07:10 PM
eunospeed eunospeed is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2011
Location: Lexington, KY
Posts: 26
Gender: Male
Vehicle: 2004 Ram 1500
Trim Level: ST
Color: Champagne
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:10
eunospeed is on a distinguished road
Default

Just posted in the 3rd gen section...............
Reply With Quote
  #3  
Old 11-26-2011, 08:55 PM
Warlock III Warlock III is offline
Banned
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,867
Gender: Male
Vehicle: 95
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Default

Not much on the 3rd Gen...However if it'd been a 2nd I'd say starter. Maybe it's still the same in a 3G.

Or the + is grounded somewhere.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:21 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors