DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Powertrain > 5.7L (345 cu in) HEMI V8 Specific Topics
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-17-2013, 11:25 AM
BremboD's Avatar
BremboD BremboD is offline
Dodge Ram Forum Member
 
Join Date: Jul 2012
Location: Surrey B.C.
Age: 25
Posts: 50
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Sport Quad Cab
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:58
BremboD will become famous soon enough
Default Coasting stall

Being a member for a while, I was hoping this wasn't going to be one of my first posts! But here we are.

I have a 2012 ram 1500 sport 5.7L, and over the last few months it has "stalled" out on my at random about 3 times now. Usually this occurs while coasting or braking, is very unpredictable when it happens, and shows no warning signs. The truck shuts off as if I turned the ignition off. The dashboards lights all turn off, engine light off, radio off, etc. And with that is the power steering and power braking! The truck runs fine otherwise, no rough idle or acceleration problems. After it stalls, I can throw it in park or neutral, and it fires up right away.

Of course since it is an intermittent issue, when I bring it into the dealership and they can't duplicate the issue, they are going to just turn me around and send me on my not so merry way!

So I need to figure out a solution be it myself, or VIA the dealership. A google search showed up no issues similar to what I am experiencing. Had anyone here on this forum experienced this issue or heard of anyone that has had this happen? Or if anyone has an idea of how to approach the dealership or a possible solution, I am all ears. I'm feeling that the Computer is just shutting down?

EDIT: I just realized that there is other postings on this forums regarding this issue. Sorry guys!

Last edited by BremboD; 12-17-2013 at 11:41 AM.
Reply With Quote
Sponsored links
  #2  
Old 12-18-2013, 02:18 PM
hydrex's Avatar
hydrex hydrex is offline
Dodge Ram Forum Senior Member
 
Join Date: Sep 2009
Location: Penobscot, Maine
Age: 64
Posts: 2,388
Gender: Male
Vehicle: 2005 QC 4X4 HEMI RAM
Trim Level: Thunder Road
Color: Mineral Grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:427
hydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nice
Default

If the dealer can't find it, maybe buy a Diablo tuner and if you are a lot smarter than me you can fix it in the tuning , or perhaps find a good CMR tuner like hemituner here. When I did the relatively hot cam swap, my truck wouldn't even start. Within 30 minutes my dyno tuner guy (TDP) had it running better than ever. I can't believe that such a hot cam runs smoother than stock, yet picked so much top end power. I think you might just need to add a wee bit more fuel, or perhaps a small vaccum leak.
__________________
Inertia Spartan Plus cam, Circle D 3,000 rpm stall converter,Sonnax line pressure booster, MagHytec 68RE pan,and differential cover, Vararam, JBA's with cut outs, Rancho 9000's,3:92's, extra rear leaf.Line-X Bedliner,GY Armortracs, 210,000 miles To Hell and back. 14.2/96 mph NEDW
Reply With Quote
  #3  
Old 12-19-2013, 06:32 PM
Outoftheblue Outoftheblue is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Mass
Posts: 26
Gender: Male
Vehicle: 2012 Ram
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Outoftheblue is on a distinguished road
Default

few things i can think of:

any codes being thrown? can you hook it up to a scan tool and see if there are any pending codes? some local places will do this for 50 bucks or so, then at least you have an idea. the problem sounds electrical.

second, have you looked into having your alternator load tested? could have been you had alot of stuff running in the truck at the time (radio, lights, phone, etc) and the alternator just got temporarily overloaded. you can find how to do it on youtube im sure.

there also could be a glitch in software somewhere. i've heard of doiing factory reset's by taking off the terminals off the battery and letting the truck completely run out of juice (say an hour) then reconnecting the battery terminals. that will reset the computers and it may help. look that up before you do it. i have never done it, just heard of it.

good luck
Reply With Quote
  #4  
Old 01-02-2014, 01:49 PM
southerncomfort southerncomfort is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Atlanta, Ga
Posts: 4
Gender: Male
Vehicle: 1997 Dodge Ram 1500 Laramie V8
Color: White
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
southerncomfort is on a distinguished road
Default

My '97 has been doing the same thing. It shuts off when I put it in Reverse or when idling or taking off from a stop. I just got off the phone with the mechanic who drove it and could not find anything wrong with it.
Reply With Quote
  #5  
Old 01-03-2014, 07:31 AM
BremboD's Avatar
BremboD BremboD is offline
Dodge Ram Forum Member
 
Join Date: Jul 2012
Location: Surrey B.C.
Age: 25
Posts: 50
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Sport Quad Cab
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:58
BremboD will become famous soon enough
Default

I haven't had a chance to bring this into a dealer yet, but she hasn't stalled on me again.

The only thing I can think of to cause this with the timeline, would be the oversized tires. I haven't had the ECU flashed to the new tire size, so I'm wondering if the shift points are acting a little weird. After thinking more in depth, it also seems like it only does it when I start slowing gradually while the truck is in MDS. Hmm...

I think the solution to my problem may in fact be getting a tuner, adjusting my tire size, and adding a few extra horses under the hood.
Reply With Quote
  #6  
Old 01-03-2014, 09:37 PM
ericlee9386's Avatar
ericlee9386 ericlee9386 is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2010
Location: Ruston, La
Age: 28
Posts: 296
Gender: Male
Vehicle: 2011 Dodge Ram
Trim Level: Big Horn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:36
ericlee9386 is on a distinguished road
Default

I have the same issue. I have read a lot of threads that point to this being a tranny filter issue. I'm changing mine on Tuesday. Try checking your tranny fluid for bubbles it seems to be a sign. Hope this helps
__________________
Performance mods
2800 stall, moes ported throttle body, vararam intake, ARH LT, Flowmaster 10 series, Hemifever tune.
Best 1/4 mile: 14.30 @91 mph soon to be 13's
Reply With Quote
  #7  
Old 01-04-2014, 04:58 AM
BremboD's Avatar
BremboD BremboD is offline
Dodge Ram Forum Member
 
Join Date: Jul 2012
Location: Surrey B.C.
Age: 25
Posts: 50
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Sport Quad Cab
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:58
BremboD will become famous soon enough
Default

Quote:
Originally Posted by ericlee9386 View Post
I have the same issue. I have read a lot of threads that point to this being a tranny filter issue. I'm changing mine on Tuesday. Try checking your tranny fluid for bubbles it seems to be a sign. Hope this helps
Do you have any links to these threads? Interesting. Will be checking on that one.
Thanks for the tip!
Reply With Quote
  #8  
Old 01-05-2014, 01:55 PM
southerncomfort southerncomfort is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Atlanta, Ga
Posts: 4
Gender: Male
Vehicle: 1997 Dodge Ram 1500 Laramie V8
Color: White
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
southerncomfort is on a distinguished road
Default

Just wanted to check back in and report that the TPS sensor change did the trick. My truck idles smoothly and does not stall or shut off as it was doing before, ie at stop, inclines, turning left and reverse.

The sensor costs $37.00 at O'rileys or $32.00 at Auto Zone. I chose O'riley as I find the guys there tend to be a bit more knowledgeable.

I used the YouTube links below as a reference. The sensor did come with installation instructions but the vids really help.





Note that some mechanics ie, my one of my friends and as one of the vids shown above will tell you the throttle bodies need to be cleaned. I did NOT have to do that. The sensor change was all that was necessary. This of course could be case by case basis but in my experience it's always better to start with the easiest fix first and go from there.

Hope this helps.
Reply With Quote
  #9  
Old 01-28-2014, 10:47 AM
theTANK theTANK is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Minneapolis
Posts: 11
Gender: Male
Vehicle: 2011 Dodge Ram
Color: BLACK
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
theTANK is on a distinguished road
Default

Same Issue!

My 2011 5.7 will stall out at a complete stop and ONLY when I come to a complete stop. I can roll and I have no issues. I can even pop it into Neutral and it will not stall. After awhile, it seems to be working fine. in MN we have been in a subzero freeze for most of the winter...

But I find it crazy that it only does this every once and awhile, when it is a COMPLETE stop
__________________

JOSH
2011 RAM 1500 5.7 HEMI
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:59 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum