DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2012 Dodge Ram Forum


Notices

2012 Dodge Ram Forum For specific discussion of the 2012 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #111  
Old 07-04-2012, 11:32 AM
Arth's Avatar
Arth Arth is offline
Dodge Ram Forum Member


 
Join Date: Jan 2012
Location: North Carolina
Posts: 3,114
Gender: Male
Vehicle: 2013 Ram 1500 Crew Cab 4x4
Trim Level: Laramie
Color: Mineral Gray Metallic
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 8
Rep:2008
Arth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond repute
Default

I don't mean to be an as* but make sure you actually do have your headlights on auto, just gotta mention it because it has happened. However if you feel it's a problem take it to your dealer. 60 miles means warranty and this is a very easy fix. They will have to replace the sensor, or little bubble towards the window on your dash.

As far as trash? Just get on youtube and listen to some 2012 Hemi engines and decide for yourself. As long as nothing is wrong and it is performing like it should I think you just aren't used to the Hemi engine is all.

Quote:
Originally Posted by sccole View Post
Hello, I have a 2012 Ram with 60 miles and the auto headlights don't work at all. Also motor 5.7 Hemi sounds like a thrash machine. Is this normal for the engine. This is my first Dodge and not for sure about it.
__________________

Chrome... in moderation.
Reply With Quote
Sponsored links
  #112  
Old 07-04-2012, 11:57 AM
sccole's Avatar
sccole sccole is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: wv
Posts: 2
Gender: Male
Vehicle: 2012 dodge ram 1500
Color: fire red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
sccole is on a distinguished road
Default

Yes it is on auto. I have a app. at the dealer to get checked. I happen to be ASE master tech and GM master certified and Duramax diesel master certified. Just have never had a Hemi before. Been wrenching for 24 years. Was just curios if this was a common issue with a Dodge. Thanks for the info
Reply With Quote
  #113  
Old 07-04-2012, 12:09 PM
skinnysfd's Avatar
skinnysfd skinnysfd is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: nw iowa
Age: 34
Posts: 319
Gender: Male
Vehicle: 2012 dodge ram 2500
Trim Level: big horn
Color: black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:53
skinnysfd will become famous soon enough
Default

I have right at about 14,000 on my 2012. though i have only had it about 4-5 months i love every minute of it. Pulls great and im towing alot with it . Love the HEMI and i guess my only complaint would be the smile on my face all the time when i jump into it .
__________________
2012 RAM 2500 HEMI AFE CAI flowmaster dual exhaust,airlift 5000 bags w/onboard compressor,shaved tailgate,2.5" lift/level tuftruck front springs,bushwacker pocket flares,gear alloy wheels, goodyear duratracs 315/70/17,bd gt hemiplus tuner much more coming
04.5,2006 5.9l cummins
Reply With Quote
  #114  
Old 07-12-2012, 07:44 PM
Triton189 Triton189 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Troy,OH
Age: 46
Posts: 77
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Big Horn
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Triton189 is on a distinguished road
Default

Quote:
Originally Posted by skooter125 View Post
Just got my truck yesterday, Only problem was the LineX guys scratching the bed. The dealer is going to fix it. Traded my 09 silverado off cause GM couldn't figure out the oil burning problem with the AFM.
I hear ya on the GM! Got rid of my "07" Avalanche because of the oil consumption issue. I did not realize it was hitting late model GM's as the 07 was the first year foor variable cylinder engine.
Reply With Quote
  #115  
Old 07-29-2012, 11:51 PM
jacksonsnorth's Avatar
jacksonsnorth jacksonsnorth is offline
Dodge Ram Forum Member
 
Join Date: Feb 2012
Location: Maine
Age: 54
Posts: 1,297
Gender: Male
Vehicle: 2012 Dodge Ram 1500 QC 4wd
Trim Level: Express
Color: Deep Cherry Red Crystal Pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:69
jacksonsnorth will become famous soon enough
Default

Quote:
Originally Posted by Raven 4x4 View Post
Hello All,
Our Laramie has under 7K and electrical problems started approx. 2K ago. Sometimes (About 15 times so far) when you try to start her up it does nothing, all of the lights and gauges and so forth illuminate as normal but no reaction click etc. from the starter. After setting for a bit and a few tries it has cranked and not left us stranded. Same problem using either of two keys we have.

I thought maybe a loose connection or something may be the cause. We took it back to the dealer, they had a few day's. The service order describes the problem as "6678 Interm Open Starter Circuit 08890102, .3 Tested, Replaced, And Configured TIPN Module". I felt all along that it was a relay issue of some sort.

Well it happened again yesterday and the wife needless to say was pissed, it's her daily driver, I drive my 2002 Z-71. We called the dealer and told them about the recurring problem, we wanted to have a comporable truck loaned for the weekend since we already had RV reservations and some much needed surf fishing/beach therapy in our future. We had already spent $70 on a rental from the first time and wanted a free loaner. Of course nobody could confirm or deny the free loaner.....

The dealer called back this morning and wants to give us another truck, yes, replace the truck, so this must be a fairly serious problem and possibly a fire hazard. I sure don't feel safe parking the truck in the garage. I'll keep you posted. FYI the service mgr. had said they had one other truck with the same problem but they have not had it happen again after the "repair" like we did.

I'll end this post by stating that our 2008 Lone Star 2x4 never had a single problem.
This is the exact thing plaguing my truck.
__________________
The Rammin' Fool from Maine
Stubby Antenna, Bed Net, Toyo Open Country tires, Bilstein 5100 Ride Height adjustable set at 2.1 ..Tow Hooks in house ready for install. More to come!
Reply With Quote
  #116  
Old 07-29-2012, 11:59 PM
Maelstrom1976 Maelstrom1976 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2012
Location: Killeen, Tx
Posts: 6
Gender: Male
Vehicle: 2011 Dodge Ram 1500 Laramie
Trim Level: Laramie
Color: Garnet and Gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Maelstrom1976 is on a distinguished road
Default

Quote:
Originally Posted by rcgreg View Post
Nada on mine - but whats the 'Hill start assist" all about?

The "Hill Start Assist" is when you are on an incline, or decline, the truck will remain motionless when you transition your foot from the brake to the throttle.

If it is turned off, the truck will creep forward on minor inclines and on steep declines, it will roll back slightly. The hill start assist will prevent the truck from moving while on hills. Probably works great for people that live in San Fransisco.
Reply With Quote
  #117  
Old 07-30-2012, 09:54 PM
dxii dxii is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: Minneapolis
Posts: 1
Gender: Male
Vehicle: 2012 Ram 1500
Trim Level: Big Horn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dxii is on a distinguished road
Default

I just picked up a 2012 Big Horn CC 4x4 on Friday. Only problem so far is that I got rear-ended yesterday. 250 miles on the truck.
Reply With Quote
  #118  
Old 07-31-2012, 09:50 AM
jacksonsnorth's Avatar
jacksonsnorth jacksonsnorth is offline
Dodge Ram Forum Member
 
Join Date: Feb 2012
Location: Maine
Age: 54
Posts: 1,297
Gender: Male
Vehicle: 2012 Dodge Ram 1500 QC 4wd
Trim Level: Express
Color: Deep Cherry Red Crystal Pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:69
jacksonsnorth will become famous soon enough
Default

So I spoke with my Service manager and he tells me he had a long conversation with the engineer rep at Chrysler last night before he left the shop. It seems they both believe that my issue is the TIPM. They are flying one in for my truck and it will be here at noon today. They will have it for 2 hours or so and they assure me, they believe this is my problem. I stressed to him that I will give them this last opportunity to fix this issue, (try number 5), and if it does not work they will be sending it back to Chrysler and I expect a replacement.
Do yo think I am being fair?
I think I have bent over backwards to get this issue fixed and work with them. (Especially considering the homemade wires an lights etc, and driving around doing their diagnostics on a rolling computer diagnostic center that does not work)
Keep your fingers crossed and wish me luck, I really hope for my sake, and others with this issue, that this is the fix.
__________________
The Rammin' Fool from Maine
Stubby Antenna, Bed Net, Toyo Open Country tires, Bilstein 5100 Ride Height adjustable set at 2.1 ..Tow Hooks in house ready for install. More to come!
Reply With Quote
  #119  
Old 07-31-2012, 11:02 PM
jacksonsnorth's Avatar
jacksonsnorth jacksonsnorth is offline
Dodge Ram Forum Member
 
Join Date: Feb 2012
Location: Maine
Age: 54
Posts: 1,297
Gender: Male
Vehicle: 2012 Dodge Ram 1500 QC 4wd
Trim Level: Express
Color: Deep Cherry Red Crystal Pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:69
jacksonsnorth will become famous soon enough
Default Update on starting issue

Hey Raven4x4 they said my truck is fixed if so I will let you know for sure. I will be back from camp on the 8th or 9th. I pick it up tomorrow. Pasting in the post form my thread for ya.


Dealer says my truck is done and gtg. They replaced the TIPM an did a start on it off and on all day to the tune of about 60 times. Service Manager took it home tonight with him, he lives 40 miles or so from Dealership, and is confident it is fixed but wanted to make sure. I will be happy if my truck is good as new. Then it is time to hit Chrysler and my Dealership for some comp stuff for all the down time and aggravation. Thinking of something that is not unreasonable for 16 days downtime, plus days sitting in my driveway that they were closed and I needed it in, and also the 5 times it had to be worked on for 1 issue. I dont think it will be a hat this time.
I am thinking some new Bilsteins installed on front, along with a front end alignment, and install my tow hooks I have already bought. I dont think thats unreasonable do you? I could have gone the Lemon Law route already but i worked with them to get it fixed.( this is of course if my truck is def fixed) Any serious ideas? lol Thanks guys for the support so far on this issue. It is much appreciated.
__________________
The Rammin' Fool from Maine
Stubby Antenna, Bed Net, Toyo Open Country tires, Bilstein 5100 Ride Height adjustable set at 2.1 ..Tow Hooks in house ready for install. More to come!
Reply With Quote
  #120  
Old 08-04-2012, 12:09 AM
Wheels1 Wheels1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: Oregon
Age: 59
Posts: 15
Gender: Male
Vehicle: 2012 Limited 1500 Crew
Trim Level: Larramie Limted M25
Color: Black Clear Coat
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Wheels1 is on a distinguished road
Default

I got mine last Saturday, Waxed it on Sunday, found some paint issues
One on the passage door a dent from the inside out
small dent on hood, had some padding coming out the Upgrade Leather seats Look like they made the hole to big, molding strip not install right, have some hard stuff on the running board. Also mist the scraps on the mirrors arms, I'm dropping the truck back off on Monday
With a 100 miles on it, they are giving me a car to drive well they get her fixed, I hope it comes out nice
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:41 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum