DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 3rd Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-09-2011, 10:18 PM
hubble hubble is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Posts: 1
Gender: Male
Vehicle: 2006 dodge ram 2500
Color: blue
Engine: 2005-???? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:10
hubble is on a distinguished road
Default heating problem need help

I need your help. I have a 2006 2500 Ram and having trouble with my cummings. We are located in nebraska and its cold. My pickup will not heat up but going down the road it may go up to 190 then down to 140 then when i stop its below that. I had a new theromstate and clutch fan put on it and it didnt help . Also my tach is reading almost nothing at idle..Could this be my ecm, does it need to be flashed.

It is cold ....and could use your help.
Reply With Quote
Sponsored links
  #2  
Old 12-09-2011, 10:37 PM
erm
Guest
 
Posts: n/a
Default

First of all, Welcome To The Forum!

Secondly, only one thread is needed for this subject. I moved your first one to the proper section. Then I deleted the second one you just posted.

Lastly, I don't think the tach reading has any bearing on your heat problem. I believe you have a heater core problem. It may be plugged and not letting the heat transfer to complete the cycle.

The puzzling thing is the weird fluctuation in temp while in motion. I would think that it would rise when you come to a stop or are at idle, then lower as you move down the road, moving more air through the radiator.

How new is your coolant? And have you had the system flushed recently?
Reply With Quote
  #3  
Old 12-18-2011, 01:15 PM
THK THK is offline
Dodge Ram Forum Member

 
Join Date: Jun 2011
Location: Out West
Posts: 65
Gender: Male
Vehicle: 02 Dodge Ram
Trim Level: ST
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
THK is on a distinguished road
Default

I just went through this situation about 2 weeks ago. Being fat, dumb, and happy and with the temperatures on the cold side, I have not checked my fluids lately. About a week ago, I noticed the heater was not producing heat as it normally does. I did notice that the heat output would change with engine rpm. The higher the rpm the more heat. I made a mental note to check the fluids. by the way, mine is a gasser.

On the way home, I noticed a sweet sicking smell, anti-freeze. Ah crap. Hoping it was not the heater core, I got home and started to look for the cause the violated my senses. Interior cab nor wet, no moisture from the vents. Opened the hood and said yes.

Water pump, no. Hoses, no. Coolant reserve tank, low. looked under the vehicle, wet. Radiator side tank gasket went south.

New radiator purchased, flushed the heater core, and 2 hours later, back in business.

Flush the heater core and look for leaks.
Reply With Quote
  #4  
Old 12-18-2011, 08:52 PM
DadzDodge DadzDodge is offline
Dodge Ram Forum Junior Member
 
Join Date: Aug 2011
Location: Kentucky
Posts: 47
Gender: Male
Vehicle: 1996 Dodge Ram
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:37
DadzDodge is on a distinguished road
Default

hubble - there's a chance you have air in the cooling hoses, which would cause the problems you've described. I just changed the heater core and heater hoses in our '96 and to get the air out I would leave the radiator cap loose, start the engine and let it run until the thermostat is open, and then squeeze the bottom hose (being sure to stay clear of the fan). I then tighten the cap and squeeze the hose again.

With the engine fully warmed up and running, have you squeezed the two hoses going to and from the heater core? They should both be very hot, and be at about the same temperature.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:52 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum