Blower motor not working - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 4th Gen Dodge Ram Heating & Cooling Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 01-08-2018, 07:37 PM
progenius1 progenius1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2017
Location: Lampasas TX
Age: 53
Posts: 1
Gender: Male
Vehicle: 2016 Dodge Ram 1500
Trim Level: Big Horn
Color: Black Metalic
Engine: 2014-20?? 182ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 0
Rep:10
progenius1 is on a distinguished road
Default Blower motor not working

2016 Ram 1500 Quad cab Ecodeisel. Blower does nor come on at all?? Worked yeesterday, but went out today to make my 1.5 hour trek to work, fan motor will not turn on. When i flip to the climate screen, everything is working properly. just no fan motor??
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-08-2018, 11:59 PM
ColdCanuck's Avatar
ColdCanuck ColdCanuck is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2018
Location: Great White North
Posts: 101
Gender: Male
Vehicle: 09 Dodge 1500
Trim Level: SLT
Color: Mineral Grey
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
ColdCanuck is on a distinguished road
Default

Check the electrical connector to the blower - it's under the dash below the glove box. It's exposed - you don't have to remove anything. Fidgety passengers have been known to damage the connector.
Reply With Quote
  #3  
Old 01-09-2018, 09:15 AM
ramcares's Avatar
ramcares ramcares is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2016
Location: Michigan
Posts: 1,241
Gender: Female
Vehicle: n/a
Trim Level: n/a
Color: n/a
Rep Power: 4
Rep:84
ramcares will become famous soon enough
Default

Quote:
Originally Posted by progenius1 View Post
2016 Ram 1500 Quad cab Ecodeisel. Blower does nor come on at all?? Worked yeesterday, but went out today to make my 1.5 hour trek to work, fan motor will not turn on. When i flip to the climate screen, everything is working properly. just no fan motor??
Hi progenius1,

Sorry to hear about this! If you end up deciding to visit a certified dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Ram Social Care Specialist
Reply With Quote
 
  #4  
Old 04-04-2019, 03:23 PM
oneurt oneurt is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Age: 34
Posts: 2
Gender: Male
Vehicle: 2013 Dodge Ram
Rep Power: 0
Rep:10
oneurt is on a distinguished road
Default

I'm having the same issue, where randomly the motor will not work at all. I have replaced the blower motor and that did not fix the problem. We have taken it to the dealership and they couldn't find anything at the time since it was working. But no less than 24 hours later it goes out again.
has anyone had a similar issue? I have searched and I know possibly on the older models the failure is at the ignition switch is this the same issue with my 2013 Ram 1500 sport?

It does not have the push button start.
Reply With Quote
  #5  
Old 04-05-2019, 04:06 AM
ColdCanuck's Avatar
ColdCanuck ColdCanuck is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2018
Location: Great White North
Posts: 101
Gender: Male
Vehicle: 09 Dodge 1500
Trim Level: SLT
Color: Mineral Grey
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
ColdCanuck is on a distinguished road
Default

Quote:
Originally Posted by oneurt View Post
I'm having the same issue, where randomly the motor will not work at all. I have replaced the blower motor and that did not fix the problem. We have taken it to the dealership and they couldn't find anything at the time since it was working. But no less than 24 hours later it goes out again. Has anyone had a similar issue? I have searched and I know possibly on the older models the failure is at the ignition switch is this the same issue with my 2013 Ram 1500 sport?

You're equipped with auto HVAC or the manual setup? The auto setup is sweet but the controllers can get funky after a few or four yrs. The manual equipment tends to be more reliable. I don't suspect the ignition switch is a factor cuz you'd be having other issues too.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:35 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors