Heater issue 2013 ram 2500 - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 4th Gen Dodge Ram Heating & Cooling Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 10-09-2018, 02:00 PM
jesse4681 jesse4681 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2018
Posts: 3
Rep Power: 0
Rep:10
jesse4681 is on a distinguished road
Default

I am getting heat on the passenger side and cold air on driver side. I crank up fan and it is not blowing very hard either. I have flushed heater core, checked actuator to make sure blender doors are operating and still nothing. I am running out of things to research. Hoping someone can help.

Thank you
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-27-2018, 08:48 AM
Jam516's Avatar
Jam516 Jam516 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2018
Location: South Vienna Ohio
Age: 44
Posts: 5
Gender: Male
Vehicle: 2013 2500
Trim Level: Tradesman
Color: Black gold
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
Jam516 is on a distinguished road
Default

I have not looked into my issue yet but my cab isnt warming up. I figured I would start with the forum and see if anyone had any issues. It sounds like a blend door if you have it on one side but not the other. Do you have zone heating?
Reply With Quote
  #3  
Old 10-31-2018, 01:04 PM
jesse4681 jesse4681 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2018
Posts: 3
Rep Power: 0
Rep:10
jesse4681 is on a distinguished road
Default

I ended up taking my pickup in to Dodge dealership. It was my heater core, it was plugged up along with evaporator core as well. Total cost was about $1600. They had to flush coolant as well because there was a mix of 2 different coolants. Luckily i had a warranty and they paid $1400 of it.
Reply With Quote
 
  #4  
Old 10-31-2018, 07:38 PM
Tred's Avatar
Tred Tred is offline
Super Moderator



 
Join Date: Sep 2017
Location: Kansas City, Kansas
Age: 63
Posts: 4,949
Gender: Male
Vehicle: 2019 Ram Big Horn Sport QC 4x4
Trim Level: Level 1 W/Tow Pkg
Color: Blue Streak Pearl Coat
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 4
Rep:125
Tred will become famous soon enoughTred will become famous soon enough
Default

Glad you go tit fixed, thanks for letting us know.
__________________
U.S.Navy - Ret.
The needs of the many are being forsaken for the wants of a few...


Starting over!
RetraxONE MX Tonneau Cover - Line-X Bed Liner - Tinted Windows - MOPAR Window Vent/Visors - MOPAR Bug Shield - Husky Mud Flaps - Stake Pocket Covers (Rear)
R.I.P. 2017 Ram SLT Big Horn QC 4x4 (Totaled - 01/24/19)
Reply With Quote
  #5  
Old 11-27-2018, 10:11 AM
ajpillz ajpillz is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2018
Location: Des Moines IA
Posts: 12
Gender: Male
Vehicle: 2013 Ram
Trim Level: Ext. Cab Express
Color: Black
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
ajpillz is on a distinguished road
Default

I'm about to travel down the same road I'm afraid - mine inst going to be covered by the warranty though.

Same issue. Luke warm heat on passenger side and barley warm / cool air on the driver side. I can adjust all of the vents and it works fine.

If I turn the temp down the air speed picks up. If I turn the temp up the air speed slows down.

That is the only thing I find weird about mine other than heat only coming out of one side.
Reply With Quote
  #6  
Old 01-15-2019, 03:18 PM
ajpillz ajpillz is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2018
Location: Des Moines IA
Posts: 12
Gender: Male
Vehicle: 2013 Ram
Trim Level: Ext. Cab Express
Color: Black
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
ajpillz is on a distinguished road
Default

Follow up: The Core was plugged and the AC evaporator had a ton of build up on the lower side because the previous owner didn't do the cabin vent mod. Cleaned it and it blows consistent and very hot. Replacing the Core and Cleaning the Evaporator fixed all issues.
Attached Images
File Type: jpg 12.jpg (128.3 KB, 0 views)
File Type: jpg 15.jpg (129.7 KB, 0 views)
File Type: jpg 13.jpg (134.2 KB, 0 views)
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 12:54 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors