2010 Ram Factory Trailer Brake Controller Install - Page 35 - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > Dodge Ram Knowledge Base


Dodge Ram Knowledge Base Here you can find owner submitted how-to's for performing various mods to your Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #341  
Old 02-03-2017, 11:10 AM
svanarts's Avatar
svanarts svanarts is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2016
Location: California
Posts: 11
Gender: Male
Vehicle: 2012 Ram 1500 ST
Trim Level: Tradesman
Color: White
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
svanarts is on a distinguished road
Default

Quote:
Originally Posted by quikduk View Post
I have the correct Yazaki connector and will make up the harness and try it in a 2012 screw.

How critical is the wire gauge? I have similar colored and sized wires I got out of a dodge truck at a bone yard and was going to try them.

I'll let you know how it works out.
I'd be interested in hearing how it works out. I just have my wires going to female connectors and pushed onto the pins. It's a tight fit and the wires are pretty secure since I taped them real good. Would be nice to get the right connector though.
Reply With Quote
Sponsored Links
Advertisement
 
  #342  
Old 04-19-2019, 10:35 PM
Johnboy72 Johnboy72 is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2016
Location: Fort Leonard Wood
Age: 41
Posts: 77
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT
Color: Light Graystone Pearl
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Johnboy72 is on a distinguished road
Default

Is there anyway to test the module? I have a 2010 SLT CC. Previous owner must’ve had an aftermarket brake controller judging by the screw holes in the knee boaster and the second plug wired in. I picked up an ITBC from another 2010 1500. I have had it installed for a minute but now trying to test it out because no power to the rear trailer plug. Dealer says they have to flash it to install the tow package. I don’t have an EVIC and could care less. I don’t feel like paying $85 for a dealer flash when this thread basically states I don’t need it. So I’m going to recheck all the wiring but any way to check the actual module???
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 03:13 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors